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Release Notes
The release notes provide product improvements and various bug fixes.

VMware Fusion 13.6.3 Release Notes
This document contains the following sections

• Introduction
• About VMware Fusion
• System Requirements
• What's New
• Prior Releases
• Known Issues

Introduction

VMware Fusion 13.6.3 | 4 MAR 2025 | Build 24585314
Check for additions and updates to these release notes.

About VMware Fusion

VMware Fusion® is the easiest, fastest, and most reliable way to run Windows and other x86/ARM based operating
systems on a Mac without rebooting. You can download VMware Fusion 13.6.3 from here.

For more information, see the broader VMware Fusion documentation.

System Requirements

• Hardware
Intel or Apple Silicon Mac models.
– Mac models that support macOS 13 Ventura or later.

• Software
– macOS 13 Ventura
– macOS 14 Sonoma
– macOS 15 Sequoia

What's New

• The 13.6.3 release resolves CVE-2025-22226. For more information on this vulnerability and its impact on Broadcom
products, see VMSA-2025-0004.

• VMware Fusion no longer requires a license key and is now free for commercial, educational, and personal use.
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Prior Releases

Features and Known Issues from prior releases of VMware Fusion 13 are described in the release notes for each release.
To view the release notes for a prior release, click the appropriate link:

• VMware Fusion 13.6.2 Release Notes

• VMware Fusion 13.6.1 Release Notes

• VMware Fusion 13.6 Release Notes

Known Issues

The Default Applications feature is not available in VMware Fusion because of the removal of Unity mode

Unity mode has been removed in VMware Fusion 13.6. The Default Applications feature is closely integrated with Unity
mode and therefore also is no longer available.

Workaround: None.

Unable to install VMware Tools on macOS 15 Sequoia host operating system

The Install VMware Tools button is grayed out on a device that uses macOS 15 Sequoia operating system.

Workaround: Download VMware Tools from https://packages-prod.broadcom.com/tools/frozen/darwin/darwin.iso and
execute the installation steps in https://knowledge.broadcom.com/external/article?legacyId=1014294.

vctl pull command is failing on Sonoma 14.5 and later

If you attempt to pull an image by using the vctl pull command, it fails with a "hdiutil: mount failed - Permission denied"
error on macOS Sonoma 14.5 and later Host Operating Systems.

Workaround: None

The multi-monitor feature might not work correctly in specific topologies

In specific situations, based on different hardware and topologies, the multi-monitor feature does not work as expected.
You might see issues like reverting the topology to a single screen, or not cycling through monitors.

Workaround: None.

VMware Fusion 13.6.2 Release Notes
This document contains the following sections

• Introduction
• About VMware Fusion
• System Requirements
• What's New
• Prior Releases
• Known Issues

Introduction

VMware Fusion 13.6.2 | 17 DEC 2024 | Build 24409261
Check for additions and updates to these release notes.
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About VMware Fusion

VMware Fusion® is the easiest, fastest, and most reliable way to run Windows and other x86/ARM based operating
systems on a Mac without rebooting. You can download VMware Fusion 13.6.2 from here.

For more information, see the broader VMware Fusion documentation.

System Requirements

• Hardware
Intel or Apple Silicon Mac models.
– Mac models that support macOS 13 Ventura or later.

• Software
– macOS 13 Ventura
– macOS 14 Sonoma
– macOS 15 Sequoia

What's New

• Free Licensing Model

VMware Fusion no longer requires a license key and is now free for commercial, educational, and personal use.

Prior Releases

Features and Known Issues from prior releases of VMware Fusion 13 are described in the release notes for each release.
To view the release notes for a prior release, click the appropriate link:

• VMware Fusion 13.6.1 Release Notes
• VMware Fusion 13.6 Release Notes

Known Issues

The Default Applications feature is not available in VMware Fusion because of the removal of Unity mode

Unity mode has been removed in VMware Fusion 13.6. The Default Applications feature is closely integrated with Unity
mode and therefore also is no longer available.

Workaround: None.

Unable to install VMware Tools on macOS 15 Sequoia host operating system

The Install VMware Tools button is grayed out on a device that uses macOS 15 Sequoia operating system.

Workaround: Download VMware Tools from https://packages-prod.broadcom.com/tools/frozen/darwin/darwin.iso and
execute the installation steps in https://knowledge.broadcom.com/external/article?legacyId=1014294.

vctl pull command is failing on Sonoma 14.5 and later

If you attempt to pull an image by using the vctl pull command, it fails with a "hdiutil: mount failed - Permission denied"
error on macOS Sonoma 14.5 and later Host Operating Systems.

Workaround: None

The multi-monitor feature might not work correctly in specific topologies

In specific situations, based on different hardware and topologies, the multi-monitor feature does not work as expected.
You might see issues like reverting the topology to a single screen, or not cycling through monitors.

Workaround: None.
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VMware Fusion 13.6.1 Release Notes
This document contains the following sections

• Introduction
• About VMware Fusion
• System Requirements
• What's New
• Prior Releases
• Known Issues
• Resolved Issues

Introduction

VMware Fusion 13.6.1 | 10 OCT 2024 | Build 24319021
Check for additions and updates to these release notes.

About VMware Fusion

VMware Fusion® is the easiest, fastest, and most reliable way to run Windows and other x86/ARM based operating
systems on a Mac without rebooting. You can download VMware Fusion 13.6.1 from here.

For more information, see the broader VMware Fusion documentation.

System Requirements

• Hardware
Intel or Apple Silicon Mac models.
– Mac models that support macOS 13 Ventura or later.

• Software
– macOS 13 Ventura
– macOS 14 Sonoma
– macOS 15 Sequoia

What's New

VMware Fusion 13.6.1 provides various bug fixes requested by customers.

Prior Releases

Features and Known Issues from prior releases of VMware Fusion 13 are described in the release notes for each release.
To view the release notes for a prior release, click the appropriate link:

•  VMware Fusion 13.6
• VMware Fusion 13.5.2
• VMware Fusion 13.5.1
• VMware Fusion 13.5
• VMware Fusion 13.0.2
• VMware Fusion 13.0.1

Known Issues
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Unable to install VMware Tools on macOS 15 Sequoia host operating system

The Install VMware Tools button is grayed out on a device that uses macOS 15 Sequoia operating system.

Workaround: Download VMware Tools from https://packages-prod.broadcom.com/tools/frozen/darwin/darwin.iso and
execute the installation steps in https://knowledge.broadcom.com/external/article?legacyId=1014294.

vctl pull command is failing on Sonoma 14.5 and later

If you attempt to pull an image by using the vctl pull command, it fails with a "hdiutil: mount failed - Permission denied"
error on macOS Sonoma 14.5 and later Host Operating Systems.

Workaround: None

The multi-monitor feature might not work correctly in specific topologies

In specific situations, based on different hardware and topologies, the multi-monitor feature does not work as expected.
You might see issues like reverting the topology to a single screen, or not cycling through monitors.

Workaround: None.

Resolved Issues

Installing a Windows 11 arm 24H2 virtual machine fails with a blank screen

Installing a Windows 11 arm 24H2 virtual machine through the Get Windows from Microsoft option fails with a blank
screen. The issue occurred because of a problem loading a VMware svga video driver included in the ISO file created
during the installation of a guest virtual machine. To configure a VMware svga video driver after the guest operating
system installation, make sure to install VMware Tools. 

When creating a new virtual machine from an ISO image file, VMware Fusion does not recognize Windows 11
24H2

If you create a virtual machine from a Windows 11 24H2 ISO image file, VMware Fusion recognizes a Windows Server
2025 iso file instead.

Importing a Boot Camp partition or creating a virtual machine based on a Boot Camp partition might fail with
virtual disk is corrupt error

If you try importing a Boot Camp partition on your disk or creating a virtual machine based on the Boot Camp partition,
you might encounter the the virtual disk is corrupt error. The issue occurs when you try converting a 4KN disk with 4096
bytes in sector size with a Boot Camp partition to a virtual disk.

Virtual machine created on a VoiceOver enabled Mac shuts down randomly on macOS versions 14 and later

If you enable VoiceOver on a macOS host version 14 and later and attempt to power on the virtual machine, the virtual
machine randomly shuts down. In the console, you receive the The application with bundle ID com.vmware.vmware-
vmx is running setugid(), which is not allowed. Exiting. error message. After upgrading to macOS version Sonoma
14.7 and macOS version Sequoia 15.0, the issue no longer occurs.

VMware Fusion 13.6 Release Notes
This document contains the following sections

• Introduction
• What's in the Release Notes
• About VMware Fusion
• System Requirements
• What's New
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• Product Support Notices
• Prior Releases
• Known Issues
• Resolved Issues

Introduction

VMware Fusion 13.6 | 03 SEP 2024 | Build 24238079
Check for additions and updates to these release notes.

What's in the Release Notes

• About VMware Fusion
• System Requirements
• Prior Releases
• Known Issues
• Resolved Issues

About VMware Fusion

VMware Fusion® is the easiest, fastest, and most reliable way to run Windows and other x86/ARM based operating
systems on a Mac without rebooting.

For more information, see the broader VMware Fusion documentation.

System Requirements

• Hardware
Intel or Apple Silicon Mac models.
– Mac models that support macOS 13 Ventura or later.

• Software
– macOS 13 Ventura
– macOS 14 Sonoma

What's New

Introducing vmcli

vmcli is a command-line tool included with VMware Fusion, enabling users to interact with the hypervisor directly from
a Linux or macOS terminal, or the Windows command prompt. With vmcli, you can perform a variety of operations such
as creating new virtual machines, generating VM templates, powering on VMs, and modifying various VM settings.
Additionally, you can also create scripts to run multiple commands sequentially. For more information, see Using VMware
Fusion.

New Guest Operating System Support

On Intel Chipset

• macOS Sequoia
• Windows Server 2025
• Windows 11 Version 23H2
• Ubuntu 24.04
• Fedora 40
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On Apple Silicon

• Windows 11 Version 23H2
• Ubuntu 24.04
• Fedora 40

New Host Operating System Support

On Intel Chipset

• macOS Sequoia

On Apple Silicon

• macOS Sequoia

Security enhancements

This release resolves CVE-2024-38811. For more information on this vulnerability and its impact on VMware products,
see VMSA-2024-0018.

Product Support Notices

• Legacy VMTools ISOs are no longer included by default but are available for download.
• Bluetooth hub passthrough support has reached its end of life and has been removed from VMware Fusion.
• Unity mode has reached its end of life and has been removed from VMware Fusion.
• Fusion Application Menu has reached its end of life and has been removed from VMware Fusion.

Prior Releases

Features and Known Issues from prior releases of VMware Fusion 13 are described in the release notes for each release.
To view the release notes for a prior release, click the appropriate link:

• VMware Fusion 13.5.2
• VMware Fusion 13.5.1
• VMware Fusion 13.5
• VMware Fusion 13.0.2
• VMware Fusion 13.0.1

Known Issues

When voiceover is turned on, the VM shuts down abruptly on macOS 14 and later

If you enable voiceover on a macOS 14 host and later and attempt to power on the virtual machine, the VM abruptly shuts
down. In the console, you receive "The application with bundle ID com.vmware.vmware-vmx is running setugid(), which is
not allowed. Exiting." error message.

Workaround: None

vctl pull command is failing on Sonoma 14.5 and later

If you attempt to pull an image by using the vctl pull command, it fails with a "hdiutil: mount failed - Permission denied"
error on macOS Sonoma 14.5 and later Host Operating Systems.

Workaround: None

The multi-monitor feature might not work correctly in specific topologies

In specific situations, based on different hardware and topologies, the multi-monitor feature does not work as expected.
You might see issues like reverting the topology to a single screen, or not cycling through monitors.
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Workaround: None.

Resolved Issues

Fusion UI crashes when Connect to SSH is attempted

When SSH is configured for Linux GOS, then "Connect to SSH" results in a Fusion UI crash.

This issue is resolved.

Screen misalignment in Windows 11 VM

A screen misalignment might occur for virtual camera devices on Apple Silicon due to the usage of wrong Apple APIs for
capturing video frames.

This issue is resolved.

Security Issues

OpenSSL has been updated to 3.0.14

 16



 VMware Fusion Pro 13

Using VMware Fusion
Using VMware Fusion describes how to use VMware Fusion® to create, use, and manage virtual machines. It also
describes how to install, configure, upgrade, and uninstall Fusion.

Intended Audience

This information is intended for anyone who wants to install, upgrade, or use Fusion.

Additional Resources

To view or ask questions about VMware Fusion, visit the VMware Fusion Community.

Getting Started with Fusion
With Fusion, you can run personal computer (PC) applications and devices on all supported Mac.

Designed for the Mac user, Fusion takes advantage of the security, flexibility, and portability of virtual machines to run
Windows and other operating systems at the same time as macOS.

Basics About VMware Fusion
Take a quick look at what Fusion does and how it works.

What Fusion Does

Fusion enables you to run your Windows applications and PC-only devices on all supported Mac. You can run multiple
operating systems and applications at the same time, along with your Mac applications. The operating systems and
applications are isolated in secure virtual machines.

How Fusion Works

Fusion maps the physical hardware resources to the virtual machine’s resources, so each virtual machine has its own
processor, memory, disks, I/O devices and so on. Each virtual machine is the full equivalent of a standard x86/ARM
computer, although it is represented in a single file package on the Mac.

After you install Fusion and create a virtual machine, you can install and run complete, unmodified operating systems, and
associated application software in the virtual machine, just as on a physical PC. Operating systems you can use include
Windows, Linux, and macOS. Fusion offers the benefits of having a second PC without its added expense, physical setup,
and maintenance.

The operating system of the computer on which you run Fusion is called the host. Mac OS X, Mac OS X Server, OS X,
and macOS are the only hosts supported for Fusion. The virtualized operating system you run inside Fusion is called the
guest.

About VMware Fusion Pro
Fusion Pro provides advanced virtualization features for managing the virtual machines on your Mac.

Fusion Pro provides the following virtualization features:

• Clone a virtual machine
• Ability to power on a virtual machine to firmware
• Export a virtual machine to OVF format
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• Set a keyboard shortcut for a virtual machine
• Create advanced custom networking configurations
• Connect to a remote server
• Obtain information from the Virtual Machine Library window, such as processor, memory, network, and disk information

for a virtual machine
• Set bandwidth, packet loss, and latency for a virtual network adapter to simulate various network environments
• Set the firmware type
• Enable UEFI Secure Boot
• Enable VBS (virtualization-based security) for a Windows 10 and later virtual machine
• Use Rest API

System Requirements for Fusion
Verify that you have the minimum system requirements for installing and using Fusion.

Fusion 12.1.2 and earlier

• The following processors are supported.
– Processors on all Macs launched in 2011 or later except for the Intel® Xeon® W3565 processor when used on the

2012 Mac Pro Quad Core
– Processors on 2010 Mac Pro Six Core, Eight Core, and Twelve Core

• The following Metal host graphics rendering engine requirements apply.
– Hardware Requirements

• MacBook, Early 2015 or later
• MacBook Air, Mid 2012 or later
• MacBook Pro, Mid 2012 or later
• Mac Mini, Late 2012 or later
• iMac, Late 2012 or later
• Mac Pro, Late 2013 or later

See https://support.apple.com/en-us/HT205073 for information about Mac support of Metal.
– Software Requirements

• macOS 10.12.5 or later
• macOS 10.15 Catalina and newer versions for the host OS.
• Operating system installation media (disk or disk image) for virtual machines. Windows operating systems are

available separately from Microsoft and other retailers.
IMPORTANT
Fusion does not provide any operating systems for installation on virtual machines that you create with
Fusion. You must provide the operating system installation media.

• 4 GB of memory, 8 GB recommended.
• 750 MB of free disk space for Fusion, and at least 5 GB of free disk space for each virtual machine.

NOTE
You must have enough memory to run macOS, plus the memory required for each guest operating system
and for applications on the Mac and in the virtual machines.
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Fusion 12.2.0 and later

• Any Intel-based Mac that officially supports macOS 11 Big Sur or later.
• Minimum 8 GB of memory. 16 GB or more recommended for running multiple virtual machines.
• Operating system installation media (disk or disk image) for virtual machines. Windows operating systems are

available separately from Microsoft and other retailers.
IMPORTANT
Fusion does not provide any operating systems for installation on virtual machines that you create with
Fusion. You must provide the operating system installation media.

• 750 MB of free disk space for Fusion, and at least 5 GB of free disk space for each virtual machine.
NOTE
You must have enough memory to run macOS, plus the memory required for each guest operating system
and for applications on the Mac and in the virtual machines.

Fusion 13.0.0 and later

• Any Mac that officially supports macOS 12 Monterey or later.
• Minimum 8 GB of memory. 16 GB or more recommended for running multiple virtual machines.
• Operating system installation media (disk or disk image) for virtual machines. Windows operating systems are

available separately from Microsoft and other retailers.
IMPORTANT
Fusion does not provide any operating systems for installation on virtual machines that you create with
Fusion. You must provide the operating system installation media.

• 1.5 GB of free disk space for Fusion, and at least 5 GB of free disk space for each virtual machine.
NOTE
You must have enough memory to run macOS, and in addition to that the memory required for each guest
operating system, and for applications on the Mac and in the virtual machines.

Install Fusion
Fusion 13.0 installer package is transitioned to universal binary. You install Fusion in the same way you install other
macOS applications.

• Verify that you have the administrator password for your Mac.
• Download the Fusion installer file to your Mac. You can obtain the Fusion installation file from Broadcom Support

Portal.

Installation of Fusion does not modify existing virtual machines.

1. Double-click the Fusion installer dmg file to open it.
The contents of the disk image appear in the Fusion Finder window.

2. In the Finder window, double-click the click to install Fusion icon.

3. When prompted, type your administrator user name and password.
Fusion is installed in the Applications folder on your Mac.

Start Fusion
Start using Fusion.

Verify that you have the administrator password for your Mac.

1. In the Applications folder, double-click VMware Fusion.
The Virtual Machine Library window appears. From this window, you can start working with virtual machines.
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2. Optional: To save Fusion in the Mac Dock, right-click the icon, and select Options > Keep in Dock.

Take Advantage of Fusion Online Resources
Go to the Fusion Support Center for product news, FAQs, more resources, and the online community.

You can find information about using Fusion at the following self-help sources:

• The VMware Knowledge Base provides troubleshooting information, solutions to error messages, and some best
practice information for most VMware products. To find information on a specific problem you encounter in Fusion,
select VMware Fusion in the product list and search for your problem by key word at  http://kb.vmware.com.

Understanding Fusion
Fusion harnesses virtualization to give you a powerful tool to run PC applications and devices on your Mac.

Virtual Machines and What Fusion Can Do
With Fusion, you can run virtual machines inside your Mac, which gives you access to a wide range of Windows and other
operating systems and applications.

What Is a Virtual Machine?
A virtual machine is a software computer that, like a physical computer, runs an operating system and applications.

A virtual machine typically contains a display, a hard disk or disks, one or more processors, memory, a CD/DVD drive,
a network adapter, and a USB controller. All of these components are virtualized. That is, these elements of a virtual
machine are all created by software and stored in files on your Mac.

The virtual machine runs in a window on all supported Mac. You install an operating system and applications in the virtual
machine and operate it as you would a physical computer. An operating system cannot distinguish between a virtual
machine and a physical machine, nor can applications or other computers on a network. What you can do with a physical
machine (install software, save files, add additional drives, and so on) you can do with a virtual machine.

Virtual machines are fully supported by Fusion with the underlying physical hardware. For example, you can configure a
virtual machine with virtual components that are completely different from the physical components that are present on the
underlying hardware. Virtual machines on the same physical host can run different kinds of operating systems (Windows,
Linux, macOS, and others).

Fusion Capabilities
With Fusion, you can create, open, and run VMware virtual machines, and use PC-specific hardware with a Mac.

With Fusion, you can perform the following tasks:

• Run x86 operating systems, including Windows, Linux, macOS, and others, on macOS without rebooting.
• Run ARM operating systems, including Windows, Linux, and others on macOS without rebooting.
• Run Windows and Linux applications on all supported Mac.
• Run most Windows 3D applications that require DirectX 9, DirectX 10, DirectX 10.1 or DirectX 11 on your Intel-based

Mac.
• Import virtual machines created with Parallels Desktop or virtual machines that use the OVF (Open Virtualization

Format) standard on Intel-based Mac.
• Access USB devices, such as video cameras and high-speed disks, from a virtual machine.
• Drag files between your Intel-based macOS host machine and virtual machines running other x86 operating systems.

Virtual Machine Compatibility
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Supported Guest Operating Systems
Fusion supports more than 100 guest operating systems, including most versions of Windows, Linux, Mac OS X, OS X,
and macOS.

You can also go to the VMware Web site and click the Support tab. Under Support Resources, click the Compatibility
Guides link.

Virtual Hardware Specifications
Each virtual machine has a standard virtual hardware configuration for chip set, BIOS, ports, and so on. The amount of
memory and number of processors depends on your Mac.

Processor

• One virtual processor on a host system with one or more logical processors
• Up to 32 virtual processors, depending on the available processors on your Mac, virtual machine hardware version,

and guest operating system support
• The following configurations have two logical processors:

– A multiprocessor Mac with two or more physical CPUs
– A single-processor Mac with a multicore CPU

Chip Set

• Intel 440BX-based motherboard
• NS338 SIO
• 82093AA IOAPIC
• Apple Silicon

BIOS

• PhoenixBIOS 4.0 Release 6 with VESA BIOS

Memory

• Up to 128 GB, depending on the available memory on your Mac, virtual machine hardware version, and guest
operating system support

• Total memory available for all virtual machines is limited only by the amount of memory on the Mac
NOTE
If you assign too much memory to your virtual machines and have them all running at the same time, your
Mac might slow down because of heavy disk swapping. As a best practice, make sure the total memory that
Fusion and all running virtual machines use stays below 70 percent of your total Mac memory.

Graphics

• VGA
• SVGA
• 128 MB 3D accelerated video with DirectX 9.0c with Shader Model 3 and OpenGL 2.1 for Windows XP as the guest

OS
• 256 MB 3D accelerated video with DirectX 9.0EX with Aero and OpenGL 2.1 for Windows Vista and later as the guest

operating system
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• 3D accelerated video with DirectX 11 with OpenGL 4.3 for Windows 7 and later as the guest operating system. DirectX
11 requires macOS 10.15 or later on the host and hardware version 18 and later. OpenGL 4.3 requires hardware
version 20 and later. You can enable DirectX 11 on the following Mac models
– MacPro 2013 and later
– iMac 27-inch 2014 and later
– MacBook Pro 13-inch 2015 and later
– MacBook Pro 15-inch 2015 with dual graphics and later
– MacBook Air 2015 and later
– MacBook 2015 and later
– iMac 21-inch 2015 and later
– iMac Pro 2017 and later
– MacMini 2018 and later

• To use the GL_EXT_texture_compression_s3tc and GL_S3_s3tc Open Graphics Library (OpenGL) extensions
in a Windows XP or Windows 7 or later guest operating system, you must install Microsoft DirectX End-User Runtime
in the guest operating system. OpenGL is an application program interface that is used to define 2D and 3D computer
graphics. You can download Microsoft DirectX End-User Runtime from the Microsoft Download Center website.

IDE Devices

• Up to four devices. Any of these devices can be a virtual hard disk or CD/DVD drive
• IDE virtual disks up to 8 TB
• CD/DVD drive can be a physical device on the host or client system, or an ISO image file or a DMG image file

SATA Devices

• Up to 120 SATA devices: 4 controllers and 30 devices per controller
• SATA virtual disks up to 8 TB

SCSI Devices

• Up to 60 devices. Any of these devices can be a virtual hard disk or CD/DVD drive
• SCSI virtual disks up to 8 TB
• LSI Logic LSI53C10xx Ultra320 SCSI I/O controller. For Windows XP guest systems, this controller requires an add-on

driver from the LSI Logic website. On the website, select Support & Downloads, click the link for downloading drivers,
and select the controller in the drop-down menu to find the driver to download.

• Mylex (BusLogic) BT-958 compatible host bus adapter. For Windows XP and Windows Server 2003 guest
systems, this requires an add-on driver from the VMware Web site. See http://www.vmware.com/download/fusion/
drivers_tools.html.

NVMe Devices

• Up to 256 NVMe devices: 4 controllers and 64 devices per controller. This feature is supported in hardware version 21
and above

• The following guest operating systems do not support virtual NVMe hard disks by default.
– Windows operating systems prior to Windows 8.1
– Mac operating systems prior to macOS 10.13
– Some Linux operating systems

Several Linux operating systems support NVMe while others do not. Check with the operating system vendor.
• Support for NVMe 1.3 in the following guest operating systems:

– Microsoft Windows 11
– Microsoft Windows Server 2022
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Floppy Drives

• Up to two 1.44 MB floppy devices
• Virtual floppy devices use floppy image files only

Serial (COM) Ports

• Up to four serial (COM) ports
• Virtual serial ports support only output to a file

Parallel (LPT) Ports

• Up to three bidirectional parallel (LPT) ports
• Virtual parallel ports support only output to a file

USB Ports

• Supports high-speed USB 2.0 and SuperSpeed USB 3.0 and SuperSpeed Plus USB 3.1
• Supports most devices, including USB printers, scanners, PDAs, hard disk drives, memory card readers and digital

cameras, as well as streaming devices such as webcams, speakers, and microphones

Keyboard

• 104-key Windows 95/98 enhanced

Mouse and Drawing Tablets

• PS/2 mouse
• USB mouse
• USB drawing tablets

Ethernet Card

• Up to 10 virtual Ethernet cards are supported.

Virtual Networking

• Three virtual hubs are configured by default for bridged, host-only, and NAT networking.
• Support for most Ethernet-based protocols, including TCP/IP v4, Microsoft Networking, Samba, Novell NetWare, and

Network File System.
• Built-in NAT supports client software using TCP/IP v4, FTP, DNS, HTTP, WINS, and Telnet, including VPN support for

PPTP over NAT.
• Create additional virtual networks to create isolated logical networks. This feature is available only with Fusion Pro.
• Support for IPv6 for NAT only applies to additional virtual networks, and is available only with Fusion Pro.

Sound

• Sound output and input using the Mac default input and output settings.
• Emulates Creative Labs Sound Blaster ES1371 AudioPCI sound card. MIDI input, game controllers, and joysticks are

not supported.
• HDAudio
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Solid-State Drives

If your host machine has a physical solid-state drive (SSD), the host informs guest operating systems they are running on
an SSD.

This allows the guest operating systems to optimize behavior. How the virtual machines recognize SSD and use this
information depends on the guest operating system and the disk type of the virtual disk (SCSI, SATA, IDE, or NVMe).

• On Windows 8, Windows 10, Ubuntu, and Red Hat Enterprise Linux virtual machines, all drive types can report their
virtual disks as SSD drives.

NOTE

• NVMe virtual hard disks are natively supported for Windows 8.1 and later.
• To create a new a virtual machine with a Windows 7 or Windows 2008 R2 guest operating system using

NVMe as the virtual hard disk, apply the appropriate Windows hot fix. See https://support.microsoft.com/
en-us/kb/2990941.

• Several Linux operating systems support NVMe while others do not. Check with the operating system
vendor.

• On Windows 7 virtual machines, only IDE and SATA virtual disks can report their virtual disks as SSD. SCSI virtual
disks only report as SSD when used as a system drive in a virtual machine, or as a mechanical drive when used as a
data drive inside a virtual machine.

• On Mac virtual machines, only SATA and NVMe virtual disks are reported as SSD. IDE and SCSI virtual disks are
reported as mechanical drives.

NOTE
NVMe virtual hard disks are supported for macOS 10.13 and later.

Use the virtual machine operating system to verify your virtual machine is using SSD as its virtual disk.

Navigating and Taking Action by Using the Fusion Interface
With Fusion interface elements, you can access your virtual machines and manage Fusion.

VMware Fusion Toolbar
You can use icons on the toolbar to initiate actions or change settings.

You can use the Fusion toolbar to change the state of the virtual machine (for example, power on, suspend, reboot),
access its snapshots, or view and change settings for the virtual machine.

With the Virtual Machine Path item in the toolbar, you can navigate the virtual-machine path and easily view the full path in
a text file or terminal window on the Mac host. See Use the Fusion Toolbar to Access the Virtual-Machine Path.

You can see the toolbar in the virtual machine window in Single Window view and in the Virtual Machine Library based on
your selection to show or hide the toolbar in the View menu. See Show or Hide the Fusion Toolbar.

You can customize the toolbar. See Customize the Fusion Toolbar
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Use the Fusion Toolbar to Access the Virtual-Machine Path
You can use the Virtual Machine Path item in the virtual-machine toolbar to navigate the virtual-machine path and quickly
view the full path in a text file or terminal window on the Mac host.

• If not already added, add the Virtual Machine Path item to the toolbar of the virtual machine. See Customize the Fusion
Toolbar.

The Virtual Machine Path item consists of an icon coupled with the name of the virtual machine. The path leads to the
location of the virtual machine, which Fusion stores as a single package.

• Navigate to a location on the virtual-machine path.
Command-click the name portion of Virtual Machine Path item and select a location.
The location opens in the Finder on your Mac host.

• Create a file on the Mac host that contains the full path of a virtual machine.
In Single Window view, click the icon portion of the Virtual Machine Path item and drag it to the Mac host.
Open the file to see the full path to the virtual machine.

• Copy the full path of a virtual machine into a text file or terminal window on the Mac host.
In Single Window view, click the icon portion of the Virtual Machine Path item and drag it to the text file or terminal
window on the Mac host.
The full path to the virtual machine appears in the text file or terminal window.

Default File Location of a Virtual Machine
Unless you specify a file location for a virtual machine when you create it, Fusion saves the virtual machine package to a
default location.

The possible default file locations for newly created virtual machines are as follows.

• your home directory/Virtual Machines , the default virtual-machine folder for new installations of Fusion 11
or later.

• your home directory/Documents/Virtual Machines , the default virtual-machine folder for installations of
Fusion earlier than Fusion 11 and Fusion 11 and later installations that were upgraded from a version of Fusion earlier
than Fusion 11.

• The last location to which you saved a virtual machine.
When you use Fusion to create a virtual machine and you specify a virtual-machine location, instead of accepting the
default, your specified location becomes the default the next time you create a virtual machine with Fusion.

For information about determining the file location of virtual machines available in the Virtual Machine Library, see Perform
Actions on Your Virtual Machines from the Virtual Machine Library Window.

For information about changing the file location of virtual machines, see Change the File Location of a Virtual Machine.

Change the File Location of a Virtual Machine
You can change the location to which a virtual machine file is stored.

Power off the virtual machine that you want to move.

Unless you specify a file location for a virtual machine when you create it, Fusion saves the virtual machine package to a
default location, which can vary. See Default File Location of a Virtual Machine.
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Regardless of where the virtual machine package is stored, you can move the file to another location.

1. Select Window > Virtual Machine Library.

2. To determine the file location of the virtual machine, in the Virtual Machine Library window, control-click the virtual
machine, release the control button, and select Show in Finder.
You need the file location to access the virtual machine package again.

3. In the Virtual Machine Library window, control-click the virtual machine, and select Delete.
The Remove Virtual Machine dialog box appears.

4. Click Keep File.

5. Use the Finder to navigate back to the virtual machine package and move it to another folder.

6. Double-click the virtual machine package in the Finder window.
A dialog box appears.

7. Click I Moved It.
The virtual machine starts up and appears in the Virtual Machine Library.

Perform Actions on Your Virtual Machines from the Virtual Machine Library Window
The Virtual Machine Library window shows the virtual machines you created or powered on in Fusion.

1. To access the Virtual Machine Library window, select Window > Virtual Machine Library .

2. To perform an action with an existing virtual machine or to create a virtual machine, follow the appropriate instruction.
Option Action
Start a virtual machine Click the play button on the thumbnail image of the virtual

machine.
Suspend a virtual machine Select the thumbnail image of the virtual machine and click the

suspend button in the toolbar.
Add notes about a virtual machine Select the virtual machine and click Virtual Machine > Get Info.

Type notes in the Notes text box of the General settings for the
virtual machine.

Obtain specific information about the virtual machine
(Fusion Pro only)

The following information is available in the Virtual Machine
Library window.

• Virtual machine processor and memory information.
To access the Processors & Memory settings window, click
the information icon.

• Network information appears when the virtual machine is
connected to a network and powered on with VMware Tools
installed.
To obtain more detailed network information, click the
information icon.

• Hard disk, snapshot, and reclaimable information.
Reclaimable information is listed for Windows virtual
machines only.
Click the Refresh disk space icon to update the hard disk,
snapshot, and reclaimable information and to prompt the
Clean Up Recommended message to appear, if applicable.

Clean up a virtual machine (Fusion Pro only) The Clean Up Recommended message appears for a virtual
machine when the virtual machine is powered off and a
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Option Action
significant amount of virtual machine space is available to be
freed.

To initiate the cleanup, click the message. The General settings
dialog box appears, which includes cleanup options you can
select.

Rename a virtual machine 1. Control-click the virtual machine.
2. Select Rename.
3. Type a new name and press Enter.

Determine the location of a virtual machine's files 1. Control-click the virtual machine.
2. Release the control button.
3. Select Show in Finder.

Change the settings for a virtual machine To open the Settings window for that virtual machine, select
Virtual Machine > Settings. Some settings can be changed
only when the virtual machine is powered off.

Add virtual machines to the Virtual Machine Library window You can add one or more virtual machines at a time to the
Virtual Machine Library window

Manual Drag the virtual machine
package icons or the virtual
machines' .vmx files to the
window.

Automated 1. Select File > Scan for
Virtual Machines.

2. Click +.
3. Select a folder.
4. Click Open.
5. Click Scan.

Remove a virtual machine from the Virtual Machine Library
window

1. Shut down or power off the virtual machine.
2. Control-click the virtual machine.
3. Select Delete.

Removing a virtual machine from the Virtual Machine Library
window is not the same as deleting the virtual machine from
your hard disk.

Create a new virtual machine, import a virtual machine, or
migrate a physical computer

Use the File menu to create a new virtual machine, import a
virtual machine, or migrate a PC.

Using the Home Pane to Create a Virtual Machine or Obtain One from Another Source
You can create a virtual machine, or migrate a physical PC.

Power On the Boot Camp Partition as a Virtual Machine

You can use the contents of your Boot Camp partition at the same time that you are running your Mac operating system.
To do so, you use Fusion to power on the Boot Camp partition as a virtual machine.

You must have a Boot Camp partition in place before you start this procedure.
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You must have administrator privileges to use the Boot Camp partition as a virtual machine.

Boot Camp is Apple software that enables an Intel-based Mac to run Windows operating systems. Boot Camp requires
you to choose between Mac or Windows at boot time. Boot Camp creates separate Mac and Windows partitions on
your hard disk to create a dual-boot environment. When you use your Windows Boot Camp partition as a Fusion virtual
machine, you can perform the following tasks:

• Use your Boot Camp virtual machine and your Mac without rebooting and switching between them.
• Share files between your Boot Camp virtual machine and your Mac, through shared folders, dragging files, or cutting

and pasting text.

NOTE
Windows reactivation complications can occur if you do not install VMware Tools. In such a case, if you
reactivate Windows in your Boot Camp virtual machine, and subsequently boot your Boot Camp partition
natively, you will be prompted to reactivate Windows. Reactivating Windows in your native Boot Camp partition
will result in your Boot Camp virtual machine requiring reactivation the next time you power it on, and so forth.
Installing VMware Tools solves this problem.

1. Select Window > Virtual Machine Library.

2. In the Virtual Machine Library window, click the Boot Camp thumbnail in the list of virtual machines, which identifies
the partition that Fusion detected.

3. Optional: Type your Mac password to access the Boot Camp partition.
Fusion creates a virtual machine that uses your Boot Camp partition and starts Windows.

4. Follow the onscreen instructions and restart your virtual machine when prompted.
After Windows boots from your Boot Camp virtual machine, Fusion starts the installation of VMware Tools. VMware
Tools enables full virtual machine functionality and optimizes performance for your Boot Camp partition when you use
the partition as a virtual machine.

5. When the VMware Tools installation is complete, reboot your computer.

The first time you power on your Boot Camp virtual machine after you install VMware Tools, you must reactivate Windows.

Using the Fusion Applications Menus
The applications menus include the applications menu ( ), available for all virtual machines and the Unity applications
menu ( ), available for virtual machines with Windows guest operating systems that support Unity. The applications
menus can provide you with quicker access to virtual machine settings, functionality, and applications.

The following table provides detailed information about the applications menus.
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Table 1: About the Applications Menus

Application Menu Type Icon Description

The Applications Menu • Accessible from the Mac menu bar or with a keyboard shortcut.
• Available for all virtual machines.
• Lists all the virtual machines in the Virtual Machine Library.

You can select a virtual machine in the list to perform the
following operations.

• Access the settings and snapshots of the virtual machine.
• Change the view mode and power status mode of the virtual

machine.
• For a virtual machine with a Windows guest operating

system, you can also quickly access applications listed in
the applications menu.

• Configurable from the Fusion General Preferences dialog box.
You can perform the following configurations.
– Show or hide the applications menu in the Mac menu bar.
– Set up a keyboard shortcut for the applications menu.

The Unity Applications Menu • Accessible from the Mac Dock .
The Unity applications menu icon appears in the Mac Dock
when you switch the Windows virtual machine to Unity view and
disappears when you switch the Windows virtual machine out of
Unity view.
The Mac Dock contains a Unity applications menu icon for each
Windows virtual machine that is in Unity view, allowing multiple
Unity applications menus to appear in the Mac Dock at the
same time.

• Available for virtual machines with Windows guest operating
systems that support Unity.

• Lists the Unity applications menu options.
You can perform the following operations.

• Access the settings and snapshots of the virtual machine.
• Change the view mode and power status mode of the virtual

machine.
• Access the applications installed in the Windows guest.

You can also configure the Applications Menu settings. The Applications Menu settings apply to both the applications
menu ( ) and the Unity applications menu ( ), specifically for supported Windows guests. When you add a Windows
application to the application list in the Applications Menu settings dialog box, Fusion pins the application to the top of the
list in the applications menus.

To set the General Preferences for the applications menu ( ), see Set General Preferences.

To add, remove, or reorder Windows applications in the applications menus, see Set Up the Applications Menus.

NOTE
The Applications Menu is deprecated in VMware Fusion 13.6 and later.
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Set Up the Applications Menus

You can configure the Fusion applications menus for quick access to settings and applications.

The applications menus include the applications menu ( ), accessible in the Mac menu bar or with a keyboard shortcut,
and the Unity applications menu ( ), accessible from the Mac Dock when the virtual machine is in Unity view.

For supported Windows guest operating systems, the applications menus provide quick access to applications you add
when you configure the applications menu and to applications you recently opened.

The applications menus also provide access to Fusion functions, such as the power commands and the views, and certain
Windows functions, such as the run command.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Under System Settings in the Settings window, click Applications Menu.

4. Optional: Add items to the applications menus.
a) To see the applications and other items available in the virtual machine, click the add (+) button.
b) Click, shift-click, or -click the items to appear in the applications menu and click Add.

5. Optional: Use the mouse to select and move items up or down to reorder them.

6. Optional: Remove items from the applications menus.
a) Select the item in the list to remove.
b) Click the remove (-) button.

Related Links
Find a Windows Guest Application by Using the Applications Menus on page 30

For supported Windows guest operating systems, you can find and open any virtual machine application from the
applications menus. The applications menus include the applications menu ( ), accessible in the Mac menu bar or with
a keyboard shortcut, and the Unity applications menu ( ), accessible from the Mac Dock when the virtual machine is in
Unity view.

Find a Windows Guest Application by Using the Applications Menus

For supported Windows guest operating systems, you can find and open any virtual machine application from the
applications menus. The applications menus include the applications menu ( ), accessible in the Mac menu bar or with
a keyboard shortcut, and the Unity applications menu ( ), accessible from the Mac Dock when the virtual machine is in
Unity view.

• To access the applications menu ( ), configure the applications menu to make it accessible. See Set General
Preferences.

• To access the Unity applications menu ( ), switch the virtual machine to Unity view.
With the virtual machine open in single window or full screen view, switch to Unity view. For example, select View >
Unity.
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When you switch to Unity view, the following events occur.

• The virtual machine interface disappears.
• Applications currently open in the virtual machine appear directly on the Mac desktop.
• VMware Unity ( ) appears in the Mac Dock.

For supported Windows guests, the applications menus provide quick access to applications you add when you configure
the applications menus, see Set Up the Applications Menu, and applications you recently opened.

1. Open the applications menu ( ) or the Unity applications menu ( ).

• To open the applications menu, click the application menu ( ) status item in the Mac menu bar or use the keyboard
shortcut and click the appropriate virtual machine.

• To open the Unity applications menu, click VMware Unity ( ) in the Mac Dock.

2. In the list, find the application to open.

3. Optional: If the application name does not appear in the list, you can show more applications.

• Click All Programs.
• Type the name of the application in the search text box.

4. To open the application, click the icon.

Related Links
Set Up the Applications Menus on page 30

You can configure the Fusion applications menus for quick access to settings and applications.

Using Different Views in the Fusion Interface
You can view the Fusion interface in Single Window view, Full Screen view, and Unity view. These views enable you to
work with your applications and virtual machines in different ways.

Use Single Window View to Have Your Virtual Machine Appear in a Single Window on the Mac Desktop

In Single Window view, the virtual machine appears in a single window that you can resize and move with the mouse.

In Single Window view, you can see and use the VMware Fusion toolbar.
Switch to Single Window View
To see the Mac desktop and the virtual machine desktop at the same time, switch to Single Window view.

In Single Window view, the virtual machine appears in a single window that you can resize and move with the mouse.

• Switch to Single Window view.

• In Full Screen view with the Full Screen title bar, select  View > Single Window.
• In Full Screen view without the Full Screen Minibar, use the keyboard shortcut +Control+F to switch to Single

Window view.
• In Unity view, use the keyboard shortcut +Shift+U to switch to Single Window view.

Related Links
Return to Another View from Single Window View on page 32

To have the desktop of your virtual machine fill your display or set of displays, or to see a guest application in a window on
the Mac desktop, exit Single Window view.
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Return to Another View from Single Window View
To have the desktop of your virtual machine fill your display or set of displays, or to see a guest application in a window on
the Mac desktop, exit Single Window view.

• To have the desktop of your virtual machine fill your entire display or set of displays, from the VMware Fusion menu
bar, select View > Full Screen.

• To display guest application windows directly on your Mac desktop without seeing the virtual machine's desktop, select
View > Unity.

Related Links
Switch to Single Window View on page 31

To see the Mac desktop and the virtual machine desktop at the same time, switch to Single Window view.

Use Unity View to Display Guest Applications Directly on a Mac Desktop

To work with your virtual machine applications from the Mac desktop without the Fusion interface, use Unity view.

In Unity view, your virtual machine's window is hidden and VMware Unity appears in the Mac Dock. When you open virtual
machine applications, those applications also appear in the Mac Dock. You can use the virtual machine applications just
as you use your native Mac applications.

NOTE
Unity Mode is deprecated in VMware Fusion 13.6 and later.

About Unity View
Unity view is supported in several Windows operating systems, and enables you to use many Mac functions with your
guest applications.

Unity view is fully supported in virtual machines running Windows XP, Windows Vista, Windows 7, Windows 8, and
Windows 10. Unity view is experimentally supported in virtual machines running Windows Server 2003 (32-bit and 64-bit),
2008, 2012, and 2016.

You can use the  + C,  + X, and  + V Mac keyboard shortcuts to copy, cut, and paste text between your Mac
applications and virtual machine applications displayed in Unity view. You can also use the Mission Control feature with
virtual machine applications in Unity view, and you can use  + Tab to switch between applications.

To use a virtual machine application, click the application in the Mac Dock, which launches Fusion and opens the
application.

The following Mac features are supported with virtual machine applications.

• Keep virtual machine applications in the Mac Dock after you power off your virtual machine and quit Fusion. See Keep
a Windows Application in the Mac Dock on the Intel-based Mac.

• Set virtual machine applications to open when you start up your Mac and log in. See Set a Virtual Machine Application
to Open When You Log in to Your Mac.

Related Links
Switch to Unity View on page 33

You can switch to Unity view from an application open in another view.

Use the Waiting for Unity Window to Interact with the Guest Operating System on page 33
Some operating system activities that require a response do not appear in Unity view. Fusion displays the Waiting for
Unity window to enable you to respond.

View the Windows Taskbar and System Tray in Unity View on page 34
You can have the Windows taskbar or system tray visible while in Unity view.

Connect a USB Device in Unity View on page 34
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You must manually connect USB devices when your virtual machine is running in Unity view.

Switch to Another View From Unity View on page 35
To see the desktop of the virtual machine, you can switch from Unity view to Single Window view or Full Screen view.

Switch to Unity View
You can switch to Unity view from an application open in another view.

Unity view works only if VMware Tools is installed in the virtual machine.

1. In your Windows XP, Windows Vista, Windows 7, Windows 8, or Windows 10 virtual machine, open the applications to
use in Unity view.

2. Switch to Unity View using one of the following methods:

• From the View menu, select Unity.
• Use the keyboard shortcut +Shift+U.
• Click the Switch to Unity view icon in the tool bar of the virtual machine window.

The virtual machine window is hidden. The open applications are displayed in windows on the Mac desktop and as
icon tiles in the Mac Dock.

To exit Unity view, click the Fusion icon in the Mac Dock and select View > Single Window or View > Full Screen.

Related Links
About Unity View on page 32

Unity view is supported in several Windows operating systems, and enables you to use many Mac functions with your
guest applications.

Use the Waiting for Unity Window to Interact with the Guest Operating System on page 33
Some operating system activities that require a response do not appear in Unity view. Fusion displays the Waiting for
Unity window to enable you to respond.

View the Windows Taskbar and System Tray in Unity View on page 34
You can have the Windows taskbar or system tray visible while in Unity view.

Connect a USB Device in Unity View on page 34
You must manually connect USB devices when your virtual machine is running in Unity view.

Switch to Another View From Unity View on page 35
To see the desktop of the virtual machine, you can switch from Unity view to Single Window view or Full Screen view.

Use the Waiting for Unity Window to Interact with the Guest Operating System
Some operating system activities that require a response do not appear in Unity view. Fusion displays the Waiting for
Unity window to enable you to respond.

• In the Waiting for Unity window, follow prompts to respond to the dialog boxes.
When you are finished responding, the virtual machine returns to Unity view.

• Respond to the virtual machine's operating system by exiting Unity view.
a) Click Exit Unity.
b) Perform any activities that the guest operating system requires.
c) To return to Unity view, select View > Unity.

Related Links
About Unity View on page 32

Unity view is supported in several Windows operating systems, and enables you to use many Mac functions with your
guest applications.

Switch to Unity View on page 33
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You can switch to Unity view from an application open in another view.

View the Windows Taskbar and System Tray in Unity View on page 34
You can have the Windows taskbar or system tray visible while in Unity view.

Connect a USB Device in Unity View on page 34
You must manually connect USB devices when your virtual machine is running in Unity view.

Switch to Another View From Unity View on page 35
To see the desktop of the virtual machine, you can switch from Unity view to Single Window view or Full Screen view.

View the Windows Taskbar and System Tray in Unity View
You can have the Windows taskbar or system tray visible while in Unity view.

• Show the taskbar by selecting View > Show Taskbar in Unity.
You might have to move the location of the Mac Dock to see the taskbar.
The Hide System Tray menu item is dimmed.

• Hide the taskbar by selecting View > Hide Taskbar in Unity.
• Show the system tray by selecting View > Show System Tray in Unity.
• Hide the system tray by selecting View > Hide System Tray in Unity

When they are set to show, these elements also remain visible when you switch to work in non-Windows applications.

Related Links
About Unity View on page 32

Unity view is supported in several Windows operating systems, and enables you to use many Mac functions with your
guest applications.

Switch to Unity View on page 33
You can switch to Unity view from an application open in another view.

Use the Waiting for Unity Window to Interact with the Guest Operating System on page 33
Some operating system activities that require a response do not appear in Unity view. Fusion displays the Waiting for
Unity window to enable you to respond.

Connect a USB Device in Unity View on page 34
You must manually connect USB devices when your virtual machine is running in Unity view.

Switch to Another View From Unity View on page 35
To see the desktop of the virtual machine, you can switch from Unity view to Single Window view or Full Screen view.

Connect a USB Device in Unity View
You must manually connect USB devices when your virtual machine is running in Unity view.

NOTE
Fusion does not support USB adapters for connecting displays to your virtual machines.

1. Plug the USB device into your Mac.
The selection dialog appears.

2. Select the system to which you want to connect the device.
The action you take depends on how many virtual machines are open.
Option Description
If you have one virtual machine powered on Select Connect to Mac or Connect to OS of your open

virtual machine.
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Option Description
If you have two or more virtual machines powered on In the pop-up menu, select Connect to your Mac or Connect

to virtual machine name for the selected virtual machine.
Click OK.

Related Links
About Unity View on page 32

Unity view is supported in several Windows operating systems, and enables you to use many Mac functions with your
guest applications.

Switch to Unity View on page 33
You can switch to Unity view from an application open in another view.

Use the Waiting for Unity Window to Interact with the Guest Operating System on page 33
Some operating system activities that require a response do not appear in Unity view. Fusion displays the Waiting for
Unity window to enable you to respond.

View the Windows Taskbar and System Tray in Unity View on page 34
You can have the Windows taskbar or system tray visible while in Unity view.

Switch to Another View From Unity View on page 35
To see the desktop of the virtual machine, you can switch from Unity view to Single Window view or Full Screen view.

Switch to Another View From Unity View
To see the desktop of the virtual machine, you can switch from Unity view to Single Window view or Full Screen view.

Fusion must be the active application, so that the Fusion menu appears at the top of the display.

• Exit Unity view.
Option Action
Have your virtual machine appear in a single window on the
Mac desktop.

From the VMware Fusion menu bar, select View > Single
Window.

Have the desktop of your virtual machine fill your entire
display or set of displays.

From the VMware Fusion menu bar, select View > Full Screen.

The open applications appear in the Fusion virtual machine window.

Related Links
About Unity View on page 32

Unity view is supported in several Windows operating systems, and enables you to use many Mac functions with your
guest applications.

Switch to Unity View on page 33
You can switch to Unity view from an application open in another view.

Use the Waiting for Unity Window to Interact with the Guest Operating System on page 33
Some operating system activities that require a response do not appear in Unity view. Fusion displays the Waiting for
Unity window to enable you to respond.

View the Windows Taskbar and System Tray in Unity View on page 34
You can have the Windows taskbar or system tray visible while in Unity view.

Connect a USB Device in Unity View on page 34
You must manually connect USB devices when your virtual machine is running in Unity view.
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Use Full Screen View To Make Your Virtual Machine Desktop Fill Your Display

In Full Screen view, Fusion fills your entire display or set of displays with the desktop of your virtual machine.

In this view you do not see the Mac Dock. You can show or hide the VMware Fusion menu bar. This view looks as if you
are using a machine dedicated to running your guest operating system. You have access to the toolbar by moving the
cursor to the top of the display to reveal the toolbar. Optionally, a subset of Fusion functions are available via the compact
Full Screen Minibar.
Switch Fusion to Full Screen View
You can switch to Full Screen view from another view.

• Switch to Full Screen view.

• Click the Enter Full Screen button in the toolbar at the top of the virtual machine window.
• From the View menu, select Full Screen.
• Use the +Control+F keyboard shortcut to switch to Full Screen view.

The Fusion virtual machine window expands to fill the full screen (or screens if you have multiple displays and have
Fusion configured to use them all). When possible, a new space is created for easy navigation using Mission Control.

Related Links
Hide the VMware Fusion Menu Bar in Full Screen View on page 36

When you are in Full Screen view, the VMware Fusion menu bar hides until you hover the cursor at the top of the Full
Screen display. You can set the VMware Fusion menu bar to hide all the time.

Set the Full Screen Minibar on page 37
When you are in Full Screen view, you can use the Full Screen Minibar to access some virtual machine controls such as
state change and some Virtual Machine menu options.

Return to Another View from Full Screen View on page 38
To see the Mac desktop and the virtual machine desktop at the same time, or to see a guest application in a window on
the Mac desktop, switch to Unity view or Single Window view.

Hide the VMware Fusion Menu Bar in Full Screen View
When you are in Full Screen view, the VMware Fusion menu bar hides until you hover the cursor at the top of the Full
Screen display. You can set the VMware Fusion menu bar to hide all the time.

The Full Screen menu bar behavior applies to running virtual machines.

• Set the Hide Menu Bar in Full Screen option.

• Select View > Hide Menu Bar in Full Screen.
• Use the  + Shift +M keyboard shortcut to hide or show the VMware Fusion menu bar in Full Screen view.

Related Links
Switch Fusion to Full Screen View on page 36

You can switch to Full Screen view from another view.

Set the Full Screen Minibar on page 37
When you are in Full Screen view, you can use the Full Screen Minibar to access some virtual machine controls such as
state change and some Virtual Machine menu options.

Return to Another View from Full Screen View on page 38
To see the Mac desktop and the virtual machine desktop at the same time, or to see a guest application in a window on
the Mac desktop, switch to Unity view or Single Window view.
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Set the Full Screen Minibar
When you are in Full Screen view, you can use the Full Screen Minibar to access some virtual machine controls such as
state change and some Virtual Machine menu options.

In Full Screen view, the virtual machine window expands to fill the full screen, or screens if you are using multiple displays.
In this view you do not see the Mac Dock. However, you can access some Virtual Machine menu options by using the
Full Screen Minibar. The Full Screen Minibar contains the Fusion suspend and run button for the virtual machine, some
virtual machine options, and the return to Single Window view button.

1. Select View > Full Screen.
The virtual machine view changes to Full Screen view and the Full Screen Minibar appears on the right side of the
screen by default.

2. Select the button in the Minibar with the gear icon and set the Full Screen Minibar behavior from the Full Screen
Minibar menu.
Option Description
Always Show The Full Screen Minibar is always visible.
Automatically Hide and Show For running virtual machines, the Full Screen Minibar is visible if

you move the pointer over its position at the edge of the display.
For virtual machines that are not running, the Full Screen
Minibar always appears.

Always Hide The Full Screen Minibar never appears. Use the +Control+F
keyboard shortcut to exit Full Screen view.

Position on Screen Set where the Full Screen Minibar appears: Top, Left, Bottom,
or Right edge. You can also drag and drop the Full Screen
Minibar to different positions in a single display or you can drag
it to another display if you have more than one display.

NOTE
The Full Screen Minibar can be moved to a different side of the display by dragging.

Related Links
Switch Fusion to Full Screen View on page 36

You can switch to Full Screen view from another view.

Hide the VMware Fusion Menu Bar in Full Screen View on page 36
When you are in Full Screen view, the VMware Fusion menu bar hides until you hover the cursor at the top of the Full
Screen display. You can set the VMware Fusion menu bar to hide all the time.

Return to Another View from Full Screen View on page 38
To see the Mac desktop and the virtual machine desktop at the same time, or to see a guest application in a window on
the Mac desktop, switch to Unity view or Single Window view.
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Return to Another View from Full Screen View
To see the Mac desktop and the virtual machine desktop at the same time, or to see a guest application in a window on
the Mac desktop, switch to Unity view or Single Window view.

To have your virtual machine appear in a single window on the Mac desktop, exit to Single Window view. To display guest
application windows directly on your Mac desktop without seeing the virtual machine's desktop, exit to Unity view.

• To exit Full Screen to Single Window view, in the Full Screen title bar, select  View > Single Window, or use the
keyboard shortcut +Control+F.

• To exit Full Screen to Unity view, in the Full Screen title bar, select View > Unity, or use the keyboard shortcut
+Shift+U.

Related Links
Switch Fusion to Full Screen View on page 36

You can switch to Full Screen view from another view.

Hide the VMware Fusion Menu Bar in Full Screen View on page 36
When you are in Full Screen view, the VMware Fusion menu bar hides until you hover the cursor at the top of the Full
Screen display. You can set the VMware Fusion menu bar to hide all the time.

Set the Full Screen Minibar on page 37
When you are in Full Screen view, you can use the Full Screen Minibar to access some virtual machine controls such as
state change and some Virtual Machine menu options.

Resize the Virtual Machine Display to Fit
You can force the virtual machine display to fit the current screen or window size.

This option is not available when the virtual machine is in Unity view or when the virtual machine display cannot be
resized.

Select View > Resize Virtual Machine to Fit
The virtual machine display is resized to fit the current screen or window.

Using Multiple Displays
Fusion supports multiple displays. Fusion detects up to ten displays and can automatically adjust when displays are
plugged in or unplugged, and change in resolution and orientation.

Use Multiple Displays in Unity View

Fusion detects multiple displays by default. You can drag a window in Unity view to any available display without having to
change settings.

For multiple displays and virtual machines in Unity view, do not use the display settings within the guest operating system.
Fusion does not support any changes made there.

Use All Displays in Full Screen View

You can set Fusion Full Screen view to use all of the displays attached to your Mac.

1. Select View > Use All Displays in Full Screen if Use Single Display in Full Screen Mode is enabled.
Use All Displays in Full Screen is not supported for Mac OS X guests.
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2. Select View > Full Screen if you are in another view.

Move Full Screen View to One of Multiple Displays

When you have multiple displays, you can specify one of them to use Full Screen view for a Fusion virtual machine.

You can have a virtual machine to run in Full Screen view on a single display out of many, rather than use all of the
displays. You can have different virtual machines in Full Screen view on different monitors.

1. In the menu bar, select View > Single Window if you are in another view.

2. Drag the Fusion virtual machine window to the display you want to use for Full Screen view.

3. Optional: In the menu bar, select View > Use Single Display in Full Screen if Fusion is set to use all displays in Full
Screen view.

4. In the menu bar, select View > Full Screen.
The Fusion virtual machine window fills the specified display.

Configuring Fusion
You can configure Fusion so that it looks and works in ways that fit your needs.

Setting Fusion Preferences
You can set preferences that control the behavior of Fusion.

Set General Preferences
You can set how your mouse works, how your virtual machines behave when you quit Fusion, and other general
operations.

1. Select VMware Fusion > Preferences.

2. Click General.

3. In the When closing a virtual machine section, select how Fusion behaves when you close a virtual machine.
Option Description
Suspend the virtual machine The virtual machine is suspended when you close the virtual

machine window.

If you close a virtual machine window with this preference
selected, when you next open the virtual machine, it restarts
with applications running and files open. The behavior is similar
to when you suspend and resume a laptop computer.

Power off the virtual machine The virtual machine is powered off when you close the virtual
machine window.

Confirm before closing Fusion opens a dialog box that asks for confirmation before
closing the virtual machine window. To run virtual machines in
the background, you must select this option.

4. In the Gaming section, select a setting that fits how you expect to use your mouse.
Option Description
Auto-detect Mouse for Games Fusion detects when it needs to lock a mouse to a virtual

machine window for correct operation during gaming. If no game
is detected, the mouse works in the normal fashion. This is the
default setting.
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Option Description
Never Optimize Mouse for Games Sometimes, the autodetect function detects nongame

applications as games. Use this option to turn autodetect off
so that the mouse can work in the normal fashion for these
applications.

Always Optimize Mouse for Games Sometimes, the autodetect function fails to recognize a game.
Use this option to have correct mouse operations for gaming in
this instance.

5. In the Applications Menu section, select options for accessing the applications menu.
a) Select an option for when the applications menu ( ) icon appears in the Mac menu bar.
b) Optional: To configure a shortcut that displays the applications menu, select Enable keyboard shortcut and select

a keyboard shortcut from the drop-down menu.
When you perform the keyboard shortcut, the applications menu opens.

6. Optional: In the Updates section, select the Automatically check for updates check box to have Fusion check for
software updates when it starts.
A message alerts you when a new version of Fusion is available to download and install. If you do not select the
Automatically check for updates check box, you can check for updates manually at any time by selecting VMware
Fusion > Check for Updates.

Select a Keyboard and Mouse Profile
Fusion provides standard keyboard and mouse profiles for each language it supports.

You can assign each virtual machine its own profile.

1. Select VMware Fusion > Preferences and click Keyboard & Mouse.

2. Select a profile from the Keyboard & Mouse Profile drop-down menu.

3. Select Edit Profiles.

4. Optional: Add or remove a profile using the add (+) button and the delete (-) button.

5. Click Done.

Set Key Mappings on the Keyboard and Mouse Preferences Pane
You can map certain key combinations on your Mac keyboard to keys on your virtual machine.

The following mappings are supported:

• Key to Key
• Set of Modifiers to Modifier
• Set of Modifiers + Key to Key
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You cannot stack key mappings. You cannot create one key mapping and include that key mapping as part of another key
mapping.

1. Select VMware Fusion > Preferences and click Keyboard & Mouse.

2. Click Key Mappings to go to the Key Mappings pane.

3. Select the Enable Key Mappings check box.

4. Optional: Select the Enable Language Specific Key Mappings check box if you want to incorporate key mappings
related to the keyboard layout for the language you selected in the Input Menu (as shown by the flag icon in the menu
bar).
When you change the Input Menu to a supported keyboard layout, additional key mappings are appended to the key
mapping list. Fusion supports U.K. English, Belgian, Danish, French, Swiss French, and German. This feature is not
available for Mac OS X Server virtual machines.

5. Change the key mapping settings.
Option Description
Turn a key mapping on or off Click the check box to the left of the Mac Shortcut.
Edit a key mapping Double-click the Mac Shortcut or Virtual Machine Shortcut to

change and make that change in the Edit Key Mapping dialog.
Add a key mapping Click the add (+) button and define the new key mapping in the

Edit Key Mapping dialog.
Delete a key mapping Select the key mapping and click the remove (-) button.
Restore the default settings Click Restore Defaults.

Set Mouse Shortcuts on the Keyboard and Mouse Preference Pane
In Fusion, you can use shortcuts to operate a single-button mouse as a two-button or three-button mouse.

The defaults are Control + primary button to mimic the secondary mouse button (right-click) and  + primary button to
mimic a third button.

You can change the shortcut.

1. Select VMware Fusion > Preferences and click Keyboard & Mouse.

2. Click Mouse Shortcuts to go to the Mouse Shortcuts pane.

3. Double-click the mouse shortcut and hold down the keys for the new shortcut.
To restore the defaults, click Restore Defaults.

Activate or Deactivate Mac Host Shortcuts on the Keyboard and Mouse Preference Pane
By default in Fusion, global keyboard shortcuts that the Mac operating system or third-party applications have registered
are sent to the Mac operating system instead of your virtual machine.

Examples of global Mac keyboard shortcuts include Command-Tab (switch applications) and F9, F10, and F11 (Exposé
commands). You set these shortcuts and commands in the macOS System Preferences.
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You can use the Mac Host Shortcuts pane to deactivate all these shortcuts while you use Fusion. This action applies only
to Single Window view and Full Screen view. In Unity view, all macOS shortcuts are always enabled.

1. Select VMware Fusion > Preferences and click Keyboard & Mouse.

2. To go to the Mac Host Shortcuts pane, click Mac Host Shortcuts .

3. To activate or deactivate all shortcuts, select or deselect the Enable Mac OS Host Keyboard Shortcuts check box.

4. To customize how the virtual machine maps the Mac Command key ( ) to the Windows command key, select the
option from the drop-down menu.
Option Description
Either Command Key Use either Mac Command key to map to the Windows command

key.
Left Command Key Use the left Mac Command key to map to the Windows

command key.
Right Command Key Use the right Mac Command key to map to the Windows

command key.

The macOS commands are not editable here. You must change them in the macOS System Preferences.

Activate Fusion Shortcuts on the Keyboard and Mouse Preference Pane
Fusion has several keyboard shortcuts for Fusion commands when you are in Single Window view or Full Screen view.
You can activate or deactivate these shortcuts in Fusion Preferences.

1. Select VMware Fusion > Preferences and click Keyboard & Mouse.

2. Click Fusion Shortcuts to go to the Fusion shortcuts pane.

3. Select or deselect an item in the list.

Set Fusion Display Resolution Preferences
You can set preferences for how Fusion virtual machines appear in both single window mode and full screen mode.

These preferences apply by default to all of your virtual machines. You can change these settings for specific virtual
machines. For more information, see Configuring Display Resolution Settings.

1. Select VMware Fusion > Preferences.

2. Select Display.

3. Select the Single Window resolution setting.
This setting specifies how all virtual machines appear in single window mode.
Option Description
Stretch the virtual machine in the window When the virtual machine window is resized, the virtual machine

display is stretched to fill the window with the resolution
unchanged.

Resize the virtual machine and the window The virtual machine display is resized to fit the single window.
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4. Select the Full Screen resolution setting.
This setting specifies how all virtual machines appear in full screen mode.
Option Description
Center the virtual machine in the screen When the virtual machine enters Full Screen view mode, the

virtual machine display is centered on the screen with the
resolution unchanged.

Stretch the virtual machine in the screen When the virtual machine enters Full Screen view mode, the
virtual machine display is stretched to fill the screen space with
the resolution unchanged.

Resize the virtual machine to fit the screen The virtual machine display is resized to fit the full screen.

Set Default Applications Preferences
You can set applications from the Mac or the virtual machines to be used to open different categories of URLs.

You can open the following categories of URLs:

• RSS feeds (feed)
• File transfers (FTP, SFTP)
• Web pages (HTTP, HTTPS)
• Mail (mailto)
• VMRC (VMware Remote Console)
• Newsgroups (news)
• Remote sessions (Telnet, SSH)

If you make a Web browser the default from within a virtual machine, the default setting for how Fusion handles URLs
does not change. The next time you start or resume the virtual machine, or change the URL preferences, the Fusion
settings overwrite the changes that you make in the guest machine.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Under System Settings in the Settings window, click Default Applications.

4. Click Configure.

5. Set or change the preference.
Option Description
Add a category of URL to the Default Applications pane Click the add (+) button and select a URL category from the

pop-up menu.
Set or change an application to use to open a category of
URL

Select an application from the pop-up menu to the right of the
appropriate Open [category] with check box. You can select
from all available applications on your Mac and in your virtual
machines.

Remove a URL category Click the remove (-) button to the right of the pop-up menu for
the category.

Creating Custom Networks
With Fusion Pro, you can change key networking settings, add and remove virtual custom networks, create custom virtual
networking configurations, and require the virtual machine to prompt for confirmation before allowing the network adapter
to run in promiscuous mode. The changes that you make affect all virtual machines that connect to the custom network
running on the host system.
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You can create custom networks to accomplish the following tasks:

• Add additional NAT configurations for scenarios in which a virtual machine shares the IP address and MAC address of
your Mac.

• Add additional private virtual networks to enable communication between virtual machines and the host system.

For either type of custom network, you can specify which subnet is used by Fusion and whether to connect a physical
network on the host system to the custom network.

NOTE
While editing a custom network, do not change the MTU, Subnet IP, Subnet Mask, Enable IPv6 and the IPv6
prefix values in the Advanced Network settings page when the VMs are connected to the corresponding
subnets. Disconnect the VMs before changing and applying the settings, and then reconnect the VMs.

Add a NAT Configuration

With Fusion Pro, you can add additional NAT configurations for scenarios in which a virtual machine shares the IP
address and MAC address of your Mac.

• Verify that you know the administrator password.

By default, Fusion provides one Share with my Mac configuration that uses NAT. You can add additional NAT
configurations to perform actions such as turning off the DHCP service or using a non-default subnet IP or subnet mask.

1. Select VMware Fusion > Preferences and click Network.

2. Click the lock icon, enter the administrator password, and click OK.

3. Click the plus sign (+) under the list of networks.

4. Optional: If you want to rename a virtual network, double-click the name, enter a new name, and press the Return key.

5. Allow virtual machines on the network to use NAT to connect to external networks.
a) Select Allow virtual machines on this network to connect to external networks (using NAT).

NOTE
On Big Sur hosts, the virtual machine gets IPv6 addresses if the host has IPv6 configured. If you use
Fusion 12.1.2 or an earlier version with a Mac OS Big Sur host configured with IPv6, skip step 5.b.

b) Optional: Select the Enable IPv6 check box.
c) Optional: Use the appropriate option to configure the IPv6 Prefix text box.

Option Description

Manual Enter the IPv6 prefix in the text box.

Automatic Leave the text box blank to allow an IPv6 prefix to generate
automatically.

d) Optional: Click the plus sign (+) under the Port Forwarding section for each port-forwarding configuration you want
to add.

e) Optional: For each port-forwarding configuration you add, provide the following information and click OK.

Host port A port number available on the Mac host. Verify that the port does
not conflict with ports used by existing port forwarding entries.

Type The appropriate protocol to use.

Virtual Machine IP address The IP address of the virtual machine to which you want to
forward the incoming requests.
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Virtual Machine Port The port number to use for requests on the specified virtual
machine. The port might be the standard port, such as 80 for
HTTP, or a nonstandard port if software running in the virtual
machine is configured to accept requests on a nonstandard port.

A port-forwarding configuration appears in the list of networks.

6. Optional: To connect the host system to this private network, select Connect the host Mac to this network.

NOTE
The Connect the host Mac to this network check box is not available for Fusion 12.1.2 and earlier on
MacOS Big Sur hosts.

7. Optional: If you enabled IPv6 and want the Mac host to use IPv6 to communicate with virtual machines, manually add
an IPv6 address to the NAT virtual network interface.

NOTE
On Mac systems, the NAT virtual network interface does not automatically accept IPv6 address assignments.

a) Open a terminal window on your Mac.
b) Enter a command such as the following.

sudo ifconfig VirtualNetworkInterfaceName inet6 IPv6Prefix::1 up

Where VirtualNetworkInterfaceName is a placeholder for the name of the virtual network interface,
such as vmnet2, and IPv6Prefix::1 is a placeholder for the IPv6 prefix, which has a format such as
xxxx:xxxx:xxxx:xxxx::1.

8. Optional: To use a local DHCP service to distribute IP addresses to virtual machines on the network, select Provide
addresses on this network via DHCP.

NOTE
The DHCP check box is not available for Fusion 12.1.2 and earlier on MacOS Big Sur hosts.

9. Optional: To change the subnet IP address or subnet mask, modify the addresses in the Subnet IP and Subnet Mask
text boxes.

10. Optional: To configure jumbo frame, select Custom from the MTU drop-down menu and enter a value between 72
bytes and 9194 bytes in the text box.

NOTE
The jumbo frame feature is not available for Fusion 12.1.2 and earlier on MacOS Big Sur hosts.

11. Click Apply.

The network that you configured is now available to the virtual network adapters associated with virtual machines on your
Mac.

Add a Private Network Configuration

With Fusion Pro, you can add additional custom host-only private virtual networks (vmnet) configurations to only allow
communication between virtual machines and the host system.

• Verify that you know the administrator password.

Multiple virtual machines configured with this type of host-only networking are on the same network. The VMware DHCP
server can provide addresses on the network.
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You might want to set up multiple private networks on the same computer in the following situations:

• To have two virtual machines connected to one private network, and other virtual machines connected to another
private network to isolate the network traffic on each network.

• To test routing between two virtual networks.
• To test a virtual machine that has multiple network interface cards, without using any physical network adapters.

1. Select VMware Fusion > Preferences and click Network.

2. Click the lock icon, type the administrator password, and click OK.

3. Click the plus sign (+) under the list of networks.

4. Optional: If you want to rename a virtual network, double-click the name, enter a new name, and press the Return key.

5. Verify that the following check box is not selected: Allow virtual machines on this network to connect to external
networks (using NAT).

6. Optional: To connect a physical network on the host system to this private network, select Connect the host Mac to
this network.

NOTE
The Connect the host Mac to this network check box is not available for Fusion 12.1.2 and earlier on
MacOS Big Sur hosts.

7. Optional: To use a local DHCP service to distribute IP addresses to virtual machines on the network, select Provide
addresses on this network via DHCP.

NOTE
The DHCP check box is not available for Fusion 12.1.2 and earlier on MacOS Big Sur hosts.

8. Optional: To change the subnet IP address or subnet mask, modify the addresses in the Subnet IP and Subnet Mask
text boxes.

9. Optional: To configure jumbo frame, select Custom from the MTU drop-down menu and enter a value between 72
bytes and 9194 bytes in the text box.

NOTE
The jumbo frame feature is not available for Fusion 12.1.2 and earlier on MacOS Big Sur hosts.

10. Click Apply.

The network that you configured is now available to the virtual network adapters associated with virtual machines on your
Mac.
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Enable Jumbo Frames
With Fusion Pro, you can enable jumbo frames for built-in networks.

• Verify that you know the administrator password.
• If you use Fusion 12.1.2 or earlier on MacOS Big Sur hosts, the jumbo frame feature is not available for built-in NAT

and private networks. Only bridged networking is supported when jumbo frame is enabled on the host.

Jumbo frames let you send larger frames out onto the physical network. For built-in networks, jumbo frames can be
configured in the Share with my Mac and Private to my Mac tabs.

1. Select VMware Fusion > Preferences and click Network.

2. Click the lock icon, enter the administrator password, and click OK.

3. Select Share with my Mac.

4. Select Custom from the MTU drop-down menu and enter a value between 72 and 9194 bytes in the text box and Click
Apply.

5. Select Private to my Mac.

6. Select Custom from the MTU drop-down menu and enter a value between 72 bytes and 9194 bytes in the text box
and Click Apply.

Jumbo frame is enabled for built-in networks.

NOTE
To enable jumbo frames on Mac OS Big Sur host, the network adapter must support jumbo frames. To enable
this feature perform the following steps:

1. Navigate to System Preferences > Network > Advanced > Hardware.
2. Change Configure to Manually and choose Jumbo (9000) in the MTU drop-down.

Enable Dictation
Dictation allows you to use your voice instead of typing. You must enable Dictation in Fusion to use it with guest operating
systems.

1. Select VMware Fusion > Preferences and click Keyboard & Mouse.

2. Select a profile to use from the Keyboard & Mouse Profile drop-down menu.

3. Click Mac Host Shortcuts to go to the Mac Host Shortcuts pane.

4. Make note of how your virtual machine maps the Command key to the Windows key.

5. Assign a hot key to start dictation in the virtual machine.

Join or Leave the Customer Experience Improvement Program
The VMware Customer Experience Improvement Program (CEIP) provides information to VMware. VMware uses the
information to improve its products and services, to fix problems, and to advise you on how best to deploy and use
VMware products.

VMware Fusion participates in the VMware CEIP. Information about the data collected through CEIP and how VMware
uses it are in the Trust & Assurance Center at http://www.vmware.com/trustvmware/ceip.html.
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The CEIP appears the first time you launch Fusion after you install the product. You must then make a selection. You can
change your selection any time afterwards.

1. Launch Fusion.

2. Select VMware Fusion > Preferences.

3. Click Feedback.

4. Join or leave the CEIP depending on the participation preference currently selected.
Option Description
Join Select Join the VMware Customer Experience Improvement

Program.
Leave Deselect Join the VMware Customer Experience

Improvement Program.

Customizing the Fusion Display
You can customize the Fusion display to fit the way you work with virtual machines.

Show or Hide the Fusion Toolbar
If you prefer working on your Mac without toolbars hidden when you aren't using them, you can hide the Fusion toolbar in
the virtual machine window.

• Click View > Show/Hide Toolbar.
Related Links

Customize the Fusion Toolbar on page 48
You can add or remove icons from the toolbar.

Resize the Fusion Display and Resolution on page 49
You can use the mouse to resize the virtual machine window.

Customize the Fusion Toolbar
You can add or remove icons from the toolbar.

You must use Single Window view to customize the toolbar.

1. Select Customize Toolbar using one of the following methods.
Option Description
Fusion Menu With the virtual machine selected in the Virtual Machine Library,

select View > Customize Toolbar.
Virtual Machine With the virtual machine open, control-click the title bar of the

virtual machine and select Customize Toolbar.

The list of all the tools available for the toolbar appears.

2. Click Done.

Related Links
Show or Hide the Fusion Toolbar on page 48

If you prefer working on your Mac without toolbars hidden when you aren't using them, you can hide the Fusion toolbar in
the virtual machine window.

Resize the Fusion Display and Resolution on page 49
You can use the mouse to resize the virtual machine window.
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Resize the Fusion Display and Resolution
You can use the mouse to resize the virtual machine window.

Changing the display resolution by resizing the window works only if VMware Tools is installed and is up to date in the
virtual machine.

• With the pointer over the resize control at the lower-right corner of the virtual machine window, hold down the primary
mouse button and drag the handle to resize the window.

The display resolution adjusts to the new window size.

Related Links
Show or Hide the Fusion Toolbar on page 48

If you prefer working on your Mac without toolbars hidden when you aren't using them, you can hide the Fusion toolbar in
the virtual machine window.

Customize the Fusion Toolbar on page 48
You can add or remove icons from the toolbar.

Keep a Windows Application in the Mac Dock on the Intel-based Mac
You can place an icon tile for a Windows application in your Mac Dock. You can open the application in the same way that
you open your Mac applications. You can access your virtual machine's applications without having to use the VMware
Fusion menu bar or the guest operating system interface.

1. With the application open, switch to Unity view by selecting View > Unity.
The application appears in the Mac Dock.

2. Control-click or right-click the application in the Mac Dock and select Options > Keep in Dock.

Set a Virtual Machine Application to Open When You Log in to Your Mac
For convenience, you might want to have an application on your virtual machine open whenever you start your Mac.

1. With the application open, switch to Unity view by selecting View > Unity.
The application appears in the Mac Dock.

2. Control-click or right-click the application in the Mac Dock and select Options > Open at Login.

Contents of the Virtual Machine Package
The files that describe a virtual machine are bundled in a package in macOS.

Virtual machine files have different functions, as shown in Table 2:  Files in the Virtual Machine Package. Some of these
files, like the lock files, are created when the virtual machine runs.

Table 2: Files in the Virtual Machine Package

File Description

Virtual disk file(s) *.vmdk This can be a single large file or many 2GB portions, depending
on how you set up your disk and if you have snapshots.

Configuration file *.vmx A plain text file describing the virtual machine, such as which files
it uses, how much RAM it gets, and a variety of other settings.

BIOS file *.nvram This contains information such as the virtual machine's boot order.
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File Description

Log file vmware.log This is a plain text file that contains information on the most
recent run of the virtual machine. The next-most-recent is called
vmware-0.log, then vmware-1.log, and finally vmware-2.log. If you
ever have a problem with Fusion, you might be asked to provide
this file.

Lock files *.lck These files are created for the configuration and disk files when
the virtual machine is running.

Memory files *.vmem Snapshot files are an example of memory files.

Work with Virtual Machine Packages
When you create a virtual machine, Fusion stores the virtual machine files as a single package. This feature lets you
move an entire virtual machine as a single entity.

Fusion must not be running during virtual machine file editing.

A package (sometimes called a bundle) has the extension .vmwarevm. When you move the package, all virtual machine
files are included.

You might need to access the virtual machine package files during troubleshooting.

NOTE
Editing the configuration file can cause problems. Make a backup copy of the file before you make any changes.

1. In the Finder, select the virtual machine package.
a) In Fusion, select Window > Virtual Machine Library.
b) Control-click the virtual machine.
c) Release the control button.
d) Select Show in Finder.

2. Control-click the package in the Finder window and select Show Package Contents.

3. Perform one of the following tasks.

• Copy the log file (vmware.log) to provide for troubleshooting analysis.
• Open the configuration file (*.vmx) in a text editor to modify it. You can find instructions for how to modify the file in

the Fusion release notes or from appropriate support personnel.

Creating Virtual Machines
You can create virtual machines, import virtual machines created elsewhere, and migrate virtual machines converted from
physical PCs. If you have Fusion Pro, you can also clone existing virtual machines.

Create a Virtual Machine
How you create a virtual machine depends on its guest operating system. Virtual machines created using Fusion 6 and
later are created with SATA virtual disks or CD drives.

NOTE
VMware Fusion does not provide any technical support for errors encountered during the in-place upgrade
to any major versions of the Guest Operating System. If the operating system vendor identifies an issue with
VMware Fusion, then VMware can provide assistance.
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Creating a Microsoft Windows Virtual Machine
You can create a virtual machine that uses a Microsoft Windows operating system as its guest operating system.

Fusion creates your virtual machine, selects the default Windows installation options, and installs VMware Tools, which
loads the drivers required to optimize your virtual machine's performance.

You can also allow Windows Easy Install to make your home folder available to Windows as a shared folder. This feature
provides you with options, such as sharing files between the virtual machine and your Mac.

Windows Easy Install is available for the following Windows operating systems:

• Windows 10, Windows 8, Windows 7, Windows Vista, and Windows XP
• Windows Server 2016, Windows Server 2012, Windows Server 2008, Windows Server 2003, and Windows 2000

Server

NOTE
You must provide the operating system software and its product key. Fusion does not include any operating
system or license.

If you are not using one of these Windows operating systems in your virtual machine, or if you are using Windows but
want to install the operating system manually, you can use the procedure for creating a virtual machine for any supported
operating system.

Create a Virtual Machine by Using Windows Easy Install

When you create a Microsoft Windows virtual machine, you can use the Fusion Windows Easy Install feature to install the
Windows operating system you supply and to install VMware Tools in your virtual machine.

• If you are installing the guest operating system from an image file, verify that the ISO image file is in a directory that is
accessible to the host system.

• If you are installing the guest operating system from a physical disc, insert the operating system installation disc into
your Mac.

IMPORTANT
Fusion does not include any operating systems to install in virtual machines that you create. You must obtain the
operating system and any necessary product keys.

Unless you specify a file location for a virtual machine when you create it, Fusion saves the virtual machine package to a
default location, which can vary. See Default File Location of a Virtual Machine.

1. Select File > New.
A dialog box appears with the Select the Installation Method panel showing.

2. Click Continue.

3. Select the disc or ISO image.
Option Description
ISO image file 1. Click Use another disc or disc image, browse to the .iso

file for the operating system, and click Open to identify the
file.

2. Select the file from the list in the Create a New Virtual
Machine window, and click Continue.

Physical disc Select the disc you inserted into the Mac from the list and click
Continue.

If the disc does not appear in the list, click Use another disc or
disc image and browse to the location of the disc.
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4. In the Microsoft Windows Easy Install panel, select the Use Easy Install option, provide the appropriate
information, and click Continue.

• Display Name or Account Name

For Windows XP and earlier, the entry in the Display Name text box appears in Info windows as the name your
Windows software is registered to. It is not the Windows user name.

• Password (optional)

The entry in the Password text box is the password for the Windows administrator account only.
• Windows Product key

Fusion does not provide the product key. The product key is included in the materials from the Windows operating
system vendor.

5. In the Integration panel, indicate how basic file sharing is handled in the new virtual machine.
Option Description
More Seamless Fusion shares the documents and applications on your Mac with

Windows. Files on your Mac that Windows supports open in
Windows. Windows can modify your Mac’s documents, so install
and regularly update Windows antivirus software.

More Isolated Fusion does not share the documents and applications on
your Mac with Windows. To copy files between your Mac and
Windows, use drag and drop.

You can change these settings after the virtual machine is created by selecting Virtual Machine > Settings and using
the Sharing panel.

6. In the Finish panel, you can use default settings or customize the settings before powering on the virtual machine to
start the operating system installation.
Option Action
To create the virtual machine according to the
specifications listed in the Finish panel

1. Click Finish.
2. Indicate the location to save the virtual machine to or accept

the default, such as the your home directory/
Virtual Machines folder.

3. To share the virtual machine with other users on the Mac
host, save the virtual machine to the Shared folder and
select the Share this virtual machine with other users
on this Mac check box. Deselect the check box to save to
the Shared folder but not share the virtual machine with
other users on the Mac host. See Creating a Shared Virtual
Machine in Fusion.

To change disk size or other standard settings of the virtual
machine

1. Click Customize Settings.
2. Save the new virtual machine.
3. Make changes to the virtual machine’s disk size, processor

usage, removable devices, and other configurations on the
Settings window.

Fusion starts the new virtual machine, installs the operating system, and installs VMware Tools.

Create a Virtual Machine by Using Windows Easy Install and a Disc Image File

When you create a Microsoft Windows virtual machine, you can use the Fusion Windows Easy Install feature to install the
Windows operating system you supply and to install VMware Tools in your virtual machine.
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IMPORTANT
Fusion does not include any operating systems to install in virtual machines that you create. You must obtain the
operating system and any necessary product keys.

Unless you specify a file location for a virtual machine when you create it, Fusion saves the virtual machine package to a
default location, which can vary. See Default File Location of a Virtual Machine.

1. Select File > New.
A dialog box appears with the Select the Installation Method panel showing.

2. Click Continue.

3. Click Use another disc or disc image, browse for the .iso file for the operating system, and click Open to identify
the file.

4. Select the file from the list in the Create a New Virtual Machine window, and click Continue.

5. In the Microsoft Windows Easy Install dialog box, select the Use Easy Install option, provide the appropriate
information, and click Continue.

• Display Name or Account Name

For Windows XP and earlier, the entry in the Display Name field appears in Info windows as the name your
Windows software is registered to. It is not the Windows user name.

• Password (optional)

The entry in the Password field is the password for the Windows administrator account only.
• Windows Product key

Fusion does not provide the product key. The product key is included in the materials from the Windows operating
system vendor.

6. In the Integration panel, indicate how basic file sharing is handled in the new virtual machine.
Option Description
More Seamless Fusion shares the documents and applications on your Mac with

Windows. Files on your Mac that Windows supports open in
Windows. Windows can modify your Mac’s documents, so install
and regularly update Windows antivirus software.

More Isolated Fusion does not share the documents and applications on
your Mac with Windows. To copy files between your Mac and
Windows, use drag and drop.

You can change these settings after the virtual machine is created by selecting Virtual Machine > Settings >
Sharing.

7. In the Finish panel, you can use default settings or customize the settings before powering on the virtual machine to
start the operating system installation.
Option Action
To create the virtual machine according to the
specifications listed in the Finish panel

1. Click Finish.
2. Indicate the location to save the virtual machine to or accept

the default, such as the your home directory/
Virtual Machines folder.

3. To share the virtual machine with other users on the Mac
host, save the virtual machine to the Shared folder and
select the Share this virtual machine with other users
on this Mac check box. Deselect the check box to save to
the Shared folder but not share the virtual machine with
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Option Action
other users on the Mac host. See Creating a Shared Virtual
Machine in Fusion.

To change disk size or other standard settings of the virtual
machine

1. Click Customize Settings.
2. Save the new virtual machine.
3. Make changes to the virtual machine’s disk size, processor

usage, removable devices, and other configurations on the
Settings window.

Fusion starts the new virtual machine, installs the operating system, and installs VMware Tools.

Install Windows 11 as the Guest Operating System

Installing Windows 11 on a virtual machine is similar to installing Windows 11 on a physical computer. When you create a
virtual machine with Windows 11 as the guest operating system, WorkstationFusionWorkstation Player adds vTPM (virtual
Trusted Platform Module) to the virtual machine.

• Verify that the operating system is supported. See the online VMware Compatibility Guide on the VMware Web site.
• See the VMware Guest Operating System Installation Guide for information on the guest operating system that you are

installing.
• If you want to install the operating system using an installer CD, ensure that you have configured the virtual machine to

use a physical CD-ROM or DVD drive. Also, ensure that you have configured the drive to connect at power on.
• If you want to install the guest operating system from an ISO image file, configure the CD/DVD drive in the virtual

machine to point to the ISO image file, and configure the drive to connect at power on.

To install Windows 11, a physical machine must have a TPM chip version 2.0. The vTPM is a representation of the
physical TPM 2.0 on virtual machines. While creating a virtual machine with Windows 11 as the guest operating system,
you must choose the full encryption or fast encryption of the virtual machine. WorkstationFusionWorkstation Player adds
vTPM to an encrypted virtual machine.

NOTE
After you complete the installation of the Windows 11 operating system, we recommend that you do not remove
the encryption or the vTPM device from the virtual machine for a seamless experience of using Windows 11.

NOTE
Fusion does not support creating a Windows 11 guest operating system on a remote virtual machine.

You can install a guest operating system from an installer disc or ISO image file. If the host configuration does not permit
the virtual machine to boot from an installer disc, you can create an ISO image file from the installer disc.

1. Select File > New.
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A dialog box named Select the Installation Method appears.
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2. Select the installation method, and then click Continue.

3. From Choose the Operating System dialog box, select Windows 11 x64 for Intel-based Mac or Windows 11 64-bit
Arm for Apple Silicon Mac.

4. Click Continue.

5. From the Choose Firmware Type dialog box, select a boot firmware and click Continue.

6. From the Choose Encryption dialog box, select an encryption type, enter a password for the encryption, and then
click Continue.
You can choose to encrypt all the files, or only the minimum needed files to support the vTPM device.

NOTE
You can specify a password of your choice or select the Auto Generate Password option to automatically
generate a password. You can also select the option to remember the encryption password. Mac's Keychain
stores the password.For a Windows host operating system, Credential Manager stores the password. For a
Linux host operating system, libsecret stores the password.

7. Create a new virtual disk or use an existing virtual disk, and then click Continue.

8. To change disk size, CPU, memory, or other standard settings of the virtual machine, click Customize Settings, and
make the required changes.

9. Enter the name and location of the virtual machine, and then click Save.

10. Click Finish.

Workstation starts the new virtual machine and user can install the operating system by following the installation
instructions.

Fusion starts the new virtual machine and user can install the operating system by following the installation instructions.

Workstation Player starts the new virtual machine and user can install the operating system by following the installation
instructions.

Install VMware Tools. You should install VMware Tools before you activate the license for the operating system.

Download and Install Windows 11 as Guest Operating System on Apple Silicon Mac
You can now download and install Windows 11 on your Apple Silicon Mac from the Fusion user interface.

To use this feature, you must have an Apple Silicon Mac using Fusion Pro or Player version 13.5 and onward.

Windows 11 introduces new system requirements for physical and virtual machines.

VMware Fusion 13 provides the necessary hardware and security requirements to satisfy these requirements, and gives
options for the user to customize if necessary.

The following is the list of Windows 11 requirements:

• TPM 2.0 device (or vTPM equivalent)
• UEFI Firmware

NOTE
The best Windows 11 experience requires Virtual Hardware version 21. Virtual Hardware version 21 is default in
Fusion 13.5 and later.

When you install Windows 11 on a physical machine, the PC must have a TPM chip of at least version 2.0. The vTPM in
VMware virtual machines is a representation of a physical TPM 2.0, and requires a measure of encryption. While creating
a Windows virtual machine, you may choose between a full encryption or a fast encryption of the virtual machine to satisfy
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the requirements for the vTPM. After the VM is encrypted, Fusion automatically adds the vTPM during the installation
walkthrough.

These requirements are for both the traditional x86-based Windows as well as Windows for Arm devices, which is
required when you use Fusion on Macs with Apple silicon such as the M1 and M2 chips.

NOTE
If you have previously created an ISO using this method, you can cancel this method and use another
method to install Windows 11 with the already existing ISO file located in the following directory: ~/Virtual
Machines.localized/VMWIsoImages/

NOTE
Fusion does not support creating a Windows 11 guest operating system on a remote virtual machine.

The following steps provide a walkthrough of a fresh Windows 11 guest installation on an Apple Silicon Mac host using the
new built-in ISO download utility.

1. Select File > New.
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A dialog box named Select the Installation Method appears.
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2. Select Get Windows from Microsoft, and click Continue.

The Download and Install Windows 11 window appears.
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3. Click Continue.

4. In the Windows Edition field, select your preferred edition for Windows 11.

5. In the Language field, select your preferred language for Windows 11.
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6. Click Download Windows.
Fusion downloads and creates the Windows 11 ISO file for installation. After the ISO file is created, you can see the
path to the ISO in the dialog. You may use this ISO file to install Windows 11 any number of times in any number of
virtual machines.
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7. Click Continue.

8. From the Choose Firmware Type dialog box, select a boot firmware and click Continue.

9. From the Choose Encryption dialog box, select an encryption type, enter a password for the encryption, and then
click Continue.
You can choose to encrypt all the files, or only the minimum needed files to support the vTPM device.

NOTE
You can specify a password of your choice or select the Auto Generate Password option to automatically
generate a password. You can also select the option to remember the encryption password. Mac's Keychain
stores the password.For a Windows host operating system, Credential Manager stores the password. For a
Linux host operating system, libsecret stores the password.

10. Create a new virtual disk or use an existing virtual disk, and then click Continue.

11. To change disk size, CPU, memory, or other standard settings of the virtual machine, click Customize Settings, and
make the required changes.

12. Enter the name and location of the virtual machine, and then click Save.

13. Click Finish.

Fusion starts the new virtual machine and begins installing Windows 11, taking you through the out-of-the-box experience.
After Windows 11 is successfully installed, you need to install VMware Tools. It is recommended that you install VMware
Tools before you attempt to activate/license the operating system. For more information on installing VMware Tools on an
Apple Silicon Mac, see Manually Install VMware Tools on Windows

Download and Generate Windows 11 ISO Using the Command-line Interface
You can now download the Windows 11 ESD file and generate a Windows 11 ISO file via the command-line user interface
using the vmw_esd2iso tool bundled with Fusion.

To use this feature, you must have Fusion Pro or Player version 13.5 and onward.

You can use this feature for both x86-based Mac and Apple Silicon Mac. You can use the command with the following
syntax to get a desired output:
vmw_esd2iso commandoptions

For example, use the following command to get the URL for downloading the ESD file:
[~/Documents]$ vmw_esd2iso getesdurl

The following table lists the commands you can use with vmw_esd2iso tool:

Table 3: vmw_esd2iso Commands

Command Description

getesd Download the Windows 11 ESD file from the Microsoft website

getesdurl Get the url to download the Windows 11 ESD file from the
Microsoft website

generateiso Generate the Windows 11 ISO file from a Windows 11 ESD file
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NOTE
Fusion does not support creating a Windows 11 guest operating system on a remote virtual machine.

1. On your Mac, open a terminal window.

2. To download the Windows 11 ESD file, run the ./vmw_esd2iso getesd command in the following format:
vmw_esd2iso getesd --edition <Microsoft Windows 11 Edition> --lang <language code>

The following example illustrates the command:
[~/Documents]$ vmw_esd2iso getesd --edition "Professional" --lang "en-us"

The vmw_esd2iso tool downloads the Windows 11 ESD file in your current working directory.

NOTE
Ensure that you have sufficient privileges to write on the current folder to avoid any error while downloading
the file.

3. To generate the Windows 11 ISO file from the ESD file you downloaded, run the ./vmw_esd2iso generateiso
command in the following format:
vmw_esd2iso generateiso --esd <path to the downloaded ESD file> --drivers "<absolute path of the driver

 1>,<absolute path of the driver 2>"

After you run the command, vmw_esd2iso tool generates the Windows 11 ESD file into an ISO file and saves it in
your current working directory.

NOTE
Ensure that you have sufficient privileges to write on the current folder to avoid any error while generating
and saving the ISO file.

Creating a Linux Virtual Machine in Fusion
You can create a virtual machine that uses a Linux distribution as its guest operating system.

Fusion creates your virtual machine, selects the default Linux installation options, and installs VMware Tools, which loads
the drivers required to optimize your virtual machine's performance. You can also have Linux Easy Install make your home
folder available to Linux as a shared folder, so that you can share files between the virtual machine and your Mac.

Linux Easy Install is available for the following operating systems:

• Ubuntu 7.10 and later
• Ubuntu Server Edition 8.10 and later
• Red Hat Enterprise Linux 3 and later
• SUSE Linux Enterprise Desktop/Server 10 and later
• Open SUSE 11.3 and later

If you are not using one of these Linux operating systems in your virtual machine, or if you are using Linux but want
to install the operating system manually, you can use the procedure for creating a virtual machine for any supported
operating system.

Create a Virtual Machine by Using Linux Easy Install and an Installation CD

When you create a Linux virtual machine, you can use the Fusion Linux Easy Install feature to install the Linux operating
system you provide and to install VMware Tools in your virtual machine.

 64



 VMware Fusion Pro 13

You must obtain the operating system installation image. Fusion does not include any operating systems to install in
virtual machines that you create.

Unless you specify a file location for a virtual machine when you create it, Fusion saves the virtual machine package to a
default location, which can vary. See Default File Location of a Virtual Machine.

1. Select File > New.
A dialog box appears with the Select the Installation Method panel showing.

2. Insert the operating system installation CD into your Mac.
Fusion detects it and asks for confirmation that it is the operating system to install.

3. If it is the correct operating system, ensure that Install this operating system is selected and click Continue to go to
the Linux Easy Install panel.

4. In the Linux Easy Install dialog box, select the Use Easy Install option, provide the appropriate information, and click
Continue.
a) Enter your Display Name, Account Name, and Password.
b) Select Make your home folder accessible to the virtual machine to have Linux Easy Install configure your

home folder as a shared folder, so you can share files between the virtual machine and your Mac.

5. Optional: If you selected to make your home folder accessible, select either Read only or Read & Write for your
virtual machine.

6. In the Finish panel, you can use default settings or customize the settings before powering on the virtual machine to
start the operating system installation.
Option Action
To create the virtual machine according to the
specifications listed in the Finish panel

1. Click Finish.
2. Indicate the location to save the virtual machine to or accept

the default, such as the your home directory/
Virtual Machines folder.

3. To share the virtual machine with other users on the Mac
host, save the virtual machine to the Shared folder and
select the Share this virtual machine with other users
on this Mac check box. Deselect the check box to save to
the Shared folder but not share the virtual machine with
other users on the Mac host. See Creating a Shared Virtual
Machine in Fusion.

To change disk size or other standard settings of the virtual
machine

1. Click Customize Settings.
2. Save the new virtual machine.
3. Make changes to the virtual machine’s disk size, processor

usage, removable devices, and other configurations on the
Settings window.

Fusion starts the new virtual machine, installs the operating system, and installs VMware Tools.

Create a Virtual Machine by Using Linux Easy Install and an Image File

When you create a Linux virtual machine, you can use the Fusion Linux Easy Install feature to install the Linux operating
system you provide and to install VMware Tools in your virtual machine.
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You must obtain the operating system installation image. Fusion does not include any operating systems to install in
virtual machines that you create.

Unless you specify a file location for a virtual machine when you create it, Fusion saves the virtual machine package to a
default location, which can vary. See Default File Location of a Virtual Machine.

1. Select File > New.
A dialog box appears with the Select the Installation Method panel showing.

2. Click Continue.

3. Click Use another disc or disc image, browse for the .iso file for the operating system, and click Open to identify
the file.

4. Select the image in the Create a New Virtual Machine panel and click Continue.

5. In the Linux Easy Install dialog box, select the Use Easy Install option, provide the appropriate information, and click
Continue.
a) Enter your Display Name, Account Name, and Password.
b) Select Make your home folder accessible to the virtual machine to have Linux Easy Install configure your

home folder as a shared folder, so you can share files between the virtual machine and your Mac.

6. If you selected to make your home folder accessible, select either Read only or Read & Write for your virtual
machine.

7. In the Finish panel, you can use default settings or customize the settings before powering on the virtual machine to
start the operating system installation.
Option Action
To create the virtual machine according to the
specifications listed in the Finish panel

1. Click Finish.
2. Indicate the location to save the virtual machine to or accept

the default, such as the your home directory/
Virtual Machines folder.

3. To share the virtual machine with other users on the Mac
host, save the virtual machine to the Shared folder and
select the Share this virtual machine with other users
on this Mac check box. Deselect the check box to save to
the Shared folder but not share the virtual machine with
other users on the Mac host. See Creating a Shared Virtual
Machine in Fusion.

To change disk size or other standard settings of the virtual
machine

1. Click Customize Settings.
2. Save the new virtual machine.
3. Make changes to the virtual machine’s disk size, processor

usage, removable devices, and other configurations on the
Settings window.

Fusion starts the new virtual machine, installs the operating system, and installs VMware Tools.

Creating a macOS Virtual Machine in Fusion
You can install Mac OS X, OS X, or macOS in a virtual machine. Fusion creates the virtual machine, opens the operating
system installation assistant, and installs VMware Tools. VMware Tools loads the drivers required to optimize a virtual
machine's performance.

Mac OS X, OS X, or macOS virtual machines that you create in Fusion can run on any Apple-branded hardware that uses
Intel processors. The Apple licensing agreement defines the situations when it is permissible to virtualize Mac OS X, OS
X, or macOS. Fusion does not change these terms or enable macOS on non-Apple hardware. You cannot use a Mac OS
X, OS X, or macOS virtual machine in another VMware product, such as Workstation Pro.
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Fusion supports the following Mac server and client versions for the guest operating system:

• Mac OS X Server 10.5, 10.6
• Mac OS X 10.7
• OS X 10.8, 10.9, 10.10, 10.11
• macOS 10.12, 10.13, 10.14, 10.15
• macOS 11.x
• macOS 12.x
• macOS 13.0

Fusion does not support the following features for Mac virtual machines:

• Multiple displays
• 3D Accelerated graphics
• Unity view

To install the operating system, use the procedure for creating a virtual machine for any supported operating system. See
Create a Virtual Machine for Any Supported Operating System.

Creating a Shared Virtual Machine in Fusion
You can create a shared virtual machine in Fusion that can be accessed by all users on the local Mac host.

Unless you specify a file location for a virtual machine when you create it, Fusion saves the virtual machine package to a
default location, such as the your home directory/Virtual Machines folder. See Default File Location of a Virtual
Machine.

This folder has limited permissions that allow only the creator of the virtual machine to use it. To allow other users on the
Mac host to access the virtual machine, save it to the /Users/Shared folder on the Mac.

With a shared virtual machine, the user can log out of the current account on the Mac host, and another user on the Mac
host can log in to access the virtual machine.

The Run Windows applications from your Mac's Applications folder option is not available on shared virtual
machines.

IMPORTANT
Shared virtual machines in Fusion work differently than shared virtual machines in Workstation Pro. In
Workstation Pro, a shared virtual machine is a virtual machine on the host system that remote Workstation Pro
users can access as a remote virtual machine. In Fusion, shared virtual machines can be accessed only on the
local Mac host.

Create a Virtual Machine from a Mac Recovery Partition
You can use the recovery partition on your Mac to create virtual machines running macOS.

• You must have a recovery partition on your Mac to create this kind of virtual machine.
• You must have Mac OS X 10.11 or later.

Unless you specify a file location for a virtual machine when you create it, Fusion saves the virtual machine package to a
default location, which can vary. See Default File Location of a Virtual Machine.

1. Select File > New.
A dialog box appears with the Select the Installation Method panel showing.
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2. Click Install macOS from the recovery partition.

3. Select a recovery partition and click Continue.
If you have more than one recovery partition, a list of partitions is presented from which to choose.

4. Provide information about the virtual machine.
a) In the Where text box, indicate the folder to save the virtual machine to or accept the default, such as the your

home directory/Virtual Machines folder.
b) To enable the virtual machine to be shared with other users on the Mac host, save the virtual machine to the

Shared folder and select the Share this virtual machine with other users on this Mac check box.
c) Click Save.

5. In the Finish panel, you can use default settings or customize the settings before powering on the virtual machine to
start the operating system installation.
Option Action
To create the virtual machine according to the
specifications listed in the Finish panel

• Click Finish.

To change disk size or other standard settings of the virtual
machine

1. Click Customize Settings.
2. Make changes to the virtual machine’s disk size, processor

usage, removable devices, and other configurations on the
Settings window.

Create a Virtual Machine on a Remote Server
You can create a virtual machine on a remote server, but certain requirements must be met for the server.

• You have login credentials for the server where you want to create the virtual machine.
• The server is defined in the Virtual Machine Library.
• Sufficient space exists on the server to accommodate the virtual machine.
• The remote server is running VMware Workstation Pro, VMware ESXi or VMware vCenter Server.
• Confirm that the firmware type with which you plan to configure the virtual machine is supported by the guest operating

system. See Configure a Firmware Type.

IMPORTANT
Fusion does not include operating systems to install in virtual machines that you create. You must obtain the
operating system and any necessary product keys.

1. Select File > New.
A dialog box appears with the Select the Installation Method panel showing.

2. Click Create a virtual machine on a remote server.

3. Click Continue.

4. Select the server from the list in the Choose a Server window, and click Continue.

5. Optional: If the server supports folders, select a folder location for the virtual machine and click Continue.

6. Select the host and datastore from the Choose a Host and Datastore window, and click Continue.

7. Select a hardware version from the Choose a Hardware Version drop-down menu, and click Continue.

8. Select a network option for the virtual machine.
Option Description
Custom To configure a network connection for the virtual machine, use

the Custom drop-down menu to select a network option.
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Option Description
Do not use a network connection To create the virtual machine without a network connection,

select the Do not use a network connection option.

9. Select the guest operating system for the virtual machine and click Continue.

10. Select the firmware type and click Continue.

11. Configure the virtual disk by creating a virtual disk or use an existing virtual disk. If you create a virtual disk, use the
disk size slider to specify the size of the virtual disk and specify the bus type. Click Continue.
The Finish window appears.

12. Optional: Change the name of the new remote virtual machine.

13. Click Finish.
The new remote virtual machine appears in Virtual Machine Library under the remote server.

Create a Virtual Machine for Any Supported Operating System
You can create a virtual machine with a guest operating system that does not have an Easy Install option if the guest
operating system is supported by Fusion.

• If you are installing the guest operating system from an image file, verify that the image file is in a directory that is
accessible to the host system.
The image file is an ISO file or, for a macOS 10 virtual machine, a .app file. A .app file for a macOS 10 operating
system is available at the App Store.

• If you are installing the guest operating system from a physical disc, insert the operating system installation disc into
your Mac.

IMPORTANT
Fusion does not include any operating systems to install in virtual machines that you create. You must obtain the
operating system and any necessary product keys.

Unless you specify a file location for a virtual machine when you create it, Fusion saves the virtual machine package to a
default location, which can vary. See Default File Location of a Virtual Machine.

1. Select File > New.
A dialog box appears with the Select the Installation Method panel showing.

2. Locate an operating system installation disc image file and drag and drop it to Install from disc or image.
The Create a New Virtual Machine assistant starts.

3. Click Continue.

• If you are installing the guest operating system from an image file, verify that the image file is in a directory that is
accessible to the host system.

• If you are installing the guest operating system from a physical disc, insert the operating system installation disc
into your Mac.

IMPORTANT
Fusion does not include any operating systems to install in virtual machines that you create. You must obtain
the operating system and any necessary product keys.

If you are installing a Windows or Linux operating system, the Easy Install panel appears.

 69



 VMware Fusion Pro 13

4. Optional: Deselect Use Easy Install and click Continue to skip this panel of the assistant.

5. In the Finish panel, you can use default settings or customize the settings before powering on the virtual machine to
start the operating system installation.
Option Action
To create the virtual machine according to the
specifications listed in the Finish panel

1. Click Finish.
2. Indicate the location to save the virtual machine to or accept

the default, such as the your home directory/
Virtual Machines folder.

3. To share the virtual machine with other users on the Mac
host, save the virtual machine to the Shared folder and
select the Share this virtual machine with other users
on this Mac check box. Deselect the check box to save to
the Shared folder but not share the virtual machine with
other users on the Mac host. See Creating a Shared Virtual
Machine in Fusion.

To change disk size or other standard settings of the virtual
machine

1. Click Customize Settings.
2. Save the new virtual machine.
3. Make changes to the virtual machine’s disk size, processor

usage, removable devices, and other configurations on the
Settings window.

After you install the operating system in the virtual machine, install VMware Tools.

Power On the Boot Camp Partition as a Virtual Machine
You can use the contents of your Boot Camp partition at the same time that you are running your Mac operating system.
To do so, you use Fusion to power on the Boot Camp partition as a virtual machine.

You must have a Boot Camp partition in place before you start this procedure.

You must have administrator privileges to use the Boot Camp partition as a virtual machine.

Boot Camp is Apple software that enables an Intel-based Mac to run Windows operating systems. Boot Camp requires
you to choose between Mac or Windows at boot time. Boot Camp creates separate Mac and Windows partitions on
your hard disk to create a dual-boot environment. When you use your Windows Boot Camp partition as a Fusion virtual
machine, you can perform the following tasks:

• Use your Boot Camp virtual machine and your Mac without rebooting and switching between them.
• Share files between your Boot Camp virtual machine and your Mac, through shared folders, dragging files, or cutting

and pasting text.

NOTE
Windows reactivation complications can occur if you do not install VMware Tools. In such a case, if you
reactivate Windows in your Boot Camp virtual machine, and subsequently boot your Boot Camp partition
natively, you will be prompted to reactivate Windows. Reactivating Windows in your native Boot Camp partition
will result in your Boot Camp virtual machine requiring reactivation the next time you power it on, and so forth.
Installing VMware Tools solves this problem.

1. Select Window > Virtual Machine Library.

2. In the Virtual Machine Library window, click the Boot Camp thumbnail in the list of virtual machines, which identifies
the partition that Fusion detected.

3. Optional: Type your Mac password to access the Boot Camp partition.
Fusion creates a virtual machine that uses your Boot Camp partition and starts Windows.
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4. Follow the onscreen instructions and restart your virtual machine when prompted.
After Windows boots from your Boot Camp virtual machine, Fusion starts the installation of VMware Tools. VMware
Tools enables full virtual machine functionality and optimizes performance for your Boot Camp partition when you use
the partition as a virtual machine.

5. When the VMware Tools installation is complete, reboot your computer.

The first time you power on your Boot Camp virtual machine after you install VMware Tools, you must reactivate Windows.

Activate Windows in a Virtual Machine
In some cases you must activate Windows when you create, import, or migrate a virtual machine.

Install VMware Tools in the virtual machine before you activate Windows. VMware Tools keeps track of the activation
keys. Without VMware Tools installed, you must reactivate Windows each time you start up the virtual machine.

When you install Windows on a computer, you must activate it to use it. You activate Windows either over the Internet or
by phone with Microsoft Support. When the Windows operating system starts up, it checks to see if it is running on the
same hardware on which it was originally installed. If the hardware has changed, the Windows operating system requires
reactivation.

If you install Windows as a guest operating system in a new virtual machine, it requires activation the same as if you had
installed it on a physical computer. If you import a virtual machine from another source, if you run the Boot Camp partition
as a virtual machine, or if you migrate a physical PC to a virtual machine, Windows recognizes that the virtual hardware is
different.

The type of license you have for your Windows operating system can affect how you activate Windows after you start to
use it in a Fusion virtual machine.

• With an OEM license, Windows is tied directly to the hardware on which it was loaded by the manufacturer. Most pre-
installed versions of Windows have OEM licenses. OEM licenses generally cannot be transferred to another computer,
or to a virtual machine. If you use the Fusion Migrate Your PC feature to migrate one of these types of systems to
a virtual machine, you might be required to purchase a second license (or product key) from Microsoft. If a second
product key is required, you can get that through the Microsoft representative when you call Microsoft Support to
activate the operating system now residing in the virtual machine.

• With a retail license, when you buy Windows from a vendor, the license enables you to change platforms as often as
you want. In this case, you can reactivate Windows over the Internet, or by phone with Microsoft Support.

• With an enterprise license, you can move the operating system around freely.

• Activate Windows online or by phone.
The Help and Support item on the Windows Start menu enables you to find specific information about activation for
that version of the operating system.

If you have activation questions, contact Microsoft.

Upload a Virtual Machine to a Remote Server
When you upload a virtual machine to a remote server, Fusion Pro copies the virtual machine to the remote host and
datastore that you select. The original virtual machine remains on the host system.

Verify that the following conditions are met:

• You have login credentials for the server where you want to upload the virtual machine.
• The server is defined in the Virtual Machine Library.
• Sufficient space exists on the server to accommodate the virtual machine.
• The remote server is running VMware ESXi or VMware vCenter Server.
• The virtual machine is not encrypted. You cannot upload an encrypted virtual machine.
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• The virtual machine is not powered on or suspended. It must be powered off.

1. Select File > Connect to Server.

2. Enter the name of the host server or click the Recent Servers drop-down menu to select a server from the list.

3. Enter your login credentials and click Connect.

4. Select a virtual machine from the Virtual Machine Library.

5. Drag the virtual machine to the server.

6. In the Upload Virtual Machine dialog box, select a host and a datastore folder or shared folder.

7. Click Upload.

Download a Virtual Machine from a Remote Server
Your users can download a virtual machine from a remote server.

Verify that the following conditions are met:

• You have login credentials for the server where you want to download the virtual machine.
• The server is defined in the Virtual Machine Library.
• Sufficient space exists on the Mac host to accommodate the virtual machine.
• The remote server is running VMware ESXi or VMware vCenter Server.
• The virtual machine is not powered on or suspended. It must be powered off.

1. Select File > Connect to Server.

2. Enter the name of the host server or click the Recent Servers icon to select a server from the list of recently accessed
servers.

3. Enter your login credentials and click Connect.

4. Select a virtual machine from the remote server.

5. Drag the virtual machine to the Virtual Machine Library.

6. Click Save.

Importing Windows Virtual Machines
You can import into Fusion virtual machines that you created with Parallels Desktop, as well as virtual machines using the
Open Virtualization Format (OVF).

Fusion can import virtual machines created with Parallels or OVF.

When you import a Parallels virtual machine, Fusion creates a VMware virtual machine based on the original virtual
machine. The import process is nondestructive, so you can continue to use the original source virtual machine with the
product you use to create the source virtual machine.

Fusion can also import the contents of the Boot Camp partition as a virtual machine, creating a completely new VMware
virtual machine based on the partition. This is a separate entity, not tied to the partition like the virtual machine described
in Power On the Boot Camp Partition as a Virtual Machine. You can then reclaim the space by deleting the Boot Camp
partition, which restores the drive to a single volume.

Supported Guest Operating Systems for Import
A guest operating system is the system that runs in a virtual machine. Fusion supports importing Parallels virtual
machines with certain operating systems.
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Fusion supports importing the following operating systems:

• Microsoft Windows 10
• Microsoft Windows 8
• Microsoft Windows 7
• Microsoft Windows Vista
• Microsoft Windows XP Service Pack 3
• Microsoft Windows XP Service Pack 2

Virtual machines must be powered off before you import them.

If your copy of Windows was not licensed with a volume-license key, you might need to reactivate it when it starts inside
Fusion.

How Importing Affects Settings
You might have to modify the imported virtual machine, depending on settings and virtual hardware.

The imported VMware virtual machine contains an exact copy of the disk state from your source virtual machine, except
for some hardware-dependent drivers and sometimes the mapped drive letters. Imported virtual machines are created
with IDE or SCSI virtual disks. You can manually change the disk to SATA or NVMe when the import process is complete.

Settings from the Source Computer

The following settings from the source computer remain identical:

• Operating system configuration (computer name, security ID, user accounts, profiles and preferences, and so on)
• Applications and data files
• The volume serial number of each disk partition

Because the target and the source virtual machines or system images have the same identities (name, SID, and so on),
running both on the same network can result in conflicts. To redeploy the source virtual machine or system image, ensure
that you do not run both the source and target images or virtual machines on the same network at the same time.

For example, if you use the Fusion Importer to test the viability of running a Parallels virtual machine as a VMware virtual
machine without first decommissioning the original non-VMware machine, you must resolve the duplicate ID problem first.

Changes to Virtual Hardware

Most imported applications should function correctly in the VMware virtual machine because their configuration and
data files have the same location as the source virtual machine. Applications might not work if they depend on specific
characteristics of the underlying hardware such as the serial number or the device manufacturer.

When you troubleshoot after a virtual machine import, notice the following potential hardware changes:

• CPU model and serial numbers (if activated) can be different after the import. They correspond to the physical
computer hosting the VMware virtual machine.

• Ethernet adapter can be different (AMD PCNet or VMXnet) with a different MAC address. Each interface’s IP address
must be individually reconfigured.

• Graphics card can be different (VMware SVGA card).
• Numbers of disks and partitions are the same, but each disk device can have a different model and different

manufacturer strings.
• Primary disk controllers can be different from the source machine’s controllers.
• Applications might not work if they depend on devices that are not available from within a virtual machine.
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Import a Parallels Virtual Machine
You can import existing third-party virtual machines and run them in Fusion.

1. Select File > Import.

2. Browse to the existing virtual machine you want to import and click Open.

3. Type the name for the imported virtual machine in the Save As text box and indicate where to save it.
The default destination is the Virtual Machines folder created by Fusion.
Fusion displays the disk space needed for the import, and the space available on the current disk.

4. Click Import.
When the import is complete, the virtual machine appears in the virtual machine list, in the powered-off state.

5. Click Finish.
Fusion installs VMware Tools after the virtual machine powers on, and reboots the system after the Tools installation is
complete.

You have a separate Fusion version of the third-party virtual machine.

Import the Boot Camp Partition
You can import the Boot Camp partition as a virtual machine, creating a VMware virtual machine that copies the partition.

Power on the boot camp partition. See Power On the Boot Camp Partition as a Virtual Machine.

1. Select Window > Virtual Machine Library.

2. In the Virtual Machine Library window, control-click the Boot Camp virtual machine and click Import.

3. Change the name for the imported virtual machine in the Save As text box from the default Boot Camp to something
unique, and indicate where to save it.
The default destination is the Virtual Machines folder created by Fusion.
Fusion displays the disk space needed for the import, and the space available on the current disk.

4. Click Import.
When the import is complete, the virtual machine appears in the virtual machine list, in the powered-off state.

5. Click Finish.
Fusion installs VMware Tools after the virtual machine powers on, and reboots the system after the Tools installation is
complete.

Import an Open Virtualization Format Virtual Machine on Intel-based Mac
You can import an Open Virtualization Format (OVF) virtual machine and run it in Fusion. You can import both .ovf and
.ova files.

Download or copy the OVF virtual machine file (.ovf or .ova file) to a location that is accessible to your Mac.

Fusion converts the virtual machine from OVF format to VMware runtime (.vmx) format.

OVF is a platform-independent, efficient, extensible, and open packaging and distribution format for virtual machines. For
example, you can import OVF virtual machines exported from Workstation Pro into Fusion. You can import OVF 1.x files
only.
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You can also use the standalone OVF Tool to convert an OVF virtual machine to VMware runtime format. For information
about using the OVF Tool, see the OVF Tool User Guide.

1. Select File > Import.

2. Click Choose file and browse to the .ovf or .ova file and click Open.

3. Type the name for the imported virtual machine in the Save As text box and indicate where to save it.
The default destination is the Virtual Machines folder created by Fusion.

4. Click Save.
Fusion performs OVF specification conformance and virtual hardware compliance checks. A status bar indicates the
progress of the import process.

NOTE
You must use the graphical user interface to import an OVF virtual machine file with vTPM placeholder. You
cannot import such OVF files using the OVF tool command line. If the OVF file contains a vTPM device
placeholder, the Choose Encryption window appears.

5. If the Choose Encryption window appears, choose an encryption option, enter a password, and then click Continue.

After the import is complete, the virtual machine appears in the virtual machine library and in a separate virtual machine
window. The virtual machine is shut down.

NOTE
If the OVF file contains a vTPM placeholder, Fusion adds the vTPM device to the virtual machine after it is
encrypted.

Export a Virtual Machine to OVF Format on Intel-based Mac
You can export a virtual machine from Fusion Pro to Open Virtualization Format (OVF). You can export both .ovf and .ova
files.

• Verify that the virtual machine is not encrypted. You cannot export an encrypted virtual machine to OVF format.
• Verify that the virtual machine is powered off.

Fusion Pro converts the virtual machine from VMware runtime (.vmx) format to OVF format.

OVF is a platform-independent, efficient, extensible, and open packaging and distribution format for virtual machines.
OVF format provides a complete specification of the virtual machine, including the full list of required virtual disks and
the required virtual hardware configuration. The virtual hardware configuration includes CPU, memory, networking, and
storage. An administrator can quickly provision an OVF-formatted virtual machine with little or no intervention.

You can also use the standalone version of OVF Tool to convert a virtual machine that is in VMware runtime format to
an OVF virtual machine. The standalone version of OVF Tool is installed in the Fusion Pro installation directory under
Contents/Library/VMware OVF Tool . See the OVF Tool User Guide documentation on the VMware Web site for
information about using OVF Tool.

1. Select the virtual machine and select File > Export to OVF.

2. Enter a name for the OVF file and specify a directory in which to save it.

3. Specify whether to export the virtual machine as an OVF, a folder with separate files, or as an OVA, a single-file
archive.

4. Click Export to start the OVF export process.
The export process can take several minutes. A status bar indicates the progress of the export process.
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Export a Virtual Machine with vTPM to OVF Format on Intel-based Mac
You can manually export a virtual machine with vTPM device from Fusion Pro to Open Virtualization Format (OVF) using
the command line of OVF Tool 4.5 or later. The OVF Tool is bundled with Fusion. You can export to both .ovf and .ova
files.

• Remove any application in the virtual machine that uses the vTPM device.
NOTE
If you do not remove an application in the virtual machine that uses the vTPM, the application might not
function properly when you later import the virtual machine with the vTPM device.

• Verify that the virtual machine is powered off.

A virtual machine with vTPM is always encrypted. You cannot directly convert a virtual machine with vTPM device in
Fusion Pro from VMware runtime (.vmx) format to OVF format because the OVF Tool does not support export of an
encrypted virtual machine. Before you proceed with the manual export, you must manually remove the vTPM device
and decrypt the virtual machine. After you decrypt the virtual machine, export the virtual machine to OVF with a vTPM
placeholder.

The following steps guide you through the process of manually removing the vTPM, decrypting the virtual machine, and
then exporting to OVF using command line.

1. To remove the vTPM, perform the following steps:
a) Select the required virtual machine in the Virtual Machine Library window and click Settings.
b) Under Removable Devices in the Settings window, click Trusted Platform Module.
c) Click Remove Trusted Platform module.
d) To confirm the removal of the vTPM, click Remove.

2. To remove the virtual machine encryption, perform the following steps:
a) Select the required virtual machine in the Virtual Machine Library window and click Settings.
b) Under Other in the Settings window, click Encryption.
c) Select Virtual machine is not encrypted.
d) Type the password for the virtual machine.
e) Click OK.

3. To export the virtual machine to OVF with an added vTPM placeholder, use the following command in the OVF Tool
bundled with Fusion:
main % '/Applications/VMware Fusion.app/Contents/Library/VMware OVF Tool/ovftool' --X:logLevel=verbose --

exportFlags=extraconfig --allowExtraConfig --addDevice:vtpm '<path of the virtual machine vmx file with

 the file name>' '<path to export the ovf file with the file name>'

The following is an example command to export a virtual machine named vm:
main % '/Applications/VMware Fusion.app/Contents/Library/VMware OVF Tool/ovftool' --X:logLevel=verbose

 --exportFlags=extraconfig --allowExtraConfig --addDevice:vtpm '/Users/<userid>/Virtual Machines.local-

ized/vm.vmwarevm/vm.vmx' '/Users/<userid>/Virtual Machines.localized/ovfExportPath/vm.ovf'

NOTE
Fusion does not provide a graphical user interface to export a virtual machine with a vTPM placeholder. A
user must use the command line to export a virtual machine with a vTPM placeholder.

After you export the virtual machine, the OVF file shows the added vTPM placeholder in the following format:

<Item ovf:required="false">

 <rasd:AutomaticAllocation>false</rasd:AutomaticAllocation>

 <rasd:ElementName>Virtual TPM</rasd:ElementName>

 <rasd:InstanceID>14</rasd:InstanceID>
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 <rasd:ResourceSubType>vmware.vtpm</rasd:ResourceSubType>

 <rasd:ResourceType>1</rasd:ResourceType>

</Item>

 Installing and Using VMware Tools
VMware Tools is a suite of utilities that enhances the performance of the virtual machine's guest operating system and
improves management of the virtual machine.

For example, the following features are just some of the features that are available only if VMware Tools is installed:

• Significantly faster graphics performance and Windows Aero on operating systems that support Aero
• The Unity feature, which enables an application in a virtual machine to appear on the host desktop like any other

application window
• Shared folders between host and guest file systems
• Copying and pasting text, graphics, and files between the virtual machine and the host or client desktop
• Improved mouse performance
• Synchronization of the clock in the virtual machine with the clock on the host or client desktop
• Scripting that helps automate guest operating system operations
• Enables guest customization for virtual machines.

Although the guest operating system can run without VMware Tools, you would lose important functionality and
convenience.

You can use the Windows Easy Install or Linux Easy Install feature to install VMware Tools as soon as the operating
system is finished installing.

In the case of Windows Easy Install or Linux Easy Install, Fusion installs VMware Tools as soon as it finishes installing
the operating system. When you finish installing the operating system in your new virtual machine by any other means
(rebooting the virtual machine when prompted), install VMware Tools.

Not all features are supported on all guests.

You can use the VMware Tools control panel to set various options that optimize your guest operating system for use in a
virtual machine.

NOTE
If you have not downloaded the latest version of the VMware Tools ISO file or the VMware Tools ISO file for
that operating system, you are prompted to download the file from https://packages-prod.broadcom.com/tools/
frozen/. Alternatively, on the host, from the VMware Fusion menu bar, select Virtual Machine >  Install VMware
Tools. You will get a link to download the specific VMware Tools ISO file.

Installing or Upgrading VMware Tools
Installing VMware Tools is part of the process of creating a new virtual machine, and upgrading VMware Tools is part of
the process of keeping your virtual machine up to current standards.

How you install or upgrade VMware Tools depends on the operating system and the source you use for the tools.

VMware upgrades VMware Tools frequently to support new devices and to add enhancements that improve the
performance of your virtual machines. When you upgrade Fusion, you should also upgrade VMware Tools.

In Windows virtual machines, you can set VMware Tools to notify you when an upgrade is available. If this notification

option is enabled, the VMware Tools icon in the Windows taskbar includes a yellow caution icon ( ) when a VMware
Tools upgrade is available.
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Manually Install VMware Tools on Windows

You can manually install VMware Tools on a windows virtual machine. The Guest operating systems that support VMware
Tools are Windows 2000 and earlier, Windows XP, Windows Server 2003, Windows Vista and later versions.

• Power on the virtual machine.
• Verify that the guest operating system is running.
• To determine whether you have the latest version of VMware Tools, look on the Summary tab for the virtual machine.
• For vSphere virtual machines, determine whether you have the latest version of VMware Tools. In the vSphere Client

inventory, select the virtual machine and click the Summary tab.
• If you connected the virtual machine’s virtual CD/DVD drive to an ISO image file when you installed the operating

system, change the setting so that the virtual CD/DVD drive is configured to autodetect a physical drive.
The autodetect setting enables the virtual machine's first virtual CD/DVD drive to detect and connect to the VMware
Tools ISO file for a VMware Tools installation. This ISO file is detected as a physical CD by your guest operating
system. Use the virtual machine settings editor to set the CD/DVD drive to autodetect a physical drive.

• For Workstation Player, Fusion, and Workstation Pro virtual machines, if you connected the virtual machine’s virtual
CD/DVD drive to an ISO image file when you installed the operating system, change the setting so that the virtual CD/
DVD drive is configured to autodetect a physical drive.
The autodetect setting enables the virtual machine's first virtual CD/DVD drive to detect and connect to the VMware
Tools ISO file for a VMware Tools installation. This ISO file looks like a physical CD to your guest operating system.
Use the virtual machine settings editor to set the CD/DVD drive to autodetect a physical drive.

• Log in as an administrator unless you are using an older Windows operating system. Any user can install VMware
Tools in a Windows 95, Windows 98, or Windows ME guest operating system. For operating systems later than these,
you must log in as an administrator.

• If you use vSphere and plan to install the Guest Introspection Thin Agent driver, see the system requirements listed
in the vShield Quick Start Guide. The vShield component is not installed by default. You must perform a custom
installation and include that component.

• If you plan to install the Guest Introspection Thin Agent driver, see the system requirements listed in the vShield Quick
Start Guide. The vShield component is not installed by default. You must perform a custom installation and include that
component.

• The AppDefense component is not installed by default. You must perform a custom installation and include that
component.

For Windows 2000 and later, VMware Tools installs a virtual machine upgrade helper tool. This tool restores the network
configuration if you upgrade the virtual machine compatibility from ESX/ESXi 3.5 to ESX/ESXi 4.0 and later or from
Workstation 5.5 to Workstation 6.0 and later.

For Windows 2000 and later, VMware Tools installs a virtual machine upgrade helper tool. This tool restores the network
configuration if you upgrade from ESX/ESXi 3.5 and later compatibility (hardware version 4) to ESX/ESXi 4.0 and later
compatibility (hardware version 7).

1. Select the menu command to mount the VMware Tools virtual disk on the guest operating system.
VMware Product Action
vSphere Client (HTML5) Right-click the virtual machine and select Guest OS > Install (or

Upgrade) Tools
vSphere Client Inventory > Virtual Machine > Guest > Install/Upgrade

VMware
vSphere Web Client Right-click the virtual machine and select Guest OS > Install (or

Upgrade) VMware Tools
Fusion Virtual Machine > Install (or Upgrade) VMware Tools
Workstation Pro VM > Install (or Upgrade) VMware Tools
Workstation Player Player > Manage > Install (or Upgrade) VMware Tools
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2. If you are using vCenter Server and are performing an upgrade or reinstallation, in the Install/Upgrade VMware Tools
dialog box, select Interactive Tools Installation or Interactive Tools Upgrade and click OK.
The process starts by mounting the VMware Tools virtual disc on the guest operating system.

3. On the host, from the Workstation Pro menu bar, select VM > Install VMware Tools.
If an earlier version of VMware Tools is installed, the menu item is Update VMware Tools.

4. On the host, from the  menu bar, select Player > Manage > Install VMware Tools.
If an earlier version of VMware Tools is installed, the menu item is Update VMware Tools.

5. On the host, from the  menu bar, select Virtual Machine > Install VMware Tools.
If an earlier version of VMware Tools is installed, the menu item is Update VMware Tools.

6. In the vSphere Client inventory, right-click the virtual machine and select Guest > Install/Upgrade VMware Tools.

7. Right-click the virtual machine in the inventory and select All vCenter Actions > Guest OS > Install/Upgrade
VMware Tools.

8. Mount the VMware Tools virtual disc on the guest operating system.
VMware Product Action
vSphere Client Inventory > Virtual Machine > Guest > Install/Upgrade

VMware Tools
vSphere Web Client Right-click the virtual machine and select Guest OS > Install/

Upgrade VMware Tools.

1. To locate a virtual machine, select a datacenter, folder,
cluster, resource pool, host, or vApp.

2. Click the Virtual Machines tab.

9. If you are performing an upgrade or reinstallation, in the Install/Upgrade VMware Tools dialog box, select Interactive
Tools Installation or Interactive Tools Upgrade and click OK.
The process starts by mounting the VMware Tools virtual disc on the guest operating system.

10. On the host, from the VMware Fusion menu bar, select Virtual Machine > Install VMware Tools.
If an earlier version of VMware Tools is installed, the menu item is Update VMware Tools.
If the VMware Tools ISO file for the guest operating system is not available with the product, you get a pop-up with a
link to download the VMware Tools ISO file.

11. If you are installing VMware Tools for the first time, click OK on the Install VMware Tools information page.
If autorun is enabled for the CD-ROM drive on the guest operating system, the VMware Tools installation wizard starts.
To launch the wizard manually if autorun is not enabled, click Start > Run and enter D:\setup.exe, where D: is your
first virtual CD-ROM drive. Use D:\setup64.exe for 64-bit Windows guest operating system.

NOTE
If you use Windows on ARM for the virtual machine, perform the following steps to install or upgrade the
VMware Tools:

1. Open Windows Terminal as an administrator.
2. Navigate to the directory containing the ISO image of the VMware Tools for Windows on ARM.
3. Type setup.ps1, and then press Enter.
4. For silent installation, run the following command: setup.ps1 -Silent
5. To install specific drivers in VMware Tools, specify the drivers when running the install command in the

following format: setup.ps1 -Drivers <driver1>,<driver2>,...
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Currently, for Windows on ARM, the VMware Tools is available with the following drivers:

• VMXNet3
• SVGA

12. Follow the on-screen prompts.

To install nondefault components or remove certain components, such as the Guest Introspection Thin Agent driver,
select the Custom setup.

If you use vSphere, to install nondefault components, such as the Guest Introspection Thin Agent driver, select the
Custom setup.

NOTE
If NSX Guest Introspection (GI) drivers are installed and you are using ‘Custom’ installation option in the
Tools installer for upgrade, ensure that all installed GI drivers are upgraded during upgrade.

13. If the New Hardware wizard appears, follow the prompts and accept the defaults.

NOTE
If you are installing a beta or RC version of VMware Tools and you see a warning that a package or driver is
not signed, click Install Anyway to complete the installation.

14. When prompted, reboot the virtual machine.

The VMware Tools label on the Summary tab changes to OK.

If you are using vCenter Server, the VMware Tools label on the Summary tab changes to OK.

If you upgraded VMware Tools as part of a larger, system-wide upgrade, next determine whether to upgrade the virtual
machines in your environment. To review and compare the hardware available for different compatibility levels, see
Hardware Features Available with Virtual Machine Compatibility Levels.

If you upgraded VMware Tools as part of a vSphere upgrade, next determine whether to upgrade the virtual machines in
your environment. To review and compare the hardware available for different compatibility levels, see the vSphere Virtual
Machine Administration documentation.

If a new virtual hardware version is available for the virtual machine, upgrade the virtual hardware.

Manually Install VMware Tools on Linux

You can manually install VMware Tools on a Linux virtual machine using the command line. For later Linux distributions,
use the integrated open-vm-tools version.

• Power on the virtual machine.
• Verify that the guest operating system is running.
• Because the VMware Tools installer is written in Perl, verify that Perl is installed in the guest operating system.
• To determine whether you have the latest version of VMware Tools, look on the Summary tab for the virtual machine.
• For vSphere virtual machines, determine whether you have the latest version of VMware Tools. In the vSphere Client

inventory, select the virtual machine and click the Summary tab.

For more information about Linux distributions supported by Open VM Tools, see Open VM Tools (README) and the
VMware Compatibility Guide at https://www.vmware.com/resources/compatibility/search.php.
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VMware Tar Tool for Linux virtual machine is feature-frozen at version 10.3.10, so the tar tools (linux.iso) included in  is
10.3.10 and will not be updated. Due to this change, the Install/Update/Reinstall VMware Tools menu is not available
for the following Linux virtual machines:

• Modern Linux distributions not officially supported by tar tools.
– Red Hat Enterprise Linux 8 and later releases.
– CentOS 8 and later releases.
– Oracle Linux 8 and later releases.
– SUSE Linux Enterprise 15 and later releases.

• Linux kernel version is 4.0 or later, and the version of the installed Open VM Tools is 10.0.0 or later.
• Linux kernel version is 3.10 or later, and the version of the installed Open VM Tools is 10.3.0 or later.

For the Linux virtual machines that have Open VM Tools installed but are not in the scope mentioned in the preceding
bullet, Install/Update/Reinstall VMware Tools menu is enabled, so that you can install bundled tar tools on top of Open
VM Tools to get Shared Folder (HGFS) feature support.

For old Linux virtual machines not supported by Open VM Tools, perform the following steps to install tar tools.

You can use the VMware Tools tar installer to install or upgrade VMware Tools. For virtual machines in a vSphere
environment, you can alternatively use VMware Tools operating system specific packages (OSPs) and open-vm-tools to
install and upgrade VMware Tools. With OSPs and open-vm-tools, you can use the native update mechanisms of your
operating system to download, install, and manage VMware Tools. For more information, see Operating System Specific
Packages for Linux Guest Operating Systems.

1. Select the menu command to mount the VMware Tools virtual disk on the guest operating system.
VMware Product Action
vSphere Client (HTML5) Right-click the virtual machine and select Guest OS > Install (or

Upgrade) Tools
vSphere Client Inventory > Virtual Machine > Guest > Install/Upgrade

VMware
vSphere Web Client Right-click the virtual machine and select Guest OS > Install (or

Upgrade) VMware Tools
Fusion Virtual Machine > Install (or Upgrade) VMware Tools
Workstation Pro VM > Install (or Upgrade) VMware Tools
Workstation Player Player > Manage > Install (or Upgrade) VMware Tools

2. On the host, from the Workstation Pro menu bar, select VM > Install VMware Tools.
If an earlier version of VMware Tools is installed, the menu item is Update VMware Tools.

3. On the host, from the  menu bar, select Player > Manage > Install VMware Tools.
If an earlier version of VMware Tools is installed, the menu item is Update VMware Tools.

4. On the host, from the  menu bar, select Virtual Machine > Install VMware Tools.
If an earlier version of VMware Tools is installed, the menu item is Update VMware Tools.

5. In the vSphere Client inventory, right-click the virtual machine and select Guest > Install/Upgrade VMware Tools.

6. Right-click the virtual machine in the inventory and select All vCenter Actions > Guest OS > Install/Upgrade
VMware Tools.

7. Mount the VMware Tools virtual disc on the guest operating system.
VMware Product Action
vSphere Client Inventory > Virtual Machine > Guest > Install/Upgrade

VMware Tools
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VMware Product Action
vSphere Web Client Right-click the virtual machine and select Guest OS > Install/

Upgrade VMware Tools.

1. To locate a virtual machine, select a datacenter, folder,
cluster, resource pool, host, or vApp.

2. Click the Virtual Machines tab.

8. If you are performing an upgrade or reinstallation, in the Install/Upgrade VMware Tools dialog box, select Interactive
Tools Installation or Interactive Tools Upgrade and click OK.
The process starts by mounting the VMware Tools virtual disc on the guest operating system.

9. On the host, from the VMware Fusion menu bar, select Virtual Machine > Install VMware Tools.
If an earlier version of VMware Tools is installed, the menu item is Update VMware Tools.
If the VMware Tools ISO file for the guest operating system is not available with the product, you get a pop-up with a
link to download the VMware Tools ISO file.

10. In the virtual machine, open a terminal window. Run the mount command with no arguments to determine whether
your Linux distribution automatically mounted the VMware Tools virtual CD-ROM image.
If the CD-ROM device is mounted, the CD-ROM device and its mount point are listed in a manner similar to the
following output:
/dev/cdrom on /mnt/cdrom type iso9660 (ro,nosuid,nodev)

If the VMware Tools virtual CD-ROM image is not mounted, mount the CD-ROM drive.
a) If a mount point directory does not already exist, create it.

mkdir /mnt/cdrom

Some Linux distributions use different mount point names. For example, on some distributions the mount point
is /media/VMware Tools rather than /mnt/cdrom. Modify the command to reflect the conventions that your
distribution uses.

b) Mount the CD-ROM drive.
mount /dev/cdrom /mnt/cdrom

Some Linux distributions use different device names or organize the /dev directory differently. If your CD-ROM
drive is not /dev/cdrom or if the mount point for a CD-ROM is not /mnt/cdrom, modify the command to reflect
the conventions that your distribution uses.

11. Change to a working directory, for example, /tmp.
cd /tmp

12. Delete any previous vmware-tools-distrib directory before you install VMware Tools.
The location of this directory depends on where you placed it during the previous installation. Often this directory is
placed in /tmp/vmware-tools-distrib.
List the contents of the mount point directory and note the file name of the VMware Tools tar installer.
ls mount-point

Uncompress the installer.
tar zxpf /mnt/cdrom/VMwareTools-x.x.x-yyyy.tar.gz

The value x.x.x is the product version number, and yyyy is the build number of the product release.

13. If necessary, unmount the CD-ROM image.
umount /dev/cdrom 

If your Linux distribution automatically mounted the CD-ROM, you do not need to unmount the image.
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14. Run the installer and configure VMware Tools as a root user
cd vmware-tools-distrib

sudo ./vmware-install.pl

Follow the prompts to accept the default values, if appropriate for your configuration.

Follow the instructions at the end of the script.

Depending on the features you use, these instructions can include restarting the X session, restarting networking,
logging in again, and starting the VMware User process. You can alternatively reboot the guest operating system to
accomplish all these tasks.

Usually, the vmware-config-tools.pl configuration file runs after the installer file finishes running. If you attempt
to install a tar installation over an RPM installation, or the reverse, the installer detects the previous installation and
must convert the installer database format before continuing.

NOTE
For newer Linux distributions, users are prompted to choose the integrated open-vm-tools.

If you upgraded VMware Tools as part of a larger, system-wide upgrade, next determine whether to upgrade the virtual
machines in your environment. To review and compare the hardware available for different compatibility levels, see
Hardware Features Available with Virtual Machine Compatibility Levels.

If you upgraded VMware Tools as part of a vSphere upgrade, next determine whether to upgrade the virtual machines in
your environment. To review and compare the hardware available for different compatibility levels, see the vSphere Virtual
Machine Administration documentation.

If a new virtual hardware version is available for the virtual machine, upgrade the virtual hardware.

 Manually Install VMware Tools on macOS

You can install or upgrade VMware Tools on a macOS virtual machine using an installer assistant.

• Power on the virtual machine.
• Verify that the guest operating system is running.

If you use VMware Fusion or ESXi on a computer with an Apple label, you can create Mac OS X Server (10.5 or later)
virtual machines and install VMware Tools.

For macOS VMs, the VMware Tools contains the following two kernel extension modules that are vital for certain features
when running on Fusion:

• com.vmware.kext.vmhgfs: For hgfs or shared folder support
• com.vmware.kext.VMwareGfx: For VMware video driver

NOTE
macOS Big Sur onwards, Apple has deprecated support for KEXT kernel extension modules. The KEXT
modules are not loaded automatically when you install the VMware tools. If you want to use the features
associated with the kernel extension modules, ensure that you manually allow the loading of VMware kernel
extension modules when prompted with an option.

1. Select the menu command to mount and open the VMware Tools virtual disc on the guest operating system.
VMware Product Menu Command
vSphere Client Right-click the virtual machine and select Guest OS > Install

VMware Tools... or Guest OS > Upgrade VMware Tools...
and select Interactive Tools Installation or Interactive Tools
Upgrade

Fusion Virtual Machine > Install (or Upgrade) VMware Tools
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2. In the vSphere Client inventory, right-click the virtual machine and select Guest > Install/Upgrade VMware Tools.

3. Right-click the virtual machine in the inventory and select All vCenter Actions > Guest OS > Install/Upgrade
VMware Tools.

4. Mount the VMware Tools virtual disc on the guest operating system.
VMware Product Action
vSphere Client Inventory > Virtual Machine > Guest > Install/Upgrade

VMware Tools
vSphere Web Client Right-click the virtual machine and select Guest OS > Install/

Upgrade VMware Tools.

1. To locate a virtual machine, select a datacenter, folder,
cluster, resource pool, host, or vApp.

2. Click the Virtual Machines tab.

5. If you are performing an upgrade or reinstallation, in the Install/Upgrade VMware Tools dialog box, select Interactive
Tools Installation or Interactive Tools Upgrade and click OK.
The process starts by mounting the VMware Tools virtual disc on the guest operating system.

6. On the host, from the VMware Fusion menu bar, select Virtual Machine > Install VMware Tools.
If an earlier version of VMware Tools is installed, the menu item is Update VMware Tools.
If the VMware Tools ISO file for the guest operating system is not available with the product, you get a pop-up with a
link to download the VMware Tools ISO file.

7. On the Connect VMware Tools installer CD pop-up, click Install

8. On the VMware Tools dialog box, click Install VMware Tools.
a) On the Welcome to the VMware Tools Installer page, click Continue.
b) Select Standard Install on 'Macintosh HD', and then click Install.
If this is a first-time installation on macOS Big Sur or later, a System Extension Blocked pop-up will appear for
each .kext in the VMware Tools release.

9. If you do not want to load the kernel extension modules, click OK.

NOTE
If you do not load the kernel extension modules, the features associated with the kernel extension modules
will not work.

10. If you want to load the kernel extension modules, perform the following steps.
a) Click Open Security Preference.
b) Unlock the Security & Privacy user interface.
c) For the System software from developer 'VMware, Inc.' was blocked from loading option, click Allow.
d) For the restart prompt, click Not now.
e) Re-lock the Security & Privacy user interface.
f) Close the Security & Privacy window.

The VMware Tools installation completes successfully.

11. Click Restart to reboot the system with the KEXT modules loaded.

12. Optionally, to verify that the VMware KEXT modules are loaded, log in and run the following command:
sudo kextstat --list-only | grep -i vmware
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 Repair or Change Modules in Windows Virtual Machines
If you have problems with enhanced graphics display or mouse actions or with features that depend on VMware Tools,
you might need to repair or modify installed modules.

Occasionally, some new modules are not installed during a VMware Tools upgrade. You can manually install new modules
by modifying installed modules.

Use the guest operating system’s Programs and Features item in the Windows Control Panel to repair or modify
VMware Tools.

 Uninstalling VMware Tools
When the upgrade process of VMware Tools is incomplete, you can uninstall and then reinstall VMware Tools.

• Power on the virtual machine.
• Log in to the guest operating system.

In a vSphere and open-vm-tools deployment, if you decide to use packages specific to Linux operating systems to
manage VMware Tools, and if you already used vSphere to install VMware Tools, you must uninstall the existing VMware
Tools. For more information about Linux OSPs for VMware Tools, see Operating System Specific Packages for Linux
Guest Operating Systems.

1. Select a method to uninstall VMware Tools.
Operating System Action
Windows 7, 8, 8.1, or Windows 10 In the guest operating system, select Programs > Uninstall a

program.
Windows Vista and Windows Server 2008 In the guest operating system, select Programs and Features >

Uninstall a program.
Windows XP and earlier In the guest operating system, select Add/Remove Programs.
Linux Log in as root and enter vmware-uninstall-tools.pl in

a terminal window.
Mac OS X, OS X, or macOS Use the Uninstall VMware Tools application, found in /

Library/Application Support/VMware Tools.
Windows on ARM Open Windows Terminal, navigate to the directory containing

the ISO image of the VMware Tools, and then type the following:
setup.ps1 -Uninstall

2. Restart the guest operation system.

Reinstall VMware Tools.

Cloning Virtual Machines with Fusion Pro
Installing a guest operating system and applications can be time consuming. With Fusion Pro, you can make many copies
of a virtual machine from a single installation and configuration process.

Clones are useful when you must deploy many identical virtual machines to a group. For example, an MIS department can
clone a virtual machine that has a suite of preconfigured office applications for each employee. You can also configure
a virtual machine that has a complete development environment and clone it repeatedly as a baseline configuration for
software testing.

The existing virtual machine is called the parent virtual machine. Two types of clones are available for creation: linked
clones and full clones. Linked clones are created more quickly than full clones, but are dependent on the parent virtual
machine. Full clones take longer to create, but are completely independent of the parent virtual machine.
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Changes made to a clone do not affect the parent virtual machine, and changes made to the parent virtual machine do not
appear in a clone. The MAC address for a clone is different from the parent virtual machine.

Using Linked Clones
A linked clone is a copy of a virtual machine that shares virtual disks with the parent virtual machine in an ongoing
manner. You can create linked clones only by using Fusion Pro.

Because a linked clone is created from a snapshot of the parent, disk space is conserved and multiple virtual machines
can use the same software installation. All files available on the parent at the moment you take the snapshot continue to
remain available to the linked clone.

Ongoing changes to the virtual disk of the parent do not affect the linked clone, and changes to the disk of the linked clone
do not affect the parent. A linked clone must have access to the parent. Without access to the parent, you cannot use a
linked clone.

Because linked clones are created quickly, you can create a unique virtual machine for each task. You can also share a
virtual machine with other users by storing the virtual machine on your local network where other users can quickly make
a linked clone. For example, a support team can reproduce a bug in a virtual machine, and an engineer can quickly make
a linked clone of that virtual machine to work on the bug.

You can make a linked clone from a linked clone, but the performance of the linked clone degrades. It is recommended
that you make a new linked clone of the original parent virtual machine, when possible. If you make a full clone from a
linked clone, the full clone is an independent virtual machine that does not require access to the linked clone or its parent.

IMPORTANT
You cannot delete a linked clone snapshot without destroying the linked clone. You can safely delete the
snapshot only if you also delete the clone that depends on it. Also, moving the linked clone or the parent virtual
machine breaks the connection between the linked clone and parent.

Since a linked clone has a dependency on the parent, you cannot delete a parent if it has a clone. You must first delete all
linked clones and snapshots before you can delete the parent virtual machine.

Using Full Clones
A full clone is a complete and independent copy of a virtual machine. A full clone shares nothing with the parent virtual
machine after the cloning operation. Ongoing operation of a full clone is separate from the parent virtual machine. You can
create full clones only with Fusion Pro.

Because a full clone does not share virtual disks with the parent virtual machine, full clones generally perform better than
linked clones. Full clones take longer to create than linked clones. Creating a full clone can take several minutes if the files
involved are large.

Because a full clone duplicates only the state of the virtual machine at the instant of the cloning operation, it does not have
access to snapshots of the parent virtual machine.

You can delete a full clone without affecting the parent virtual machine.
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Clone a Virtual Machine
You can clone virtual machines only if you have Fusion Pro. You do not need to find and manually copy the parent virtual
machine files.

• Familiarize yourself with the types of clones. See Using Linked Clones and Using Full Clones.
• If making a linked or full clone from the current state of a virtual machine, power down the virtual machine.

NOTE

• You can access cloning options from the right-click menu, Virtual Machine menu and snapshot manager.
• You cannot create linked clones from encrypted virtual machines.
• You cannot create linked or full clones from Boot Camp virtual machines.
• You can create full clones from encrypted virtual machines.
• You can create a cloned virtual machine from the powered off snapshot of the parent virtual machine.

1. Optional: To create a clone from the current state of a virtual machine:
a) Select a virtual machine from the Virtual Machine Library.
b) Click Virtual Machine and select either Create Full Clone or Create Linked Clone, depending on the type of

clone you want to create.
Fusion takes a snapshot of the selected virtual machine when creating a linked clone.

2. Optional: To create a clone from a snapshot of a virtual machine:
a) Select a virtual machine from the Virtual Machine Library.
b) Click Snapshots.
c) Select a snapshot and right-click. Select either Create Full Clone or Create Linked Clone, depending on the type

of clone you want to create.

3. Type a name for the clone and click Save.
A full clone can take several minutes to create, depending on the size of the virtual disk that is being duplicated.

The clone appears in the Virtual Machine Library.

A linked clone virtual machine is designated by a clone badge in the Virtual Machine Library. The parent virtual machine
name is shown under the virtual machine name in the Virtual Machine Library display. In snapshot manager, a snapshot
which has a linked clone virtual machine is designated with a snapshot badge.

If the parent virtual machine uses a static IP address, change the static IP address of the clone before the clone connects
to the network to prevent IP address conflicts.

Although the cloning process creates a new MAC address for the clone, other configuration information, such as the
virtual machine name and static IP address configuration, is identical to that of the parent virtual machine.

Working with Your Virtual Machines
You can work with virtual machines in the same way that you can work with physical machines. Your Mac and virtual
machines can also interact.

Scan for Virtual Machines to Add to the Virtual Machine Library
You can quickly add multiple virtual machines to the Virtual Machine Library by initiating a scan.

You can manually add one or more virtual machines at a time to the Virtual Machine Library. For information about various
actions you can perform in the Virtual Machine Library, see Perform Actions on Your Virtual Machines from the Virtual
Machine Library Window. Alternatively, you can initiate a scan that automates the process of adding virtual machines to
the library. Using a scan to search for virtual machines eliminates the need for you to search for or remember the location
of each virtual machine.
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Fusion scans the preselected folders and all subfolders within the preselected folders. In the context of a scan, files with
the .vmx extension are considered virtual machines.

You can preselect which folders Fusion searches during a scan. When you initiate the scan, Fusion adds all the new
virtual machines it finds in the preselected folders to the Virtual Machine Library.

1. Select File > Scan for Virtual Machines.

2. Add and delete folders as necessary until the list of folders in the Scan for Virtual Machines dialog box meets your
needs.

Option Description
Add 1. Click +.

2. Search as necessary and select a folder to add.
3. Click Open.

The selected folder path is added to the Scan for Virtual
Machines dialog box.

Delete 1. Click a folder path in the Scan for Virtual Machines dialog
box.

2. Click -.
The selected folder path is deleted from the Scan for Virtual
Machines dialog box.

3. Click Scan.
A message appears that reports the number of virtual machines found and added to the Virtual Machine Library.

4. To view the list of virtual machines in the Virtual Machine Library, select Window > Virtual Machine Library.

Running Fusion and Virtual Machines
You can start up, shut down, suspend, pause, resume, restart, and reset your virtual machines. You can send power
commands to either the guest operating system or the virtual machine.

Open an Existing Virtual Machine
You can open an existing virtual machine from the Virtual Machine Library window or from the applications menu.

• Open a virtual machine from the Virtual Machine Library.
a) Select Window  > Virtual Machine Library.
b) Select a virtual machine from the list of recognized virtual machines.
c) Click the run button.

• Open a virtual machine from the applications menu
a) Click the applications menu status item ( ) in the Mac menu bar.

The applications menu appears, either displaying all the local virtual machines or the most recently accessed virtual
machine.
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b) If the applications menu displays the most recently accessed virtual machine, to select a different virtual machine,
click the Back arrow in the blue title bar and select another virtual machine.

c) Click the Resume or Start Up icon.

Browse for a Virtual Machine
One way to open an existing virtual machine is to find and open its package file.

1. Select File > Open.

2. In the file selection window, find and select the virtual machine package or configuration file for the virtual machine to
open.
Virtual machine package files have the extension .vmwarevm. Virtual machine configuration files have the extension
.vmx. You can view a file's extension by selecting File > Get info.

3. Click the Open button.

Fusion opens the virtual machine and powers it on.

Open a Virtual Machine From the Finder
You can open an existing virtual machine from its package file.

Unless you specify a file location for a virtual machine when you create it, Fusion saves the virtual machine package to a
default location, which can vary. See Default File Location of a Virtual Machine.

1. In the Finder, browse to the virtual-machine location, such as the default your home directory/Virtual
Machines folder, and find the package or configuration file for the virtual machine.
Virtual machine package files have the extension .vmwarevm. Virtual machine configuration files have the extension
.vmx.

2. Optional: You can view a file's extension by selecting File > Get info.

3. Double-click the virtual machine package or configuration file to open the virtual machine in Fusion.
If Fusion is not running, it starts automatically.

Start a Virtual Machine's Operating System
You can start a powered-off guest operating system in your virtual machine.

Certain actions, such as making changes to the virtual machine configuration, require having a virtual machine open
without the operating system powered on. After the action is complete, you can start the operating system.

• Start the virtual machine's operating system, depending on the state of the virtual machine and guest operating
system.

• If the virtual machine is not running, open the virtual machine from the Finder or Virtual Machine Library.

Fusion starts the virtual machine's operating system when you open the virtual machine.

• If the virtual machine is already open in Fusion, but the operating system is shut down, select Virtual Machine >
Start Up.
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Open a Virtual Machine Without Powering On
Some configuration tasks require that the virtual machine be powered off. In the Virtual Machine Library you can access a
virtual machine without powering it on.

1. In the Virtual Machine Library window, select the virtual machine to work on.

2. Optional: If the virtual machine to configure is displayed as Suspended or Powered on, open the virtual machine and
power it off.

• Use the Shut Down button in the toolbar
• Use the Shut Down command in the Virtual Machine menu.

Fusion opens the virtual machine without powering it on or opening it in a window.

3. Click the Settings button.

You can make changes to the settings that require that the virtual machine be powered off.

Shut Down a Virtual Machine's Operating System
You can shut down the guest operating system in your virtual machine.

You can use several methods to shut down your virtual machine's operating system. This is the preferred method.

• Select Virtual Machine > Shut Down.

Suspend and Resume a Virtual Machine in Fusion
The suspend and resume feature is useful to save the current state of a virtual machine and continue work later from the
same state, even if you quit Fusion in the interim.

Fusion does not support suspending and resuming in Boot Camp virtual machines. Suspending and resuming rely on
being able to save a known state that will not change. You can boot natively into Windows in the Boot Camp partition.
When you do so, the known state is lost and data loss occurs.

Take one of the following actions.

• Select Virtual Machine > Suspend to suspend your virtual machine.

You can also set a Fusion preference to suspend the virtual machine when you close the virtual machine window.
• Select Virtual Machine > Resume to resume your virtual machine.

Cancel a Resume Command
You can cancel a resume command while Fusion is restoring the virtual machine state.

When you resume a suspended virtual machine, Fusion displays two progress bars in order. The second bar has a cancel
button.

• Click the cancel button before the progress bar is 100 percent filled.

Power on a Virtual Machine to Firmware in Fusion Pro
In Fusion Pro, you can power on or restart a virtual machine to firmware.

The power on to firmware option is available for local and remote virtual machines. If the virtual machine is suspended,
the power on to firmware option is not available

The power on to firmware option is supported in Fusion Pro 8.1 and later.
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Click Virtual Machine  > Power on to firmware.
If the virtual machine is powered off, the virtual machine boots directly to firmware. If the virtual machine is powered on,
you are prompted to restart your virtual machine. Click Restart.

Pause a Virtual Machine
Pausing a virtual machine stops the current state of a virtual machine. When you resume a paused virtual machine, the
state of the virtual machine is exactly the same as when you paused it.

NOTE
The current state of the virtual machine is not saved when you pause a virtual machine. If you quit Fusion while
a virtual machine is paused, Fusion suspends or shuts down the virtual machine depending on your Fusion
preferences.

• Click Virtual Machine > Pause.

Resume the virtual machine when you are ready to work with it again.

Restart a Virtual Machine
You can restart a virtual machine without restarting your Mac.

• Restart the virtual machine operating system.

• In the virtual machine, restart the operating system as you would in a physical computer.

The restart method depends on the operating system running in the virtual machine.
• In Fusion, select Virtual Machine >  Restart.

Reset a Virtual Machine
You can select a Fusion command to reset a virtual machine, much as you would press the reset button on a physical
computer when it becomes unresponsive.

CAUTION
Resetting the virtual machine can cause data loss.

• Press the Option key and click Virtual Machine > Force Restart, the hard power option, to reset the operating
system in your virtual machine.

Uninstall a Virtual Machine by Using the Finder
You can uninstall a virtual machine by deleting its files.

Shut down or power off the virtual machine.

Exit Fusion.

One method for uninstalling a virtual machine is to use the Finder to delete the virtual machine package.

Unless you specify a file location for a virtual machine when you create it, Fusion saves the virtual machine package to a
default location, which can vary. See Default File Location of a Virtual Machine.

1. In the Finder, browse to the virtual-machine location, such as the default your home directory/Virtual
Machines folder, and select the virtual machine to uninstall.

2. Move the virtual machine package file to the Trash.

Open Fusion. If you see the uninstalled virtual machine in the Virtual Machine Library, right-click it and select Delete.
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Uninstall a Virtual Machine by Using the Virtual Machine Library
You can uninstall a virtual machine by deleting its files.

Shut down or power off the virtual machine.

One method for uninstalling a virtual machine is to use the Virtual Machine Library to delete the virtual machine files.

1. Select Window > Virtual Machine Library.

2. Click the thumbnail of the virtual machine to uninstall.

3. Select Edit > Delete.

4. In the Remove Virtual Machine dialog box, select a method of uninstalling the virtual machine.
Depending on the type of virtual machine you are uninstalling, you might be presented with different options for
deleting the virtual machine.
Option Action
Move to Trash Removes the virtual machine from the Virtual Machine Library

window and moves all the virtual machine files to the Trash.
Keep File Removes the virtual machine from the Virtual Machine Library

window, but does nothing to the virtual machine files in the
Virtual Machines folder.

Delete Permanently Removes the virtual machine from the Virtual Machine Library
window and deletes the virtual machine files permanently. The
files are deleted permanently and not moved to the trash.

Configure SSH Login on a Linux Virtual Machine
With VMware Fusion, when a Linux virtual machine has an SSH service enabled, you can configure quick SSH login
to the virtual machine. The configuration enables SSH login from the Mac host to a Linux virtual machine in the Virtual
Machine Library. The virtual machine can be running on the Mac host or on a remote server running VMware Workstation
Pro, VMware ESXi, or VMware vCenter Server.

• Enable SSH on the Linux virtual machine, if not already enabled. See instructions for the specific Linux operating
system.

• Add the Linux Virtual Machine to the Virtual Machine Library, if not already added.
You can add virtual machines that reside on the Mac host or on a supported remote server. See Perform Actions on
Your Virtual Machines from the Virtual Machine Library Window

• Start up the Linux virtual machine, if not already started. See Start a Virtual Machine's Operating System

By configuring SSH login, you provide yourself with easy and secure SSH access to the Linux virtual machine now and at
anytime in the future. You can then use a terminal window to access the Linux virtual machine, where you can view files,
transfer data, and run the commands available on the Linux operating system.
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You can use an SSH command to log into a Linux virtual machine instead of using Fusion to configure SSH login on the
virtual machine. However, each time you use an SSH command you must provide the IP address of the virtual machine
and your user name and password.

1. Select Window > Virtual Machine Library.

2. Control-click or right-click the thumbnail of the Linux virtual machine and click Connect to SSH in the drop-down
menu.

3. Complete the form and click Connect.

Option Description

Username Enter the user name of the virtual machine.

Password Enter the password of the virtual machine.

Port If 22, the default SSH service port number, is not correct for the
Linux virtual machine you are configuring, enter the correct port
number.
The default number might be incorrect. For example, previously,
using a terminal window in the virtual machine, you reconfigured
the SSH port number.

Remember password To enable Fusion to provide the virtual machine password when
you make an SSH login attempt, select this option.

A terminal window opens on the Mac host desktop and SSH connects to the virtual machine. With the terminal window
open and connected to the Linux virtual machine, you now have command-line access to the Linux virtual machine.

In the future, to open an SSH connection from the Mac host to the Linux virtual machine, in the Fusion Virtual Machine
Library, select the Connect to SSH option for the Linux virtual machine.

Edit or Delete the SSH Login Configuration for a Linux Virtual Machine
After you configure SSH login on a Linux virtual machine, you can change or delete the configuration.

• Configure SSH login on the Linux virtual machine with the Remember password setting enabled. See Configure SSH
Login on a Linux Virtual Machine.

• Successfully establish the SSH connection at least once.

If any of the following items change, you must edit the SSH login configuration.

• Port number for the SSH service
• Your Linux virtual machine user name
• Your Linux virtual machine password

You can also delete the SSH login configuration.

1. Select Window > Virtual Machine Library.

2. Control-click or right-click the thumbnail of the Linux virtual machine and click Configure SSH in the drop-down menu.

3. Either edit updated options and click Save or remove the configuration.

Option Description

Username Edit this option if your virtual machine user name changed.

Password Edit this option if your virtual machine password changed.

Port Edit this option if the port number for the SSH service changed.
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Option Description

Remove Configuration To delete the SSH login configuration, click this option.

Send the Ctrl-Alt-Delete Command to a Virtual Machine
You can use a Fusion command to send the Ctrl-Alt-Delete keystroke combination to a Windows virtual machine.

• You can send the keystroke combination in any of the following ways.

• Select Virtual Machine > Send Ctrl-Alt-Del.
• If you are using an external PC keyboard, press Ctrl+Alt+Del.
• On a full-sized Mac keyboard, press Fwd Del+Ctrl+Option. The  Forward Delete key is below the Help key.
• On a Mac laptop keyboard, press Fn+Ctrl+Option+Delete.

Send Special Key Commands to a Windows or Linux Virtual Machine
If your keyboard does not have the full range of keys that can be found on some keyboards, you can still send special key
commands to the guest operating system.

1. Select Virtual Machine > Send Key.

2. Select the key command from the pop-up menu. See Special Key Commands.

Fusion sends the key command to the guest operating system on the virtual machine.

Special Key Commands
You can use special key commands with a virtual machine.

The Send Key item on the Virtual Machine menu contains a number of key commands that might not be available on all
keyboards.

Table 4: Special Key Commands

Key commands that can be sent to the virtual machine with the Send Key menu item

Help (Insert)

Home

End

 (Forward Delete)

Caps Lock

Clear (Num Lock)

Scroll Lock

Print Scrn

Pause

Break

Menu

F8

F9
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Key commands that can be sent to the virtual machine with the Send Key menu item

F10

F11

F12

F13

F14

F15

F16

変換 (Henkan)

無変換 (Muhenkan)

ひらがな (Hiragana)

Switch Power Commands from the Default Options
With a keyboard shortcut, you can switch some of the Fusion power command options that appear in the Virtual Machine
drop-down menu and the applications menus, from the default option.

The shortcut applies to the Shut Down/Power Off and Restart/Reset power-option pairs as listed in the Virtual Machine
drop-down menu and the applications menus. Pressing the Option or Alt key does not affect the power buttons in the
toolbar.

For example, if your virtual machine defaults to the soft options, Shut Down and Restart, holding down either the Option
key or the Alt key changes the soft options to the hard options, Power Off and Reset, respectively.

Pressing the Option or Alt key has no effect on other power options.

NOTE
You can also configure Fusion to permanently display the hard option or soft option of a power-option pair.
Therefore, you can change Shut Down to Power Off and Restart to Reset. Later, when you access the Virtual
Machine drop-down menu or an applications menu while the virtual machine is in a powered-on state, Fusion
lists the Power Off option instead of the Shut Down option and the Reset option instead of the Restart option.
See Configure Virtual Machine Power Options.

1. Select Virtual Machine to display the Virtual Machine drop-down menu.

2. Hold down the Option key (Mac keyboards) or Alt key (PC keyboards) and select an alternative power option.

Table 5: Power Commands

Soft Option Hard Option

Shut Down Power Off, also called Force Shut Down

Restart Reset, also called as Force Restart

See Options for Fusion Power Commands for descriptions of the power commands.

Options for Fusion Power Commands
You can configure your virtual machine to have soft or hard power options.
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The way the Fusion power commands work depends on the way your virtual machine is configured. If the virtual machine
was created in Fusion, the power commands default to soft options. The commands take effect on the guest operating
system. Virtual machines created in other VMware products might default to hard power options. These commands act on
the virtual machine the way the power and reset buttons work on a physical computer's power supply.

NOTE
You can change the default configuration of some of the power-option pairs from the hard option to the soft
option or reverse after the virtual machine is created. For example, you can change Shut Down, which is a soft
power option, to its hard-option counterpart, Power Off.

• To perform the switch with a keyboard shortcut, see Switch Power Commands from the Default Options.
• To configure Fusion to make the switch permanently, see Configure Virtual Machine Power Options.

Table 6: Soft and Hard Options for Power Commands in the Virtual Machine Menu

Command Result

Start Up (soft option) Triggers a startup script to run. You can customize this script.
Power On (hard option) Starts the virtual machine.

Resume (soft option) Triggers a resume script to run. You can customize this script.
Force Resume (hard option) Resumes the virtual machine from a suspended state.
Shut Down (soft option) Triggers a poweroff script to run. Sends a shut-down signal to

the guest operating system. An operating system that recognizes
this signal shuts down gracefully. Not all guest operating systems
respond to a shut-down signal from this button. If your operating
system does not respond, shut down from the operating system,
as you would with a physical machine.

Power Off (hard option)
Also called Force Shut Down

Works the way a power switch works on a computer's power
supply. The virtual machine is abruptly powered off, with no
consideration for work in progress. This action can result in data
loss. When possible, shut down the virtual machine's operating
system before you power off the virtual machine.

Suspend (soft option) Triggers a suspend script to run. You can customize this script.
Force Suspend (hard option) The Force Suspend command suspends the virtual machine.
Restart (soft option) Sends a restart signal to the guest operating system. An operating

system that recognizes this signal shuts down gracefully and
restarts. Not all guest operating systems respond to a restart
signal from this button. If your operating system does not respond,
restart from the operating system, as you would with a physical
machine.

Reset (hard option)
Also called Force Restart

Works as a reset switch. The virtual machine is abruptly reset,
with no consideration for work in progress. When possible, restart
the virtual machine's operating system. Use the reset option only
as a last resort when the virtual machine's operating system is
unresponsive.

Open a Windows Application While You Are in Unity View on Intel-based Mac
When a virtual machine is running in Unity view, you do not see the guest operating system's desktop, but you can open
an application without it.

With the virtual machine open in single window or full screen view, switch to Unity view. For example, select View > Unity.
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When you switch to Unity view, the following events occur.

• The virtual machine interface disappears.
• Applications currently open in the virtual machine appear directly on the Mac desktop.
• VMware Unity ( ) appears in the Mac Dock.

When you are working with applications in an operating system, you can use several methods to start an application. In
some cases, you click an icon on the desktop or use a start menu or its equivalent. When you use Unity view with a virtual
machine, you cannot use those methods because only the active application windows appear on your Mac's desktop.

• Select the application from the Unity applications menu.
a) Click VMware Unity ( ) in the Mac Dock.

A window opens that contains the Unity applications menu.
b) Click the application icon in the list, or find it by clicking All Programs.

• Keep a virtual machine application in the Mac Dock.
a) With the application open, switch to Unity view by selecting View > Unity.

The application appears in the Mac Dock.
b) Control-click or right-click the application in the Mac Dock and select Options > Keep in Dock.

The application remains in the Mac Dock, where you can open it even if Fusion is not currently running.
• Show the Windows taskbar to use the start menu.

a) Select View > Show Taskbar in Unity.
You might have to move the location of the Mac Dock to see the taskbar.

b) Click the Start menu and select the application.

Open a Windows Application from the Applications Menus on Intel-based Mac
You can open a Windows application from either of the applications menus, the applications menu ( ), accessible in the
Mac menu bar or with a keyboard shortcut, and the Unity applications menu ( ), accessible from the Mac Dock when the
virtual machine is in Unity view.

For supported Windows guests, the applications menus provide quick access to applications. See Find a Windows Guest
Application by Using the Applications Menus.

• Open the applications menu of your choice.
• Search for the application.

Moving and Sharing Files with Your Mac
With Fusion, you can move and share files between a virtual machine and your Mac.

Moving and Copying Files and Text Between Virtual Machines and Your Mac
You can drag files and folders to move and copy them between your virtual machines and your Mac. You can move text by
copying and pasting or cutting and pasting.

You can also drag images between Windows applications and Mac applications. You can drag Outlook attachments from
a Windows virtual machine to your Mac. You can drag files in a virtual machine directly onto Mac applications. You can
also drag and drop text, files or folders between a macOS virtual machine and your Mac.

You can copy and paste images and formatted text between a Windows or Linux virtual machine and your Mac. You can
copy and paste text between a macOS virtual machine and your Mac. Copying and pasting files or folders between a
macOS virtual machine and your Mac is not supported.

These features require VMware Tools.
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Drag Files and Folders Between Virtual Machines and Your Mac

You can use your mouse to drag files and folders in either direction.

• In either the virtual machine or your Mac, with the pointer over the icon of the file or folder to move, hold down the
primary mouse button and drag the file or folder to the new location.

Fusion copies the file or folder to the new location.
Copy and Paste Between Virtual Machines and Your Mac Using the Menu

You can copy and paste between a virtual machine and your Mac.

Copy and paste works with images and text for Windows and Linux virtual machines and your Mac.

1. In either the virtual machine or your Mac, select the text.

2. From the Edit menu, select Copy to copy the text, or Cut to move the text.

3. Move the pointer to the new location.

4. From the Edit menu, select Paste to copy or move the text to the new location.

Copy and Paste Between Virtual Machines and Your Mac Using Keyboard Shortcuts

You can copy and paste between a virtual machine and your Mac.

To use these shortcuts, make sure the Fusion preference Enable Key Mappings preference is selected.

You can copy and paste images and formatted text between a Windows or Linux virtual machine and your Mac. You can
copy and paste text between a macOS virtual machine and your Mac. Copying and pasting files or folders between a
macOS virtual machine and your Mac is not supported.

1. In either the virtual machine or your Mac, select the text.

2. Use the Mac keyboard shortcut +C to copy the text, or +X to move the text.

3. Move the pointer to the new location.

4. Use the Mac keyboard shortcut +V to copy or move the text to the new location.

View Shared Folders in a Windows Guest by Using Windows Explorer
You can use Windows Explorer to view shared folders between your Mac and Windows.

1. Open Windows Explorer.

2. View shared folders using one of the following methods:

• Click on the VMware Shared Folders shortcut.
• In the Address bar, type \\vmware-host\Shared Folders\.
• In the Address bar, type Z:.

When the Enable Shared Folders setting is enabled, Fusion creates a network drive that maps the \\vmware-
host\Shared Folders directory to the Z drive.

The Windows Explorer window displays your shared folders.
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View Shared Folders in a Windows Guest by Mapping Them as a Drive
You can view your shared folders between your Mac and Windows by mapping them as a drive in Windows.

1. Start Windows Explorer.

2. Navigate to My Computer or Computer.

3. Run the command to map a network drive.
Option Description
Windows Vista, Windows 7, Windows 8, Windows 10 Click Map Network Drive
Windows operating systems other than Vista, Windows 7,
Windows 8, Windows 10

Click Tools > Map Network Drive

4. Select a drive to map.

5. In the Folder field, type \\vmware-host\Shared Folders\.

6. Click Finish.

Your shared folders appear in Windows Explorer on the drive that you mapped.

View Shared Folders in a Linux Guest
You can go to specific directories to find your shared folders.

• Open the /mnt/hgfs directory in File Explorer to view shared folders on a Linux guest.

View Shared Folders in a macOS Guest
You can view folders that are shared between the macOS guest and the Mac host.

1. Open the macOS guest.

2. Click the VMware Shared Folders shortcut on the guest OS desktop.
The guest OS desktop displays your shared folders.

Sharing Applications Between Your Mac and Your Windows Virtual Machines
In the Applications panel of the virtual machine Settings window, you can set up Fusion so that your Mac can open
applications in a virtual machine or so that a virtual machine can open applications on your Mac, or both.

Open a File in a Virtual Machine with an Application on Your Mac
When you select a file in your virtual machine, you can open it with the appropriate application on your Mac.

Verify that the following conditions are met:

• You turned on Shared Folders in the Sharing panel of the virtual machine Settings window.
• You enabled Open your Windows files and web links using Mac applications in the Default Applications panel of

the Settings window.
• You selected a folder or folders to share.
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• The file to open is located in one of the shared folders.

• To open a file one time, right-click the file, select Open With and select Default Host Application.
Fusion determines the appropriate application on the Mac and uses that application to open the file.

• To always open a particular file with the Mac application, right-click the file, select Properties, click Change for Opens
With, and select Default Host Application in the Open With dialog box.

Whenever you open this file, it opens in the Mac application.
• To always open files of this type with the Mac application, right-click the file, select Open With, select Default Host

Application > Choose Program, and select Always use the selected program to open this kind of file.
Fusion determines the appropriate application on the Mac and uses that application whenever you open any file of this
type.

Open a File on Your Mac with an Application in a Virtual Machine
You can open a file on your Mac with the appropriate application in one of your virtual machines.

Verify that the following conditions are met:

• You turned on Shared Folders in the Sharing panel of the virtual machine Settings window.
• You selected a folder or folders to share.
• The file to open is located in one of the shared folders.
• You enabled Shared Folders in the Default Applications panel of the Settings window.

For Windows virtual machines, you can open the Mac file with a virtual machine application as a one-time event, or you
can set the application to be used whenever you open the file.

• For a one-time event, right-click the file, select Open With, and select an application from the menu.
Because you can find the same application across many virtual machines, the menu entry shows the name of the
virtual machine and the application name.
The file opens in the application that appears in the menu.

• To always open with the virtual machine application, right-click the file, select Get Info and select an application from
the Open with pop-up menu.

• Optional: Click Change All to use the application to open all files of this type.

Whenever you open this file, it launches in the application that you selected.

Keep a Windows Application in the Mac Dock on the Intel-based Mac
You can place an icon tile for a Windows application in your Mac Dock. You can open the application in the same way that
you open your Mac applications. You can access your virtual machine's applications without having to use the VMware
Fusion menu bar or the guest operating system interface.

1. With the application open, switch to Unity view by selecting View > Unity.
The application appears in the Mac Dock.
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2. Control-click or right-click the application in the Mac Dock and select Options > Keep in Dock.

Switch Between Virtual Machines That Are Powered On
You can operate multiple virtual machines at the same time, and can switch between them easily.

• Select the virtual machine to work with from the Window menu within Fusion.

Using Mac Input Devices in a Virtual Machine
To use Mac keyboards, mice, and trackpads in a virtual machine, you sometimes must change settings and use key
combinations as equivalents to PC commands.

Enable the Secondary Button in an Apple Mighty Mouse
In a virtual machine, the Apple Mighty Mouse does not perform a right-click when you Control-click. You must enable the
secondary button to perform a right-click in a virtual machine.

1. Select VMware Fusion > Preferences and click Keyboard & Mouse.

2. Select the Secondary Button check box.

3. Optional: To change the shortcut for the secondary button, double-click the current shortcut, select a new shortcut, and
click OK.

Using Mac Keyboards in a Virtual Machine
Because PC and Mac keyboards differ, you must press certain key combinations to enable certain PC commands on a
Mac keyboard.

For keys with no keyboard equivalent, Fusion provides the Send Key item in the Virtual Machine menu.

For keys with no keyboard equivalent, Fusion provides the Send Key item in the Virtual Machine menu.

Table 7: PC and Mac Keyboard Equivalents

PC Keyboard Apple External Keyboard MacBook and MacBook Pro Built-In
Keyboard

F1-F12 F1-F12 fn+F1 . . . fn+F12

Print Screen F14 (use Send Key)

Scroll Lock F15 (use Send Key)

Pause/Break F16 (use Send Key)

Backspace delete delete

delete 
(Forward Delete)

delete fn+delete

Insert (toggles overwrite) help (early models) (use Send Key and select Help item)

Num Lock clear fn+num lock F6

Command
(Windows logo key—between Ctrl and Alt
keys)

Alt alt option alt option
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Force Virtual Machines to Grab Keyboard and Mouse Input
You can set the virtual machine to grab mouse and keyboard input. When input is grabbed, the mouse pointer is confined
to the virtual machine window, and all keyboard and mouse input is directed to the virtual machine.

Ordinarily, with VMware Tools installed, when you click in the virtual machine, Fusion directs keyboard and mouse input
to the virtual machine. When you click on your Mac desktop, keyboard and mouse input is directed to your Mac host. You
can force all input to the virtual machine.

• Force grab or force release keyboard and mouse input.
Option Action
Force a virtual machine to grab keyboard and mouse input On the keyboard, press Cmd+G.
Force a virtual machine to release keyboard and mouse
input

On the keyboard, press Ctrl+ .

Sharing Files Between Windows and Your Intel-based Mac
You can set up shared folders in guest operating systems to share files between your Mac and your Windows and other
virtual machines.

In the Sharing panel of a virtual machine's Settings window, you can select shared folders on your Mac to make available
to the virtual machine. This feature requires VMware Tools.

You can mirror folders in your Windows virtual machine and in your Mac. Mirrored folders match key folders in the virtual
machine with their corresponding Mac folders: Desktop, Documents, Downloads, Movies, Music, and Pictures.

To use shared folders, you must configure your virtual machine settings to enable shared folders and to specify which
directories on your Mac are to be shared. The shared folders can be in your Mac file system or they can be network
directories accessible from your Mac.

The guest operating system determines how shared folders appear. You can view shared folders in certain Windows and
Linux guest operating systems. For a list, see Guest Operating Systems That Support Shared Folders. Before you can
view shared folders, you must enable and configure the shared folders function.

NOTE
Do not open a file in a shared folder from more than one application at a time. For example, do not use an
application on the Mac’s operating system and another application in the virtual machine’s operating system to
open the same file at the same time. If one of the applications writes to the file, data might be corrupted.

Guest Operating Systems That Support Shared Folders
You can use shared folders with virtual machines that are running certain operating systems.

Fusion supports shared folders in certain Windows, Mac, and Linux operating systems.

NOTE

Shared Folder is not supported for Windows 11 ARM GOS on Apple Silicon hosts.

• Windows 10
• Windows 8.1
• Windows 8
• Windows 7
• Windows Server 2016
• Windows Server 2012
• Windows Server 2008
• Windows Server 2003
• Windows Vista
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• Windows XP
• macOS 11.0
• macOS 12.0
• macOS 13.0
• macOS 10.12, 10.13, 10.14 and 10.15
• Mac OS X 10.6, 10.7, 10.8, 10.9, 10.10 and 10.11
• Supported Linux guest operating systems with a kernel version of 2.4 or later

Guest Operating Systems That Support Mirrored Folders
You can use mirrored folders with virtual machines that are running a variety of Windows operating systems.

Fusion supports mirrored folders in these Windows operating systems.

• Windows 10
• Windows 8
• Windows 7
• Windows Vista
• Windows XP

Fusion does not support mirrored folders for Windows 2000 and earlier, or for Windows Server 2003 and Windows Server
2008. For virtual machines with unsupported guest operating systems, the choices are not available in the Sharing panel
of the Settings window.

Enable Shared Folders or Mirrored Folders for a Virtual Machine
Before you can identify which folders to share or mirror, you must configure your virtual machine to share folders.

Verify that the virtual machine runs a guest operating system that supports folder sharing. For more information, see
Guest Operating Systems That Support Shared Folders.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. (Optional) If the host is of Intel based, navigate to Virtual Machine > Settings.

4. Under Systems Settings in the Settings window, click Sharing.

5. Select the Enable Shared Folders check box.
This action enables shared folders. It also enables mirrored folders for supported Windows guest operating systems.
On Windows and macOS virtual machines, a VMware Shared Folders shortcut is created on the guest operating
system. Click on the shortcut to view the shared folders.
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Add or Remove a Mirrored Folder
With Fusion mirrored folders you can map special folders on your Mac, such as Desktop, Documents, Downloads,
Movies, Music, and Pictures, to their counterparts in certain Windows virtual machines.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Under System Settings in the Settings window, click Sharing.

4. Select the Enable Shared Folders check box.

5. In the Mirrored Folders section, select the Mac folders to mirror and deselect any folders that you do not want
mirrored.

Add a Shared Folder
You can share files between virtual machines and your Mac by using shared folders.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Under Systems Settings in the Settings window, click Sharing.

4. Select the Enable Shared Folders check box.
On Windows and macOS virtual machines, a VMware Shared Folders shortcut is created on the guest operating
system.

5. Click the add (+) button at the bottom of the display box.

6. In the Finder sheet, find the location of the folder to share, select it, and click Add.

7. In the Permissions field, set the virtual machine permission on the contents of the Mac's shared folder.
Option Description
Read & Write Enables the virtual machine to change the contents of the

shared folder on your Mac.
Read Only Prevents the virtual machine from changing the contents of the

shared folder on your Mac.

Permission settings on your Mac also determine access to files in the shared folder. Read-only permission on a file or
folder takes precedence over the Shared Folder permission setting.

8. Optional: Click the Open in Guest button to open the shared folder in the virtual machine.
This option is available only for Windows virtual machines that are powered on. The Open in Guest option was added
in Fusion 8.1.
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Remove a Shared Folder
You can remove a folder from the list of shared folders to stop sharing it.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Under Systems Settings in the Settings window, click Sharing.

4. In the display box at the top of the Sharing panel, select the folder to remove.

5. Click the remove (-) button at the bottom of the display box.

Protecting Your Virtual Machines
You can protect your virtual machines from data loss and other problems by using snapshots, AutoProtect, complimentary
anti-virus software, and backup applications.

Snapshots
Taking a snapshot in Fusion lets you preserve the state of the virtual machine so that you can return to that state.

You might take a snapshot any time you are about to take an action in your virtual machine and you are unsure of the
consequences. For example, you might take a snapshot before you make a change to your virtual machine's system
software, such as an operating system upgrade or a major configuration change. If something doesn't work as expected
after the change, you can restore the snapshot to return the virtual machine to its previous state.

You might also take a snapshot before you go on to the Internet, or log in to an unknown network. If your computer
acquires a software virus or spyware, you can restore the snapshot to return the virtual machine to its previous uninfected
state.

A snapshot captures the entire state of the virtual machine at the time you take the snapshot.

• Memory state – Contents of the virtual machine memory
• Settings state – Virtual machine settings
• Disk state – State of all the virtual disks

A snapshot is not the same as a backup. It is not a copy of your virtual machine.

View Snapshots for a Virtual Machine
The Snapshots window shows all of the snapshots for a virtual machine.

The Snapshots window shows manual snapshots and AutoProtect snapshots.

1. Select the virtual machine to view snapshots for in one of the following ways.

• Select the virtual machine from the Virtual Machine Library.
• Open the virtual machine.

2. Open the Snapshots window for the selected virtual machine in one of the following ways.

• Select Virtual Machine > Snapshots.
• Click the Snapshots button in the virtual machine toolbar.

Take a Snapshot
Take a snapshot of the virtual machine's current state from the Snapshots window for that virtual machine.

The virtual machine does not need to be powered on for you to take a snapshot.

 105



 VMware Fusion Pro 13

You cannot take a snapshot of a Boot Camp virtual machine. Snapshots rely on being able to save a known state that will
not change. This is not possible with Boot Camp, in which you can boot natively into Windows in the Boot Camp partition.
Once that happens, the known state would be lost and data loss would occur.

1. In the Snapshots window of the virtual machine, select the Current State if it is not selected.

2. Click Take.

3. Name the new snapshot and give it a description in the dialog.

4. Click Take.
Fusion takes the snapshot of the current state of the virtual machine.

5. Close the Snapshots window.

Restore a Virtual Machine to the State in a Snapshot
You can restore a virtual machine to an earlier state.

1. Select Virtual Machine > Snapshots.

2. Select the snapshot to restore.

3. Click Restore.

4. Click either Save to save a snapshot of the current state before you restore the virtual machine to the selected
snapshot state, or Don't Save a snapshot.

The virtual machine is restored to the state that the selected snapshot captured.

Delete a Snapshot
You can manually delete snapshots that you no longer need or to make more disk space available.

Allocate enough time for virtual disk consolidation. If a snapshot captured a state considerably different from the earlier
state, for example, a service pack upgrade, the consolidation might take up to a few hours.

The virtual disk files that a snapshot creates do not contain the entire contents of the virtual machine's virtual disk. When
you delete a snapshot, you must consolidate the changes that it captured into the original, parent virtual disk.

You cannot delete the snapshot showing the "Current State" of the virtual machine.

1. Select Virtual Machine > Snapshots.

2. Select the snapshot to delete.
Option Action
To select multiple adjacent snapshots. Shift-click
To select multiple snapshots that are not adjacent. Command-click

3. Click Delete.

4. Click Delete to confirm that you want to delete the snapshot.

The snapshot is deleted and virtual disk consolidation takes place.

AutoProtect
Fusion can take snapshots of the state of your virtual machine at intervals with the AutoProtect function. This feature is in
addition to manual snapshots, which you can take at any time.

Use AutoProtect to instruct Fusion to take a snapshot automatically every 30 minutes, every hour, or every day.
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Set Up Automatic Snapshots with AutoProtect
Fusion can take snapshots of the state of a virtual machine automatically at set intervals, with the AutoProtect function.
This function is in addition to manual snapshots, which you can take at any time.

When you turn on AutoProtect, you set the maximum number of AutoProtect snapshots to keep at a time. After this
number is reached, Fusion deletes the oldest AutoProtect snapshot in the range to make room for the newest snapshot.

This number setting can affect the number of manual snapshots that you can take and keep. You can have no more than
100 snapshots for a virtual machine, and depending on the types and sizes of the virtual disk files, this number can be
less. If the total of AutoProtect snapshots reach the limit, you cannot take manual snapshots.

Fusion uses this setting to estimate the minimum amount of hard disk space the AutoProtect snapshots will use. That
information appears at the bottom of the panel. The maximum amount of hard disk space can be significantly more than
the estimate, depending on the amount of changes you make between snapshots.

NOTE
When you have manual or AutoProtect snapshots of a virtual machine, you cannot add or modify its virtual hard
disk.

1. Open a virtual machine, or select it in the Virtual Machine Library.

2. Select Virtual Machine > Snapshots.

3. Click AutoProtect Settings.

4. Select the Enable AutoProtect check box.

5. Select the frequency of snapshots.

6. Select the number of AutoProtect snapshots to retain.
After this number is reached, Fusion deletes the oldest AutoProtect snapshot in the range to make room for the
newest snapshot.

7. Click Done to apply the AutoProtect settings.

8. Close the Snapshots view and return to the virtual machine.

Prevent the Deletion of an AutoProtect Snapshot
When AutoProtect takes a new snapshot, it deletes the oldest snapshot to maintain the allowable number that you set.
You can prevent the deletion of an AutoProtect snapshot.

1. In the Snapshots window, hover the cursor over the AutoProtect snapshot to keep, and click the information button (i).

2. Click Keep Snapshot.

Fusion considers the AutoProtect snapshot the same as a snapshot taken manually. AutoProtect will not delete this
snapshot when the next AutoProtect snapshot is taken.

Copy a Virtual Machine to External Media
Because virtual machines are files, you can back them up by making a copy.

Shut down or power off the virtual machine and shut down Fusion.

Although virtual machines run other programs and manipulate files, they are still files themselves. Because of this, you
can back them up by making a copy to external media and restore the virtual machines by copying back.

NOTE
You cannot copy a Boot Camp virtual machine, because instead of having a virtual hard disk, the Fusion virtual
machine uses the Boot Camp partition.
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Unless you specify a file location for a virtual machine when you create it, Fusion saves the virtual machine package to a
default location, which can vary. See Default File Location of a Virtual Machine.

1. Connect to the media to which you will be copying the virtual machine.

2. Browse to the virtual-machine location, such as the default your home directory/Virtual Machines folder,
and select the virtual machine to copy.

3. Right-click and select Copy "virtual machine name".

4. Open the external media in the Finder, right-click and select Paste Item.

The contents of the virtual machine package is copied to the external media. You can reverse the process to restore the
copied virtual machine to your Mac.

Using Time Machine When You Have Fusion on Your Mac
If you use Time Machine, exclude virtual machines from the backup.

Any change to a virtual machine's virtual hard disk file results in the entire file being backed up. When you have a 40GB
virtual machine, having Time Machine back it up every hour can fill a hard disk quickly.

Exclude a Virtual Machine From Time Machine
To prevent problems with your virtual machines and to save space on your backup media, you should not back up virtual
machines with Time Machine.

If you do not exclude virtual machines from Time Machine backups, Time Machine can back up a virtual machine while
it is running. Restoring from this kind of backup would overwrite your current virtual machines with versions that are
incomplete and potentially damaged. For the recommended method of backing up virtual machines, see Copy a Virtual
Machine to External Media.

1. Open the Mac's System Preferences and click Time Machine.

2. Click Options.

3. Click the add (+) button at the bottom of the Do not back up list.

4. Browse to your Documents folder on the Mac, select the Virtual Machines folder, and click Exclude.
The Virtual Machine folder appears in the Do not back up list, and displays the total memory used by all your virtual
machines.

5. Click Done, and close the Time Machine window.

Related Links
Use Shared and Mirrored Folders If You Back Up Your Mac With Time Machine on page 108

To use Time Machine to back up data and documents from your virtual machines, keep those files on the Mac.

Use Shared and Mirrored Folders If You Back Up Your Mac With Time Machine
To use Time Machine to back up data and documents from your virtual machines, keep those files on the Mac.

Exclude your virtual machines from Time Machine.

When you use Shared Folders and Mirrored Folders in your virtual machines, you save your documents and data as files
on the host, not in the guests. This means that although you exclude virtual machines from Time Machine backups, Time
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Machine can back up the files in the Shared and Mirrored folders because they do not reside in the virtual machines. See
Enable Shared Folders or Mirrored Folders for a Virtual Machine

• Enable Shared or Mirrored folders.

Related Links
Exclude a Virtual Machine From Time Machine on page 108

To prevent problems with your virtual machines and to save space on your backup media, you should not back up virtual
machines with Time Machine.

Configuring Your Virtual Machines
You can configure the way your virtual machine uses the Mac system hardware and attached devices. You can manage
your virtual hard disks.

Fusion General System Settings
You can find basic information about your virtual machine in the General system settings.

The General system settings of the virtual machine include the virtual machine name, the guest operating system, and
notes. You can change some of the settings directly in this panel.

Table 8: General System Settings

Setting Description

Name Name of the virtual machine that you specified when you created
it. This name appears in the Virtual Machine Library. You can
change the name of the virtual machine at any time.

OS Guest operating system installed in the virtual machine. This name
is typically provided as the guest operating system you selected
when you created the virtual machine. If you uninstall the guest
operating system and install a different one, you can change the
guest operating system listed here.

Notes You can add notes about this virtual machine, its use, or other
information at any time.

Start automatically when Fusion launches Starts the virtual machine when you start Fusion.

The General system settings include information about the virtual machine's hard disk and options for disk clean up.

You can use the Clean up Virtual Machine or Clean up disks after shutting down virtual machine options to free up
space on your Mac. For more information, see Clean up a Virtual Machine.

Set a Virtual Machine to Start When Fusion Starts
You can set any virtual machine to start when you start Fusion.

You can set any number of virtual machines to start when you start Fusion. You must select this option in each virtual
machine that you want to start when Fusion launches.
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Setting a virtual machine to start when Fusion starts can be useful if you have many virtual machines that you want to
start. You might want to start a virtual machine when Fusion starts if you use a laptop to run one virtual machine that you
always want to resume every time you start Fusion.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Under System Settings in the Settings window, select General.

4. Select the Start automatically when VMware Fusion launches check box.

The virtual machine starts each time you start Fusion.

Setting Virtual Processors and Memory
You can configure processor settings for a virtual machine, including the number of processors, the amount of virtual
memory available, and whether to enable hypervisor applications, code profiling applications, and IOMMU.

Set the Number of Virtual Processors
You can increase performance of a virtual machine by making more processors available because more tasks can be
performed simultaneously. When you assign a virtual processor to the virtual machine, it reduces the processor resources
that are available to your Mac.

Shut down or power off the virtual machine. You cannot change the setting while the virtual machine is powered on or
suspended.

For Windows virtual machines running mostly office and Internet productivity applications, using multiple virtual
processors is not beneficial, so the default single virtual processor is ideal. For server workloads and compute-intensive
applications, adding extra virtual processors may provide an increase in application performance.

Application Recommended number of processors

Desktop applications 1 processor

Server operating systems 2 processors

Video encoding, modeling, and scientific 4 processors

In some circumstances, adding additional processors can decrease the overall performance of the virtual machine
and your Mac. This can occur if the operating system or application is not using the processors efficiently. In this case,
reducing the number of processors is recommended.

Assigning all processors on the Mac to the virtual machine results in extremely poor performance. macOS must continue
to perform background tasks even if no Mac applications are running. If you assign all processors to a virtual machine, this
prevents important Mac tasks from being completed.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Under System Settings in the Settings window, click Processors & Memory.

4. Select the number of processor cores for the virtual machine.
Information about your selected number of processors is displayed at the bottom of the Processors & Memory
window.
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5. Restart the virtual machine.

Set the Amount of Virtual Memory
Certain applications in the virtual machines might perform better with more memory available. Having more memory
available to the guest operating system can facilitate caching, which can improve performance of the virtual machine. You
can change the amount of virtual memory available to a virtual machine.

Shut down or power off the virtual machine. You cannot change the setting while the virtual machine is powered on or
suspended.

For the best balance of performance between Windows and Mac applications, do not give Windows too much memory,
because it might cause your Mac to become slower. For Windows XP, 512MB of memory is ideal for Internet and office
productivity applications.

For Windows Vista, Windows 7, Windows 8 and Windows 10, 1GB of memory is ideal for Internet and office productivity
applications. 1GB of memory is appropriate for both the 32-bit and 64-bit versions of Windows 7, Windows 8 and Windows
10. If your Mac has at least 6GB of memory, Fusion uses 2GB of memory as the default for 64-bit versions of Windows
7, Windows 8 or Windows 10 guests. These settings are the default memory settings for Windows virtual machines that
Fusion Easy Install creates.

NOTE
Manufacturer recommendations do not generally take virtualization into account in terms of performance. Good
performance relies on balancing the needs of the Mac with the needs of the virtual machine.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Under System Settings in the Settings window, click Processors & Memory.

4. Set the amount of memory to allocate to the virtual machine by using the slider control.
The memory slider control displays the recommended amount of memory for your virtual machine.

Set Advanced Processor Options
You can enable hypervisor applications, applications that use performance counters, or both in certain virtual machines.

• Verify that the virtual machine is compatible with Fusion 8 or later virtual machines.
• Verify that the virtual machine does not have an older guest operating system, such as Windows versions prior to

Windows XP.
• Verify that the host system has a CPU that is recent enough to support Virtualized Intel VT-x/EPT, performance

counters, and IOMMU.
• Shut down or power off the virtual machine. You cannot change the setting while the virtual machine is powered on or

suspended.

With Fusion virtual machines, you have the following advanced options:

• You can run hypervisor applications such as Workstation Pro and Fusion inside a virtual machine. For example, you
can use Fusion to create a virtual machine, install Workstation Pro in that virtual machine, and then use that version of
Workstation Pro to create a virtual machine.

• You can use code profiling applications such as VTune or OProfile to optimize or debug software that runs inside a
virtual machine.

• You can use input–output memory management unit (IOMMU), which is capable of mapping virtual addresses to
physical addresses.
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IMPORTANT
If you enable either of the preceding settings and then move the virtual machine to another host system, confirm
that the new host uses the same kind of CPU.

The Enable hypervisor applications in this virtual machine and Enable IOMMU in this virtual machine settings are
required to enable virtualization-based security (VBS), a feature that reinforces the security of Microsoft Hyper-V. See
Enable Microsoft Virtualization-Based Security. When you enable VBS, these two settings are automatically selected and
are not available for editing. They become editable when you do not enable VBS.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Under System Settings in the Settings window, click Processors & Memory.

4. Click to expand Advanced Options and select the check boxes for the options that you want to use.

Enable Default Applications
You can set up Fusion so that certain applications open files regardless of whether the files reside on your Mac or in the
virtual machine.

• Verify that VMware Tools is installed.
• If your virtual machine is suspended, power it on.

The Default Applications setting also adds applications from your virtual machine to your Mac Applications menu and
Spotlight.

• Select Window > Virtual Machine Library.
• Select a virtual machine in the Virtual Machine Library window and click Settings.
• Under System Settings in the Settings window, click Default Applications.
• Select the defaults for application sharing between your Mac and the virtual machine.

You can enable more than one of these options at the same time.
Option Description
Open your Mac files and web links by using Windows
applications

You can use applications in your virtual machine to open files
that reside on your Mac. For example, you can open a Microsoft
Word document stored on your Mac in a Microsoft Office
application in your virtual machine.

Open your Windows files and web links using Mac
applications

You can use your Mac applications to open files in your virtual
machines.

Run Windows applications from your Mac's Applications
folder

Find applications that you installed in Windows in your Mac's
Applications folder or using Spotlight. This option requires
VMware Tools. The virtual machine must be running to enable
this option. This option is not available on shared virtual
machines.

• Optional: Click Configure to assign the applications used to manage mail, Web pages, and so on. See Set Default
Applications Preferences.

• Optional: Click Restore Applications to restore the applications listed in your Mac Application folder to only those that
Windows does not include by default.
If you deleted any of the Windows applications not included by default from the Mac Application folder, the deleted
applications are restored.
If you added any applications that are included by default to your Mac's application folder, those applications are
deleted from the Mac Application folder.
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• Optional: Click Clean Up Applications to delete any Windows applications in the Mac Application folder that are not
being used by any of your virtual machines.

App Nap Support
Fusion 7.0 or later supports the App Nap feature, which places UI applications running in the background in a reduced
system resource state.

You do not have to turn off App Nap for Fusion 7 or later.

Configuring Keyboard and Mouse Profiles
These profiles specify how Mac key combinations and mouse shortcuts are mapped to shortcuts on a virtual machine,
including key combinations for Windows 8 shortcuts.

With keyboard and mouse profiles, you can also specify whether keyboard shortcuts are sent to your Mac instead of the
virtual machine, and you can specify which Fusion-specific keyboard shortcuts to enable.

Although you can also create and edit keyboard and mouse profiles in Fusion preferences, you use virtual machine
settings to select which profile to use for a particular virtual machine.

You can edit the default profiles provided by Fusion, or you can create additional profiles, either by adding a new one or
by duplicating and editing one of the existing profiles.

• Profile maps common Macintosh key combinations such as +C and +X to their Windows and Linux
counterparts, such as Control+C and Control+X, respectively.

• Mac Profile has very few keyboard mappings. Most keystrokes are passed directly to the macOS guest.
• Windows 8 Profile has a set of key mappings specifically for Windows 8 features, such as pressing Windows-C to

open the Charms bar.
Fusion includes a Windows 8 specific profile because many keyboard shortcuts specific to Windows 8 include the
Windows key, which normally maps to the  key on macOS. Unfortunately, many of these  key combinations
are also used for system hot keys in macOS. To avoid conflicts, the Windows 8 profile allows you to use the key
combination +shift to map to the Windows key in Windows 8. You can, however, configure a different key
combination.

Enable a CD/DVD Drive on a Remote Virtual Machine
You can enable a CD/DVD drive and select a disk image on a virtual machine hosted on a remote server. You can access
or install software from a physical CD/DVD drive on to your remote virtual machine.
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Verify that the following conditions are met:

• You have login credentials for the server where the virtual machine is hosted.
• The virtual machine is powered on.

1. Select File > Connect to Server.

2. Enter the name of the host server or select a server from the Recent Servers drop-down menu.

3. Enter your login credentials and click Connect.

4. Select Virtual Machine > Settings.

5. Click CD/DVD Drive.

6. Select the Enable CD/DVD Drive check box.

7. Select a remote disc image from the Choose a remote disc image drop-down menu.

8. Optional: Expand Advanced options and select a bus type from the drop-down menu.

9. Optional: Click Remove CD/DVD Drive to return to the CD/DVD drive that your virtual machine uses.

Related Links
Add a CD/DVD Drive on page 130

You can add a virtual CD/DVD drive to a virtual machine.

Remove a CD/DVD Drive on page 131
You can remove a physical or virtual CD/DVD drive from your virtual machine.

Connect and Set Up a CD/DVD Drive on page 131
You can set up a CD/DVD drive so that it is always detected, or so that you must connect it manually.

Connect and Disconnect the CD/DVD Drive Without Using the Settings Window on page 132
You can use the buttons on the status bar to connect and disconnect devices.

Create a CD/DVD Image on page 132
You can use the Apple Disk Utility to create CD/DVD disk images.

Enable a Floppy Drive on a Remote Virtual Machine
You can enable a floppy drive and select a disk image on a virtual machine hosted on a remote server. You can access or
install software from a physical floppy drive on to your remote virtual machine.
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Verify that the following conditions are met:

• You have login credentials for the server where the virtual machine is hosted.
• The virtual machine is powered on.

1. Select File > Connect to Server.

2. Enter the name of the host server or select a server from the Recent Servers drop-down menu.

3. Enter your login credentials and click Connect.

4. Select Virtual Machine > Settings.

5. Click Floppy.

6. Click the Enable Floppy Drive check box.

7. Select a floppy image from the drop-down menu.

View the Status of a Server or Remote Virtual Machine
You can view the power state, CPU use, and disk space use of a server or the configuration information of a remote virtual
machine.

Verify that you have login credentials for the server where the virtual machine is hosted. The server cannot be a vCenter
Server host.

1. Select File > Connect to Server.

2. Type the name of the server, or select a server from the Recent Servers drop-down menu.

3. Type your login credentials and click Connect.

4. Select a server to view CPU use, memory use, and available storage information.

5. Select a virtual machine to view snapshot, configuration file, and hardware compatibility information.

Configuring Display Resolution Settings
You can configure display resolution settings for your virtual machine to enable 3D accelerated graphics, retina display
support, and single window and full screen settings.

Enable Accelerated 3D Graphics
On certain virtual machines, Fusion provides support for accelerated 3D graphics.

Shut down or power off the virtual machine. You cannot change these settings while the virtual machine is powered on or
suspended.

On virtual machines running Windows 7 or later, Fusion supports DirectX 11 with Open GL 4.3. Hardware version 20 and
later is required.

On virtual machines running Windows 7 or later, Fusion supports DirectX 11 with Open GL 4.1. Hardware version 18 is
required.

On virtual machines running Windows XP or later, Fusion supports DirectX 9.0c with Shader Model 3 and OpenGL 2.1
accelerated 3D graphics.

On virtual machines running Windows Vista or later, Fusion supports DirectX 10 with Open GL 3.3. Hardware version 12
is required.

On virtual machines running Windows 7 or later, Fusion supports DirectX 10.1 with Open GL 3.3. Hardware version 16 is
required.
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On virtual machines running Linux, Fusion supports OpenGL 4.1 for accelerated 3D graphics. Hardware version 18 is
required. Linux kernel and Mesa 3D versions that support 3D accelerated graphics are required.

On virtual machines running Linux, Fusion supports OpenGL 4.3 for accelerated 3D graphics. Hardware version 20 and
later is required. Linux kernel and Mesa 3D versions that support 3D accelerated graphics are required.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Under System Settings in the Settings window, click Display.

4. Select the Accelerate 3D graphics check box.
The version of DirectX supported by your hardware version is displayed.

5. Select the Battery life menu item from the drop-down menu.
You can select the option to use high-performance graphics for 3D applications only to conserve battery life. You can
select the menu item to always use high-performance graphics, but this selection results in shorter battery life.

6. Select the shared graphics memory item from the drop-down menu.

Enable External GPU
Fusion provides support for external GPU when an external GPU is connected to the host.

Shut down or power off the virtual machine before you change the external GPU settings. The external GPU feature can't
be enabled when the virtual machine is powered on or suspended.

1. On the host desktop, select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Click Display in the Settings window.

4. Select the Prefer External GPU check box.

Fusion will now use external GPU.

NOTE
You can also enable external GPU for Fusion UI by performing the following steps:

1. Open Finder and navigate to Applications > right-click VMware Fusion.app >  Get Info.
2. Enable the Prefer External GPU option.
3. Restart VMware Fusion.

Enable Retina Display Support
The Retina display options control the appearance of virtual machines on displays with high pixel density.

• Verify that you are using a Retina display or another high-pixel density display.
• Verify that you are using hardware version 11 or later. Hardware version 14 is recommended.
• Verify that the latest version of VMware Tools is installed.
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• For best appearance and performance, in the Display pane of System Preferences on the Mac host, select Best for
Display in OS X 10.9.5 or Default for Display in OS X 10.10 and later.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Under System Settings in the Settings window, click Display.

4. Select the Use full resolution for Retina display check box.

When the Use full resolution for Retina display option is on, the virtual machine resolution is set to the full Retina
display resolution.

When the Use full resolution for Retina display option is off, the virtual machine resolution is set to half of the Retina
display resolution. This setting matches the non-Retina display size, but might appear pixelated.

5. Select the options for Scaled high resolution.
This option takes effect when an external non-Retina display is connected to a Mac with Retina display. The option
adjusts the user-interface size on an extended non-Retina display to match the user-interface size on the Retina
display.
Option Description
Unity Only Use high resolution scaling for Unity View only.
Unity and Full Screen Use high resolution scaling for Unity View and Full Screen

modes.
Unity and Single Window Use high resolution scaling for Unity View and Single Window

modes.
All View Modes Use high resolution scaling for all view modes.

6. Optional: Select the Automatically adjust user interface size in the virtual machine check box.
Applies to Windows virtual machines only.

Configure Resolution Settings for Virtual Machine Display
You can configure the resolution settings that determine how a virtual machine is displayed.

• Verify that you are using a Retina display or another high-pixel density display.
• Verify that you are using hardware version 11 or later, preferably hardware version 12.
• Verify that the latest version of VMware Tools is installed.
• For best appearance and performance, select Best for Display in the Display pane of System Preferences on the Mac

host.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Under System Settings in the Settings window, click Display.
You use the Virtual Machine Resolution options to select the display settings for single window mode and full screen
mode.

4. Select the Single Window resolution setting.
This setting specifies how the virtual machine displays in single window mode.
Option Description
Use Fusion Display Preferences Uses the global Fusion display preference setting. See Set

Fusion Display Resolution Preferences.
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Option Description
Stretch the virtual machine in the window When the virtual machine window is resized, the virtual machine

display is stretched to fill the window with the resolution
unchanged.

Resize the virtual machine and the window The virtual machine display is resized to fit the single window.

5. Select the Full Screen resolution setting.
This setting specifies how the virtual machine is displayed in full screen mode.
Option Description
Use Fusion Display Preferences Uses the global Fusion display preference setting. See Set

Fusion Display Resolution Preferences.
Center the virtual machine in the screen When the virtual machine enters Full Screen view mode, the

virtual machine display is centered on the screen with the
resolution unchanged.

Stretch the virtual machine in the screen When the virtual machine enters Full Screen view mode, the
virtual machine display is stretched to fill the screen space with
the resolution unchanged.

Resize the virtual machine to fit the screen The virtual machine display is resized to fit the full screen.

Enable Hot Keys for Virtual Machines
If you have Fusion Pro, you can create a keyboard shortcut to define a hot key combination to launch a virtual machine.

• The hot key combination must contain at least one key modifier, such as Control or Command, plus another modifier.
• A hot key combination must be unique to one virtual machine.
• The hot key cannot be a function or a specially defined key such as Return, Escape, Insert, Delete, Home, End, Page

Up, Page Down, F key, Print Screen, Scroll Lock, Pause, or the arrow keys.
• You cannot assign a hot key combination to an application.
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• You cannot use the Tab key as a hot key.

1. Select VMware Fusion > Preferences.

2. Select the Enable per-virtual machine keyboard shortcuts check box.

3. Select Window > Virtual Machine Library.

4. Select a virtual machine in the Virtual Machine Library window and click Settings.

5. Under System Settings in the Settings window, click Keyboard & Mouse.

6. Type the keyboard shortcut to use to trigger the virtual machine.

Configure Discrete Graphics Management
With discrete graphics management, you can manage battery use and performance of applications that use 3D graphics
in a virtual machine.

• Verify that your MacBook Pro has an integrated graphics card and a discrete graphics card. Discrete graphics
management enables the operating system to switch between the two cards.

• Verify that 3D graphics are enabled.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Under System Settings in the Settings window, click Display.

4. Verify that the Accelerate 3D Graphics check box is selected.

5. Select a graphics performance option from the Battery life drop-down menu.
Option Description
Don't Use High Performance Graphics (Longer Battery Life) Maximizes battery life.
Use High Performance Graphics for 3D Applications Only Balances battery life and 3D graphics performance.
Always Use High Performance Graphics (Shorter Battery
Life)

Minimizes battery life.

Add a Device
You can add removable devices to use with your virtual machine.

You can add the following devices to a virtual machine:

• network adapters
• hard disks
• camera
• CD/DVD
• sound card
• USB and Bluetooth
• serial ports
• parallel ports
• Trusted Platform Module device

Configuring the Network Connection
Configure and implement Fusion virtual networking components on your virtual machine to connect to other virtual
machines in your networking environment.
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Fusion supports only Ethernet-based networking, but provides several options for connecting to networks.

• A virtual machine can use NAT to share the IP address of your host system.
• You can configure a virtual machine to bridge to a specific network interface on the host system. Fusion supports IPv6

in bridged networking.
• You can create a VPN that includes only the virtual machines on your host system.

In Fusion, when you edit settings for a virtual network adapter, you can choose from several types of network connections.

Table 9: Network Connection Options

Option Description

Share with my Mac If you want to connect to the Internet or other TCP/IP network using your Mac dial-up
networking connection and you are not able to give your virtual machine an IP address on
the external network, choosing this option is often the easiest way to give the virtual machine
access to that network. The virtual machine does not have its own IP address on the external
network. The virtual machine obtains a private IP address from the VMware virtual DHCP
server.

Bridged Networking items In the Bridged Networking list, you see various choices for bridging to one of the network
interfaces on your Mac, including wireless and Ethernet. Using one of these options is often
the easiest way to give your virtual machine access to a network.
With one of these bridged networking options, the virtual machine appears as an additional
computer on the same physical Ethernet network as your Mac. The virtual machine can use
any of the services available on the network to which it is bridged, including file servers,
printers, gateways, and so on. Likewise, any physical host or other virtual machine configured
with bridged networking can use resources of that virtual machine.

Private to my Mac When you use this type of network connection, the virtual machine is connected to your Mac’s
operating system on a virtual private network, which normally is not visible outside your Mac.
Multiple virtual machines configured with host-only networking on the same Mac are on the
same network.

Connect and Set Up the Network Adapter

You can connect the virtual network adapter for the virtual machine and set the type of networking to use.

Fusion does not support bridged networking to a VPN. If you have set a VPN to have the top priority in your Mac system
preferences, lower its priority if you intend to use bridged networking with autodetect in your virtual machine.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Under Removable Devices in the Settings window, click Network Adapter.

4. Select the Connect Network Adapter check box.
Fusion retains and reapplies the setting you select when you start up the virtual machine.

5. Select the networking type.
Option Description
Share with my Mac The virtual machine does not have its own IP address on the

external network. The virtual machine obtains a private IP
address from the VMware virtual DHCP server.

Bridged Networking items You see various choices for bridging to one of the network
interfaces on your Mac, including wireless and Ethernet. Using
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Option Description
one of these options is often the easiest way to give your virtual
machine access to a network.

When you select any of the network types other than
Autodetect, you can click System Preferences to see details of
the physical network settings for your host system.

Private to my Mac The virtual machine is connected only to the host operating
system, using a virtual private network, which is not visible
outside your Mac.

Related Links
Assign a MAC Address to a Virtual Machine Manually on page 121

You can assign a MAC address manually if you need to ensure that the same MAC address is always assigned to the
virtual network adaptor for a virtual machine.

Add a Network Adapter on page 122
You can add up to ten virtual network adapters to a virtual machine.

Change the Network Adapter on a Remote Virtual Machine on page 123
You can enable and change the virtual network adapter for a virtual machine hosted on a remote server. Your virtual
machine will have access to multiple networks.

Remove a Network Adapter on page 123
You can remove network adapters from your virtual machine.

Simulate a Network Environment with Fusion Pro on page 124
In Fusion Pro, you can use advanced virtual network adapter settings to limit the bandwidth, specify the acceptable packet
loss percentage, and create network latency for incoming and outgoing data transfers for a virtual machine.

Assign a MAC Address to a Virtual Machine Manually

You can assign a MAC address manually if you need to ensure that the same MAC address is always assigned to the
virtual network adaptor for a virtual machine.

Shut down or power off the virtual machine. You cannot change the setting while the virtual machine is powered on or
suspended.

Assign a MAC address manually instead of allowing Fusion to assign it to be sure that the following situations occur:

• The same MAC address is always assigned to the virtual network adaptor for a given virtual machine, even if the
virtual machine is moved.

• A unique MAC address for each virtual machine within a networked environment

When a physical machine is converted to a virtual machine, the MAC address of the network adapter is changed. For
software in which the licensing is linked to the MAC address, this can be a problem. Manually assigning the correct MAC
address is the solution.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Under Removable Devices in the Settings window, click Network Adapter.

4. Click Advanced options.

5. Enter a new MAC address.

• Type a known MAC address.
• Click Generate for Fusion to create a unique address.
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Related Links
Connect and Set Up the Network Adapter on page 120

You can connect the virtual network adapter for the virtual machine and set the type of networking to use.

Add a Network Adapter on page 122
You can add up to ten virtual network adapters to a virtual machine.

Change the Network Adapter on a Remote Virtual Machine on page 123
You can enable and change the virtual network adapter for a virtual machine hosted on a remote server. Your virtual
machine will have access to multiple networks.

Remove a Network Adapter on page 123
You can remove network adapters from your virtual machine.

Simulate a Network Environment with Fusion Pro on page 124
In Fusion Pro, you can use advanced virtual network adapter settings to limit the bandwidth, specify the acceptable packet
loss percentage, and create network latency for incoming and outgoing data transfers for a virtual machine.

Add a Network Adapter

You can add up to ten virtual network adapters to a virtual machine.

• Familiarize yourself with the various types of network configurations. See Configuring the Network Connection.
• Shut down or power off the virtual machine. You cannot change the setting while the virtual machine is powered on or

suspended.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Click Add Device.

4. Click Network Adapter.

5. Click Add.

6. Either select a network configuration from the list or, if you have Fusion Pro, click Configure below the list to create a
new network.

For more information about creating a custom network, see Creating Custom Networks. For more information about
configuring a new network adapter, see Connect and Set Up the Network Adapter.

Related Links
Connect and Set Up the Network Adapter on page 120

You can connect the virtual network adapter for the virtual machine and set the type of networking to use.

Assign a MAC Address to a Virtual Machine Manually on page 121
You can assign a MAC address manually if you need to ensure that the same MAC address is always assigned to the
virtual network adaptor for a virtual machine.

Change the Network Adapter on a Remote Virtual Machine on page 123
You can enable and change the virtual network adapter for a virtual machine hosted on a remote server. Your virtual
machine will have access to multiple networks.

Remove a Network Adapter on page 123
You can remove network adapters from your virtual machine.

Simulate a Network Environment with Fusion Pro on page 124
In Fusion Pro, you can use advanced virtual network adapter settings to limit the bandwidth, specify the acceptable packet
loss percentage, and create network latency for incoming and outgoing data transfers for a virtual machine.
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Change the Network Adapter on a Remote Virtual Machine

You can enable and change the virtual network adapter for a virtual machine hosted on a remote server. Your virtual
machine will have access to multiple networks.

Verify that the following conditions are met:

• You have login credentials for the server where the virtual machine is hosted.
• The virtual machine is powered on.

1. Select File > Connect to Server.

2. Enter the name of the host server or select a server from the Recent Servers drop-down menu.

3. Enter your login credentials and click Connect.

4. Select Virtual Machine > Settings.

5. Click Network Adapter.

6. Select the network adapter from the Network Connection drop-down menu.

Related Links
Connect and Set Up the Network Adapter on page 120

You can connect the virtual network adapter for the virtual machine and set the type of networking to use.

Assign a MAC Address to a Virtual Machine Manually on page 121
You can assign a MAC address manually if you need to ensure that the same MAC address is always assigned to the
virtual network adaptor for a virtual machine.

Add a Network Adapter on page 122
You can add up to ten virtual network adapters to a virtual machine.

Remove a Network Adapter on page 123
You can remove network adapters from your virtual machine.

Simulate a Network Environment with Fusion Pro on page 124
In Fusion Pro, you can use advanced virtual network adapter settings to limit the bandwidth, specify the acceptable packet
loss percentage, and create network latency for incoming and outgoing data transfers for a virtual machine.

Remove a Network Adapter

You can remove network adapters from your virtual machine.

Shut down or power off the virtual machine. You cannot change the setting while the virtual machine is powered on or
suspended.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Under Removable Devices in the Settings window, click Network Adapter.

4. Under Advanced options, click Remove Network Adapter.

5. Click Remove in the confirmation dialog box.

Related Links
Connect and Set Up the Network Adapter on page 120

You can connect the virtual network adapter for the virtual machine and set the type of networking to use.

Assign a MAC Address to a Virtual Machine Manually on page 121
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You can assign a MAC address manually if you need to ensure that the same MAC address is always assigned to the
virtual network adaptor for a virtual machine.

Add a Network Adapter on page 122
You can add up to ten virtual network adapters to a virtual machine.

Change the Network Adapter on a Remote Virtual Machine on page 123
You can enable and change the virtual network adapter for a virtual machine hosted on a remote server. Your virtual
machine will have access to multiple networks.

Simulate a Network Environment with Fusion Pro on page 124
In Fusion Pro, you can use advanced virtual network adapter settings to limit the bandwidth, specify the acceptable packet
loss percentage, and create network latency for incoming and outgoing data transfers for a virtual machine.

Simulate a Network Environment with Fusion Pro

In Fusion Pro, you can use advanced virtual network adapter settings to limit the bandwidth, specify the acceptable packet
loss percentage, and create network latency for incoming and outgoing data transfers for a virtual machine.

The advanced virtual network adapter settings allow you to simulate a network environment that differs from your own.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Under Removable Devices in the Settings window, click Network Adapter.

4. Expand Advanced options.

5. Select incoming and outgoing bandwidth settings.
This setting allows you to simulate network bandwidth.
Option Description
Limit incoming or outgoing data transfers to the data
transfer rate for a specific network connection type

Select the network connection type from the Bandwidth drop-
down menu. The value in the Kbps text box changes to the data
transfer rate, in kilobits per second, of the network connection
type that you select. For example, if you select Leased Line T1
(1.544 Mbps), the value in the Kbps text box changes to 1544.

Limit incoming or outgoing data transfers to a specific data
transfer rate

Select Custom and type the data transfer rate, in kilobits per
second, in the Kbps text box.

6. Enter the acceptable packet loss percentage for incoming and outgoing data transfers in the Packet Loss (%) text
box.
This setting allows you to simulate network packet loss. The default setting is 0.0%. The packet loss range is 0 to
100%.

7. Enter numbers to set the latency in milliseconds for incoming and outgoing data transfers.
This setting allows you to simulate network latency. The latency range is 0 to 2,000 ms.

Related Links
Connect and Set Up the Network Adapter on page 120

You can connect the virtual network adapter for the virtual machine and set the type of networking to use.

Assign a MAC Address to a Virtual Machine Manually on page 121
You can assign a MAC address manually if you need to ensure that the same MAC address is always assigned to the
virtual network adaptor for a virtual machine.

Add a Network Adapter on page 122
You can add up to ten virtual network adapters to a virtual machine.
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Change the Network Adapter on a Remote Virtual Machine on page 123
You can enable and change the virtual network adapter for a virtual machine hosted on a remote server. Your virtual
machine will have access to multiple networks.

Remove a Network Adapter on page 123
You can remove network adapters from your virtual machine.

Managing Virtual Hard Disks
You can add, remove, and resize virtual hard disks.

If you want to add more disk space to your virtual machine, you can resize your existing virtual hard disk, or add a
separate, additional hard disk.

NOTE
Having manual or AutoProtect snapshots in your virtual machine prevents you from making changes to a virtual
hard disk. You must delete the snapshots before you can make a change.

Changing the Bus Type of the Virtual Hard Disk

CAUTION
In the following situations, after you select a bus type for a virtual hard disk, do not change the bus type.

• On a system boot disk with the operating system installed
Some operating systems are incapable of changing the storage controller of the boot device.

• A virtual machine created using Easy Install
When you select Customize Settings at the end of an Easy Install configuration and change the hard disk to
a non-default bus type, the operating system might fail.

Create a Virtual Hard Disk

You might require more disk space in a virtual machine. For example, if you want to install a large application or work with
a large number of files. You can increase the size of the virtual disk already associated with your virtual machine, or you
can add a new virtual disk. You can create a virtual hard disk to add to a virtual machine.

Shut down or power off the virtual machine. You cannot change the setting while the virtual machine is powered on or
suspended.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Click Add Device.

4. Click New Hard Disk.

5. Click Add.
A new hard disk appears. The new hard disk is selected and a default filename appears in the File name pop-up
menu.

6. Optional: Change the filename for the new virtual hard disk.
a) Select the filename in the pop-up menu and select Save As.
b) Type the filename for the hard disk in the Save as field and click Save.
Fusion creates the virtual disk file with this name and stores it in the App bundle directory.

7. Use the Disk size slider to set the maximum size for the hard disk.
The maximum size for any hard disk is 8 TB.
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8. Optional: Under Advanced options, set the Bus type for the hard disk to IDE, SCSI, SATA, or NVMe.

NOTE
If the guest operating system does not support NVMe, the NVMe option appears unavailable.

Changing this setting is recommended only for advanced users. Fusion selects the bus type that is most appropriate
for the virtual machine guest operating system.

9. Set your disk space configuration, depending on the constraints of the file system.
Option Description
Pre-allocate disk space Can give better performance for your virtual machine. If you

allocate all the disk now, you cannot use the VMware Tools
shrink disk feature later. Allocating all disk space now is a
time-consuming operation that cannot be canceled. Also, the
allocation process requires as much physical disk space as you
specify for the virtual disk.

Split disk into multiple files Default. Some file systems, such as FAT and UFS, cannot
support very large files. Use this option if your virtual machine
will be used in a hard drive with a file system that does not
support very large files. This option splits your virtual disk into
multiple files. Also, use this option if you might place the virtual
machine on an external FAT drive or if you might move the
virtual machine to an external drive.

10. Click Apply.
The hard disk is created. View the new hard disk in Settings > Removable Devices of the virtual machine.

Resize a Hard Disk

You can increase the usable space in a virtual hard disk. You cannot reduce the size of a hard disk. You cannot make a
blank hard disk smaller after it has been formatted.

Having manual or AutoProtect snapshots in your virtual machine prevents you from making changes to a virtual hard disk.
You must delete the snapshots before you can make a change.

Shut down or power off the virtual machine. You cannot change the setting while the virtual machine is powered on or
suspended.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. In the Settings window, click the hard disk you want to resize.

4. Use the Disk size slider to set the new size.
The maximum disk size for any hard disk is 8TB.

5. Optional: Under Advanced options, set the Bus type for the hard disk to IDE, SCSI, SATA, or NVMe.

NOTE
If the guest operating system does not support NVMe, the NVMe option appears unavailable.

Changing this setting is recommended only for advanced users. Fusion selects the bus type that is most appropriate
for the virtual machine guest operating system.

6. Set your disk space configuration, depending on the constraints of the file system.
Option Description
Pre-allocate disk space Can give better performance for your virtual machine. If you

allocate all the disk now, you cannot use the VMware Tools
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Option Description
shrink disk feature later. Allocating all disk space now is a
time-consuming operation that cannot be canceled. Also, the
allocation process requires as much physical disk space as you
specify for the virtual disk.

Split disk into multiple files Default. Some file systems, such as FAT and UFS, cannot
support very large files. Use this option if your virtual machine
will be used in a hard drive with a file system that does not
support very large files. This option splits your virtual disk into
multiple files. Also, use this option if you might place the virtual
machine on an external FAT drive or if you might move the
virtual machine to an external drive.

7. Apply the changes and choose automatic or manual partition resize for Windows guests.
Option Description
Click Apply. For Windows guests, the partition is automatically resized when

the hard disk is resized.
Click Apply while pressing the Option key. The hard disk is resized but the partition is not. To manually

resize the partition of the guest, see Resize a Windows Partition
with the Disk Management Tool.

Fusion displays a progress dialog box as it rebuilds the virtual disk.
Resize a Windows Partition with the Disk Management Tool

When you enlarge your virtual hard disk, you must also enlarge your guest operating system's partition to take advantage
of the additional space.

Verify that your virtual hard disk is big enough to accept the increase in partition size. See Resize a Hard Disk.

Fusion resizes the guest operating system's partition when you resize the virtual hard disk. If you held down the Option
key when you clicked Apply to resize the disk, you can manually resize the Windows partition. For Windows Vista and
Windows 7 or later, you can use the operating system's Disk Management tool to resize a partition.

1. Right-click Computer and select Manage.

2. Double-click Storage.

3. Double-click Disk Management.

4. In the list, right-click the partition to expand and select Extend Volume.

5. Follow the prompts to resize the partition and click Finish.
The partition item in the Disk Management pane displays its new size.

6. Close the Computer Management  window

Clean up a Virtual Machine

You can perform a manual or automated cleanup of certain virtual machines to free up space on your Mac. The cleanup
compacts and defragments the virtual machine.

To perform a manual cleanup, shut down or power off the virtual machine. You cannot perform the manual cleanup while
the virtual machine is powered on or suspended.

When you delete files from your virtual machine, Fusion does not return the space to your Mac. Cleaning up the virtual
machine performs the following operations.

• Compacts the virtual machine and returns freed space to your Mac.
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NOTE
Only Windows virtual machines return freed space to your Mac.

• Defragments the virtual machine.
• Consolidates any unconsolidated snapshot files left on the virtual machine. Unconsolidated snapshot files can be left

on the virtual machine when manually deleting a snapshot fails.

Disk cleanup is not supported in the following situations.

• The virtual hard disk uses a FAT32, FAT, or exFAT file system.
• The virtual hard disk uses a preallocated disk format.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Under System Settings in the Settings window, click General.

4. Select a cleanup option.

Manual Click Clean Up Virtual Machine.
This option is only available when a Windows virtual machine
has disk space to reclaim, or when any virtual machine has
unconsolidated snapshot files.
Fusion displays a progress dialog box as it cleans up the virtual
machine.

Automated Select Clean up disks after shutting down virtual machine.
Fusion cleans up the virtual machine every time the virtual
machine is shut down.

Add an Existing Virtual Hard Disk

You can add an existing virtual hard disk to a virtual machine. You can copy or move the disk to your virtual machine, or
share it between virtual machines.

CAUTION
Moving the virtual hard disk can break other virtual machines that are using the virtual hard disk, because this is
the equivalent of removing the hard disk from one physical computer and installing it in another.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Click Add Device.

4. Click Existing Hard Disk.

5. Click Add Device.

6. In the Open dialog, navigate to the location of the existing .vmdk hard disk file.

7. Select the method for adding the virtual hard disk file.
Option Description
Make a separate copy of the virtual disk Default. Copies the virtual hard disk file to this virtual machine’s

package. Copying the virtual hard disk ensures that no conflicts
exist between this virtual machine and any other virtual machine
that might be using the virtual hard disk.

Share this virtual disk with the virtual machine that created
it

Virtual hard disk file remains in its original location. This might
cause a conflict if it is also being used by that original virtual
machine.
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Option Description
Take this disk away from the virtual machine currently
using it

Moves the virtual hard disk file to this virtual machine’s package.

8. Click Open.

9. Click Apply.

Fusion displays a progress dialog box if you select to copy the virtual disk.
Add a VMDK on a Remote Virtual Machine

You can add a virtual hard disk and select a disk image on a virtual machine hosted on a remote server.

Verify that the following conditions are met:

• You have login credentials for the server where the virtual machine is hosted.
• The virtual machine is powered off.

1. Select File > Connect to Server.

2. Enter the name of the host server or select a server from the Recent Servers drop-down menu.

3. Enter your login credentials and click Connect.

4. Select Virtual Machine > Settings.

5. Click Add Device.

6. Click Hard Disk.

7. Select a .vmdk file from the File name drop-down menu.

8. Use the disk size slider to specify the size of the virtual disk.

9. Optional: Expand Advanced options and select a bus type and choose how to allocate the disk space.

Remove a Hard Disk

You can remove a virtual hard disk from your virtual machine.

Shut down or power off the virtual machine. You cannot change the setting while the virtual machine is powered on or
suspended.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. In the Settings window, click the hard disk to remove from the virtual machine.

4. Under Advanced options, click Remove Hard Disk.

5. In the confirmation window, select the option for removing the hard disk.
Option Description
Keep File The virtual hard disk is disconnected from the virtual machine,

but the hard disk files remain in the virtual machine package.
Move to Trash The virtual hard disk files are deleted from the virtual machine

package.

Using Virtual DiskManager

Virtual Disk Manager (vmware-vdiskmanager) is a Fusion utility that you can use to create, manage, and modify virtual
disk files from the command line or in scripts.
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Virtual Disk Manager is included when Fusion is installed. With Virtual Disk Manager, you can enlarge a virtual disk so
that its maximum capacity is larger than it was when you created it. This feature is useful if you need more disk space in a
given virtual machine, but do not want to add another virtual disk or use ghosting software to transfer the data on a virtual
disk to a larger virtual disk.

You can also use Virtual Disk Manager to change how disk space is allocated for a virtual hard disk. You can preallocate
all the disk space in advance or configure the disk to grow as more disk space is needed. If you allocate all the disk space
but later need to reclaim some hard disk space on the host system, you can convert the preallocated virtual disk into a
growable disk. The new virtual disk is still large enough to contain all the data in the original virtual hard disk. You can also
change whether the virtual hard disk is stored in a single file or split into 2GB files.

The Virtual Disk Manager file, vmware-vdiskmanager, is located in the Applications/VMware Fusion.app/
Contents/Library directory.

Configuring the CD/DVD Drive
You can connect the virtual machine's CD/DVD drive to the Mac physical CD/DVD drive or to a CD or DVD ISO image.

Add a CD/DVD Drive

You can add a virtual CD/DVD drive to a virtual machine.

Shut down or power off the virtual machine. You cannot change the setting while the virtual machine is powered on or
suspended.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Click Add Device.

4. Click CD/DVD Drive.

5. Click Add.

6. Configure the drive.
Option Description
Automatically detect physical CD/DVD The virtual machine detects your Mac CD/DVD drive.
Specify physical CD/DVD Directs the virtual machine’s CD/DVD drive to a physical drive.
Use disk image Directs the virtual machine’s CD/DVD drive to an ISO image.

Click the pop-up menu to browse for and select the ISO image
file.

Related Links
Remove a CD/DVD Drive on page 131

You can remove a physical or virtual CD/DVD drive from your virtual machine.

Connect and Set Up a CD/DVD Drive on page 131
You can set up a CD/DVD drive so that it is always detected, or so that you must connect it manually.

Connect and Disconnect the CD/DVD Drive Without Using the Settings Window on page 132
You can use the buttons on the status bar to connect and disconnect devices.

Create a CD/DVD Image on page 132
You can use the Apple Disk Utility to create CD/DVD disk images.

Enable a CD/DVD Drive on a Remote Virtual Machine on page 113
You can enable a CD/DVD drive and select a disk image on a virtual machine hosted on a remote server. You can access
or install software from a physical CD/DVD drive on to your remote virtual machine.
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Remove a CD/DVD Drive

You can remove a physical or virtual CD/DVD drive from your virtual machine.

Shut down or power off the virtual machine. You cannot change the setting while the virtual machine is powered on or
suspended.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Under Removable Devices in the Settings window, click the CD/DVD drive to remove.

4. Under Advanced options, click Remove CD/DVD Drive.

Related Links
Add a CD/DVD Drive on page 130

You can add a virtual CD/DVD drive to a virtual machine.

Connect and Set Up a CD/DVD Drive on page 131
You can set up a CD/DVD drive so that it is always detected, or so that you must connect it manually.

Connect and Disconnect the CD/DVD Drive Without Using the Settings Window on page 132
You can use the buttons on the status bar to connect and disconnect devices.

Create a CD/DVD Image on page 132
You can use the Apple Disk Utility to create CD/DVD disk images.

Enable a CD/DVD Drive on a Remote Virtual Machine on page 113
You can enable a CD/DVD drive and select a disk image on a virtual machine hosted on a remote server. You can access
or install software from a physical CD/DVD drive on to your remote virtual machine.

Connect and Set Up a CD/DVD Drive

You can set up a CD/DVD drive so that it is always detected, or so that you must connect it manually.

You can turn off the Automatically detect physical CD/DVD feature while the virtual machine is powered on, but you must
power off the virtual machine before you can enable this feature. Use the Shut Down command in the Virtual Machine
menu.

If your CD/DVD drive is a USB device, Fusion handles it as a USB device, not a CD/DVD drive. See Configuring the USB
Controller and Connecting USB Devices.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Under Removable Devices in the Settings window, click the CD/DVD drive to connect.

4. Select the Connect CD/DVD Drive check box.

Related Links
Add a CD/DVD Drive on page 130

You can add a virtual CD/DVD drive to a virtual machine.

Remove a CD/DVD Drive on page 131
You can remove a physical or virtual CD/DVD drive from your virtual machine.

Connect and Disconnect the CD/DVD Drive Without Using the Settings Window on page 132
You can use the buttons on the status bar to connect and disconnect devices.

Create a CD/DVD Image on page 132
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You can use the Apple Disk Utility to create CD/DVD disk images.

Enable a CD/DVD Drive on a Remote Virtual Machine on page 113
You can enable a CD/DVD drive and select a disk image on a virtual machine hosted on a remote server. You can access
or install software from a physical CD/DVD drive on to your remote virtual machine.

Connect and Disconnect the CD/DVD Drive Without Using the Settings Window

You can use the buttons on the status bar to connect and disconnect devices.

• Click the CD/DVD device button in the status bar.

Related Links
Add a CD/DVD Drive on page 130

You can add a virtual CD/DVD drive to a virtual machine.

Remove a CD/DVD Drive on page 131
You can remove a physical or virtual CD/DVD drive from your virtual machine.

Connect and Set Up a CD/DVD Drive on page 131
You can set up a CD/DVD drive so that it is always detected, or so that you must connect it manually.

Create a CD/DVD Image on page 132
You can use the Apple Disk Utility to create CD/DVD disk images.

Enable a CD/DVD Drive on a Remote Virtual Machine on page 113
You can enable a CD/DVD drive and select a disk image on a virtual machine hosted on a remote server. You can access
or install software from a physical CD/DVD drive on to your remote virtual machine.

Create a CD/DVD Image

You can use the Apple Disk Utility to create CD/DVD disk images.

1. Start the Mac Disk Utility by going to Applications/Utilities/Disk Utility on your Mac.

2. Insert the CD/DVD for which you need an image.

3. In the Disk Utility window, select the CD/DVD disk and click New Image.

4. In the Image Format pop-down menu, select DVD/CD Master

5. In the Encryption pop-down menu, select None.

6. Save the CD/DVD image to the chosen location.

To attach the images to a virtual machine, see Connect and Set Up a CD/DVD Drive.

Related Links
Add a CD/DVD Drive on page 130

You can add a virtual CD/DVD drive to a virtual machine.

Remove a CD/DVD Drive on page 131
You can remove a physical or virtual CD/DVD drive from your virtual machine.

Connect and Set Up a CD/DVD Drive on page 131
You can set up a CD/DVD drive so that it is always detected, or so that you must connect it manually.

Connect and Disconnect the CD/DVD Drive Without Using the Settings Window on page 132
You can use the buttons on the status bar to connect and disconnect devices.

Enable a CD/DVD Drive on a Remote Virtual Machine on page 113
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You can enable a CD/DVD drive and select a disk image on a virtual machine hosted on a remote server. You can access
or install software from a physical CD/DVD drive on to your remote virtual machine.

Enable a CD/DVD Drive on a Remote Virtual Machine

You can enable a CD/DVD drive and select a disk image on a virtual machine hosted on a remote server. You can access
or install software from a physical CD/DVD drive on to your remote virtual machine.

Verify that the following conditions are met:

• You have login credentials for the server where the virtual machine is hosted.
• The virtual machine is powered on.

1. Select File > Connect to Server.

2. Enter the name of the host server or select a server from the Recent Servers drop-down menu.

3. Enter your login credentials and click Connect.

4. Select Virtual Machine > Settings.

5. Click CD/DVD Drive.

6. Select the Enable CD/DVD Drive check box.

7. Select a remote disc image from the Choose a remote disc image drop-down menu.

8. Optional: Expand Advanced options and select a bus type from the drop-down menu.

9. Optional: Click Remove CD/DVD Drive to return to the CD/DVD drive that your virtual machine uses.

Related Links
Add a CD/DVD Drive on page 130

You can add a virtual CD/DVD drive to a virtual machine.

Remove a CD/DVD Drive on page 131
You can remove a physical or virtual CD/DVD drive from your virtual machine.

Connect and Set Up a CD/DVD Drive on page 131
You can set up a CD/DVD drive so that it is always detected, or so that you must connect it manually.

Connect and Disconnect the CD/DVD Drive Without Using the Settings Window on page 132
You can use the buttons on the status bar to connect and disconnect devices.

Create a CD/DVD Image on page 132
You can use the Apple Disk Utility to create CD/DVD disk images.

Configuring a Floppy Device
You can add a virtual floppy device to a virtual machine and configure the floppy device to connect to a floppy image file.

You can also connect and disconnect the floppy device in Fusion. A virtual machine can have no more than two floppy
devices.

Add a Floppy Device

You can add a floppy device to your virtual machine to access data on a floppy disk image file.

Shut down or power off the virtual machine. You cannot change the setting while the virtual machine is powered on or
suspended.
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You must have a floppy image file with one of the following filename extensions:

• .flp
• .img
• .dsk
• .fdd

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Click Add Device.

4. Click Floppy Drive.

5. Click Add.

6. Browse to the floppy image file and select it.

7. Click Open.

Configure the new floppy device, as described in Connect and Set Up a Floppy Device .

Connect and Set Up a Floppy Device

You can configure how your virtual machine can use a floppy device to access data on a floppy disk image file.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Click Add Device.

4. Select the floppy device in the source list in the Other Devices panel.

5. Select or deselect the Connected check box to connect or disconnect the floppy device.

6. Optional: Select Read only to make the contents of the floppy device read-only.

7. Select Use floppy image and click Choose to browse for the floppy image file to connect the floppy device to a floppy
image file.
If you are working with a virtual machine that is configured to use a physical floppy drive, or any type of floppy device
other than a floppy image file, the Use a custom unsupported setting option is selected. Fusion supports only floppy
image files for use with a virtual floppy device.

Create a Floppy Disk Image

To read data from a floppy disk to a virtual machine, you must create a disk image that the virtual machine can recognize.

Some operating systems require you to use floppy disks to install them. Because the Mac does not include a physical
floppy drive, and because Fusion supports floppy images only, you must use a USB floppy drive to create floppy images.
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The Apple Disk Utility can create floppy disk images for this purpose.

1. Attach a USB floppy drive to your Mac.

2. Start the Mac Disk Utility by going to Applications/Utilities/Disk Utility on your Mac.

3. Insert the floppy disk for which you need an image.

4. In the Disk Utility window, select the floppy disk and click New Image.

5. In the Image Format pop-up menu, select read/write.

6. In the Encryption pop-up menu, select None.

7. Save the floppy disk image to the chosen location.

8. In the Finder, right-click on the created floppy image and select Get Info.

9. In Name & Extension, change the file extension from .dmg to .flp and close the Get Info window.
Confirm the change when prompted.

10. Optional: Repeat the process for each floppy disk to create.

To attach the images to a virtual machine, see Connect and Set Up a Floppy Device .

Enable a Floppy Drive on a Remote Virtual Machine

You can enable a floppy drive and select a disk image on a virtual machine hosted on a remote server. You can access or
install software from a physical floppy drive on to your remote virtual machine.

Verify that the following conditions are met:

• You have login credentials for the server where the virtual machine is hosted.
• The virtual machine is powered on.

1. Select File > Connect to Server.

2. Enter the name of the host server or select a server from the Recent Servers drop-down menu.

3. Enter your login credentials and click Connect.

4. Select Virtual Machine > Settings.

5. Click Floppy.

6. Click the Enable Floppy Drive check box.

7. Select a floppy image from the drop-down menu.

Configuring the Sound Card
A virtual machine can have only one sound card. You can add a sound card only if you remove the existing sound card.
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Connect the Sound Card

You can enable your virtual machine to use the Mac's sound device.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Under Removable Devices in the Settings window, click Sound Card.

4. Select the Connect Sound Card check box.

5. Select the Output Device and Input Device

6. Optional: Select the Enable Echo Cancellation check box if there is sound echo in your virtual machine.

Connect and Disconnect a Sound Adapter Without Using the Settings Window

You can use the buttons on the status bar to connect and disconnect devices.

• Click the sound device button in the status bar.

Add a Sound Adapter

You can add a sound adapter if one was previously removed.

Shut down or power off the virtual machine. You cannot change the setting while the virtual machine is powered on or
suspended.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Click Add Device.

4. Click Sound Card and click Add.

5. Select the output and input device to add.

Remove a Sound Adapter

Before you can add a new sound adapter, you must remove the existing one.

Shut down or power off the virtual machine. You cannot change the setting while the virtual machine is powered on or
suspended.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Under Removable Devices in the Settings window, click Sound Card.

4. Click Remove Sound Card.

5. Click Remove in the confirmation dialog box.

Add a Camera to a Virtual Machine
You can enable one or more cameras on a virtual machine.
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Verify that the following conditions are met:

• You have one or more cameras on the host system, either built-in or connected to a USB device.
• The virtual machine uses hardware version 11 or later.
• The virtual machine is local to your Mac, rather than hosted on a remote server.

1. Select  Virtual Machine > Settings.

2. Click  Add Device.

3. Select Camera.

4. Click Add.
Ordinarily, the default camera of the host system is added to the virtual machine. You can select a camera by name. If
a named camera is chosen, the camera of your virtual machine is connected explicitly to that camera. In that case, the
camera might not connect if you move the virtual machine to another host, or if you remove the named camera from
the host system.

Configuring the USB Controller and Connecting USB Devices
You can configure the virtual USB controller to enable USB 3.0/3.1 and 2.0 support. You can also configure the virtual
USB controller to connect USB devices to the virtual machine when such devices are connected to the Mac while the
virtual machine is active. The settings you select can persist across several VMware products, such as Workstation Pro
and VMware Horizon 7.

If you have a Mac that supports connecting USB 3.0/3.1 devices, guest operating systems can connect to USB 3.0/3.1
devices as USB 3.0/3.1 and connect to USB 2.0 devices as USB 2.0. However, guests with virtual USB 2.0 hardware
have issues when connecting to USB 3.0/3.1 devices. An example of a guest operating system that does not have virtual
USB 3.0/3.1 hardware is Windows XP. Depending on the specific device, performance might be slow or partial, or the
device might fail to connect.

Guests on older Macs can have virtual USB 3.0/3.1 virtual hardware, but both USB 2.0 and USB 3.0/3.1 devices connect
in USB 2.0 mode. Guests with virtual USB 2.0 hardware also use USB 2.0 mode for USB 2.0 and USB 3.0/3.1 devices.

NOTE
Fusion does not support USB adapters for connecting displays to your virtual machines.

Add the USB Controller

You can add a virtual USB controller to allow your virtual machine to work with the USB devices that are connected to
your Mac.

Shut down or power off the virtual machine. You cannot change the setting while the virtual machine is powered on or
suspended.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Under Removable Devices in the Settings window, click USB & Bluetooth.

4. Under Advanced USB options, use the drop-down menu to select how Fusion should respond when a USB device is
plugged in to your Mac.

NOTE
Support for USB 3.0 SuperSpeed and USB 3.1 SuperSpeed plus devices requires a suitably equipped Mac
and a guest operating system that supports USB 3.0/3.1 devices.
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Remove the USB Controller

You can remove a USB controller from your virtual machine.

Shut down or power off the virtual machine. You cannot change the setting while the virtual machine is powered on or
suspended.

When you remove the USB controller, you cannot connect a USB device to the virtual machine.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Under Removable Devices in the Settings window, click USB & Bluetooth.

4. Under Advanced USB options, click Remove USB Controller.

5. Click Remove in the confirmation dialog box.

Choose Where to Connect a USB Device When You Plug It In

When a virtual machine is running, you can select whether a USB device connects to your Mac or to your virtual machine
when you plug the device in.

Fusion must be open, with a virtual machine powered on.

With Fusion, you can select what system a USB device connects to when you plug it in. You can also set that choice as
the default connection whenever you attach that device in the future.

1. Plug the USB device into your Mac.
The selection dialog box appears. If no dialog box appears, you already set a default connection for this device in the
USB settings panel.

2. Optional: To make your connection selection the default for this device in the future, select Remember my choice and
do not ask again.
You can change this default at any time in the USB & Bluetooth settings panel.

3. Select the system to which you want to connect the device.
The action you take depends on how many virtual machines are open.
Option Description
If you have one virtual machine powered on Select Connect to Mac or Connect to OS of your open

virtual machine.
If you have two or more virtual machines powered on In the pop-up menu, select Connect to your Mac or Connect

to virtual machine name for the selected virtual machine.
Click OK.

Set the Default Plug-In Action for a USB Device

You can set whether a USB device connects to your Mac or to your virtual machine whenever you attach the device.
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Fusion must be open, with a virtual machine powered on.

This setting can be different for each virtual machine. If you set the default plug-in action for a virtual machine, but the
virtual machine is not powered on when you attach the device, the device attaches to the Mac.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Under Removable Devices in the Settings window, click USB & Bluetooth.

4. Select the USB device in the list.

5. Under Advanced USB options, select the plug-in behavior for the device.
Option Description
Ask what to do Fusion asks if you want to attach the device to the Mac or the

virtual machine.
Connect to this virtual machine Only the virtual machine recognizes the device. The Mac does

not recognize the device.
Connect to your Mac Only the Mac recognizes the device. The virtual machine does

not recognize the device.

This option is the default behavior.

Connect and Disconnect USB Devices

You can connect USB devices to your virtual machines through your Mac.

If you disconnect a USB device and reconnect it right away, it will reconnect to the virtual machine that it was previously
connected to. To change the connection, reconnect to a different USB port on your Mac.

Connecting a USB device to the virtual machine makes the USB device unavailable to your Mac.
If your CD/DVD drive is a USB device, Fusion handles it as a USB device, not a CD/DVD drive.

1. Select Window > Virtual Machine Library.

2. Under Removable Devices in the Settings window, click USB & Bluetooth.

3. In the Connect USB devices section, select or deselect the check box next to the USB device to connect or disconnect
that device.

Connect and Disconnect a USB Device Using the Virtual Machine Toolbar

You can use the buttons on the status bar to connect and disconnect devices.

1. Click the device button in the status bar.

2. Click Connect name of device.

Connect a USB Smart Card Reader

You connect a USB smart card reader with a process different from the process used for other USB devices.

When you attach a smart card reader to your computer, the reader appears as two separate USB devices in the Fusion
interface. You can use smart cards in virtual mode or USB passthrough mode. These mode are mutually exclusive. You
must pick one or the other.

• Virtual mode (Recommended): The smart card reader device is available as Virtual model name of your smart
card reader USB Smart Card Reader. After the virtual reader is connected to the virtual machine, it appears as
Virtual the model name of your smart card reader USB Smart Card Reader under the device list in the
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guest operating system. In virtual mode, the smart card reader can be shared among applications on the host and
among applications within different guests on the host.

• USB passthrough mode: The smart card reader device is available as model name of your smart card
reader  USB Smart Card Reader. When you connect the reader to the guest, it appears as model name of
the smart card reader USB Smart Card Reader under the device list in the guest operating system. In USB
passthrough mode, a single virtual machine directly controls the physical smart card reader. A USB passthrough smart
card reader cannot be used by applications on the host or by applications within other virtual machines. Use USB
passthrough mode only if connection in virtual mode does not work well for your computing environment.

NOTE
Disconnect your current mode before you switch to a different mode.

• For virtual mode, select Virtual Machine > USB & Bluetooth > Connect the model name of your smart card
reader USB Smart Card Reader.
When you select the virtual mode device, the passthrough mode the model name of your smart card
reader Smart Card Reader device no longer appears, except in Linux virtual machines.

• For USB passthrough mode, select Virtual Machine > USB & Bluetooth > Connect the model name of your
smart card reader USB Smart Card Reader.

• To disconnect either mode, select Virtual Machine > USB & Bluetooth and the device to disconnect, and click
Disconnect.

USB Connection Dialog Box Disappears Before Connection Can Be Made

In rare cases, a USB device disconnects itself before Fusion can recognize it.

When you plug in a USB device, the Fusion EasyConnect dialog box appears, but disappears before you have an
opportunity to take an action. The USB device is then not visible to either your Mac or your virtual machine.

Some USB devices disconnect very quickly if they do not receive an immediate response upon connection. Occasionally,
Fusion USB EasyConnect does not produce a response in the time required by these USB devices.

To work around this problem, you must configure the virtual machine so that Fusion connects unknown devices without
first having to ask about the type of connection.

1. Shut down or power off the virtual machine.

2. Select Window > Virtual Machine Library.

3. Select a virtual machine in the Virtual Machine Library window and click Settings.

4. Under Removable Devices in the Settings window, click USB & Bluetooth.

5. Under Advanced USB options, if the first option is set to Ask what to do, change the setting to Connect to this
virtual machine or Connect to your Mac.

6. Start up the virtual machine.
Plugging in a USB device results in it being connected to the virtual machine or Mac, depending on your setting,
without going through the USB EasyConnect dialog. The device is also visible to the Fusion interface, so you can see
it in Settings > USB & Bluetooth.

Add a Parallel Port
You can add a parallel port to your virtual machine.
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Shut down or power off the virtual machine. You cannot change the setting while the virtual machine is powered on or
suspended.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Click Add Device.

4. Click Parallel Port.

5. Click Add.

6. Browse to the location to save the output file of the virtual parallel port.

7. Type a name for the file in the Save As field.

8. Click Save.

Add a Serial Port
You can add a serial port to your virtual machine.

Shut down or power off the virtual machine. You cannot change the setting while the virtual machine is powered on or
suspended.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Click Add Device.

4. Click Serial Port.

5. Click Add.

6. Browse to the location to save the output file of the virtual serial port.

7. Type a name for the file in the Save As field.

8. Click Save.

Sharing Bluetooth Devices with a Virtual Machine
You can attach a Bluetooth device to a virtual machine

NOTE
Bluetooth device support is removed in VMware Fusion 13.6 and later.

Fusion supports these types of Bluetooth devices:

• Cell phones
• GPS receivers
• Serial Port Profile (SPP) devices
• Most other devices

Fusion has limited support for these types of Bluetooth devices:

• Input devices (HID): Can be attached to guests when using Linux/macOS hosts, but not on Windows hosts.
OBEX File Transfer: Outgoing (guest to device) transfers only. Guest may not act as an OBEX server.
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Fusion does not support these types of Bluetooth devices:

• Headphones
• Headsets
• Hands-free audio devices

Fusion has the following limitations for Bluetooth support:

• Only out going connections are allowed. A virtual machine may establish a connection to a remote Bluetooth device,
but remote devices do not see services that virtual machines try to advertise.

• Virtual machines cannot change the name, class, or discoverability of the host's Bluetooth adapter. The host is
exclusively in control over setting whether other Bluetooth devices can discover the host, and what name is used.

• The host is exclusively in control of the pairing process and collecting or displaying PIN numbers. The guest may scan
for devices, and initiate a connection with any device. If pairing is required, the pairing dialog box appears on the host,
not in the guest. From the guest's perspective, the device appears to pair without having needed a PIN.

• Any vendor-specific capabilities on the host's Bluetooth radio are not passed through to the guest. For example, some
radios provide a vendor-specific command to change their BDADDR. These commands do not appear in the guest.
The guest sees a generic VMware-brand radio.

• The virtual Bluetooth controller itself is not part of snapshots. During snapshots, it is disconnected and reconnected.
Any ongoing connections with Bluetooth devices are terminated at the time of a snapshot.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Under Removable Devices in the Settings window, click USB & Bluetooth.

4. Select the Share Bluetooth devices with the virtual machine check box.
The virtual Bluetooth radio appears in the guest. You might see notifications from the guest OS that new hardware was
detected. No action is required because the driver is automatically installed.

5. Use the guest's Bluetooth interface to search for nearby devices to pair with. Devices appear in the list as they are
detected.

6. Select the device you want to connect with and select to connect to it.

7. Pair the device with the host.
If you have not paired this device with this host before, you are prompted to do so now. The host may ask you for a
PIN, or may display a PIN to be entered on the device.
After the device pairs, the device is now available in the guest.

Configuring a Trusted Platform Module Device
You can add a virtual cryptoprocessor that uses Trusted Platform Module (TPM) technology to an encrypted virtual
machine. Afterward, you can remove the cryptoprocessor from the virtual machine.

TPM technology provides hardware-based, security-related functions. A TPM cryptoprocessor carries out cryptographic
operations. Fusion supports TPM version 2.0.
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Create a Virtual Trusted Platform Module Device

For increased security, you can add a virtual cryptoprocessor that is equipped with Trusted Platform Module (TPM)
technology to an encrypted virtual machine.

• Create a virtual machine with a minimum hardware version of 14 that uses the UEFI firmware type.
• Encrypt the virtual machine. See Encrypt a Virtual Machine.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Click Add Device.

4. Click Trusted Platform Module.
If the option is not available, the Trusted Platform Module device is not supported on the guest.

5. Click Add.
A dialog box appears.

6. Close the dialog box.

The virtual machine uses the virtual TPM device.

NOTE
You cannot decrypt the virtual machine when the TPM device is present.

Remove a Virtual Trusted Platform Module Device

You can remove a Trusted Platform Module device from a virtual machine.

After you add a virtual cryptoprocessor equipped with Trusted Platform Module (TPM) technology to an encrypted virtual
machine, you can then remove the TPM device.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. In the Removable Devices section, click Trusted Platform Module.

4. Click Remove Trusted Platform Module.
A dialog box appears asking if you want to remove the device.

5. Click Remove.

Fusion removes the TPM device from the virtual machine.

Select a Startup Device
You can select the device to use to start up your virtual machine.
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Verify that the virtual machine is running. The change does not take effect if the virtual machine is not running.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Under Other in the Settings window, click Startup Disk.

4. Click the startup device to use.

5. Click Restart.
You can also hold down the Option key and click Restart to firmware to restart the virtual machine in firmware setup
mode.

The guest operating system restarts and boots from the selected device.

Encrypting a Virtual Machine
Encrypt your virtual machine to control the use of the virtual machine and access to its contents.

Fusion supports the following types of encryption:
Fast VM Encryption

Fast encryption refers to the encryption of a minimal set of VM files as follows:

• Ancillary data files such as snapshot/screenshot/NVRAM files. These are encrypted with the key in the configuration file.
List of files encrypted- .nvram, .vmsn, .vmss, .vmem

• Partially encrypted VM configuration file.

Full VM Encryption
Full encryption refers to encryption of all VM files as follows:

• Disk file headers. These are encrypted with the key in the configuration file.
• Disk file data. These are encrypted with the key in the configuration file.
• Ancillary data files such as the snapshot/screenshot/NVRAM files. These are encrypted with the key in the configuration

file.
• VM configuration file is encrypted with authentication keys.

When you encrypt a virtual machine, you set a password that is required to open the virtual machine. You can remove the
encryption or change the password at any time.

NOTE
Large virtual machines, such as those that exceed 50GB, might generate a low disk space warning.

Encrypt a Virtual Machine
You can encrypt your virtual machine with a password to control access to the virtual machine and its contents.

• Suspend or shut down the virtual machine.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Under Other in the Settings window, click Encryption.

4. Choose appropriate encryption option and set the encryption password.
The password must be eight characters or longer.

IMPORTANT
Make a record of the encryption password. If you forget the encryption password, Fusion does not provide a
way to retrieve it.

 144



 VMware Fusion Pro 13

5. Optional: To store the encryption password in the Keychain password management system on your Mac, select
Remember Password.

6. Click OK.

The virtual machine is encrypted. Users must provide the encryption password to open the virtual machine.

Change the Password for an Encrypted Virtual Machine
You can change the password for an encrypted virtual machine at any time.

• Suspend or power off the virtual machine.
• Verify that you have the password for the encrypted virtual machine.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Under Other in the Settings window, click Encryption.

4. Click Change Password.

5. Type the old password for the virtual machine.

6. Type the password to use to encrypt the virtual machine.
Remember this password. You cannot access the virtual machine without it.

7. Type the password again.

8. Optional: Select Remember Password to store the password in the Keychain password management system on your
Mac.

9. Click OK.

The encryption password for the virtual machine is changed.

Remove Encryption from a Virtual Machine
You can remove encryption from a virtual machine at any time.

• Suspend or power off the virtual machine.
• Verify that you have the password for the encrypted virtual machine.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Under Other in the Settings window, click Encryption.

4. Choose Virtual machine is not encrypted.

5. Type the password for the virtual machine.

6. Click OK.

Encryption is removed from the virtual machine. You no longer not need a password to access the virtual machine and its
contents.

 145



 VMware Fusion Pro 13

Store the Password for an Encrypted Virtual Machine in Keychain
You can store the password for an encrypted virtual machine in your Mac's Keychain password management system at
any time. Mac Keychain remembers the password for you.

• Suspend or power off the virtual machine.
• Verify that you have the password for the encrypted virtual machine.

You can store the encryption password in the Keychain password management system when you first encrypt a virtual
machine. See Encrypt a Virtual Machine. You also have the opportunity to store the encryption password in the Keychain
password management system every time you are prompted for the encryption password.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Select the Remember Password check box.

4. Type the password for the virtual machine.

5. Click OK.

The password for the encrypted virtual machine is stored in Keychain.

Virtual Machine Compatibility
The compatibility of a virtual machine with different versions of Fusion and other VMware products is based on its
hardware version. The hardware version of a virtual machine is established by the version of Fusion that was used to
create the virtual machine.

Consider upgrading the hardware version of your virtual machine if you upgrade Fusion or if you want to use the virtual
machine in other VMware products.

You must power off a virtual machine before you change its hardware version.
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Change the Hardware Compatibility of a Virtual Machine
The latest virtual machine hardware version available yields the best performance and most reliable behavior from the
applications running in your virtual machine.

• Evaluate the applications running in your virtual machine to determine which hardware version to select. Some
applications might have specific hardware requirements offered through a virtual machine hardware version older than
the latest available version.

• Consider taking a snapshot of the virtual machine. If changing the hardware version of your virtual machine results in
undesirable behavior, you can revert to the snapshot taken before the hardware version upgrade.

• Shut down or power off your virtual machine before you change its hardware version.

Virtual machines with hardware version 10 or later are created with SATA hard disks or CD drives. Upgrading your virtual
machine from hardware version 9 or earlier does not change any devices in your virtual machine to SATA. If you want to
use SATA disks or drives with your virtual machine, you must manually change the disk and drive types.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Under Other in the Settings window, click Compatibility.

4. Under Advanced options, select a hardware version from the Use Hardware Version drop-down menu.

When you select a hardware compatibility setting, a list of the VMware products that are compatible with that setting
appears. For example, if you select hardware version 10, a list of VMware products that this version supports appears.
Limitations for the selected hardware version also appear.

Some hardware options might not be available for selection, for example, older hardware versions that your current
version of Fusion does not support.

5. (Optional) Click Revert to return to the hardware version that your virtual machine uses. When you revert your
hardware version, you can view the compatibility and limits of your current hardware version.

6. Click Apply to change the virtual machine hardware version.

7. Click Close.

The hardware version of the virtual machine is changed.

Power on the virtual machine.

Choose the Hardware Version for a Virtual Machine
Upgrading the hardware version of your virtual machine improves performance by increasing the memory limit, the
number of processors utilized, and the amount of disk space available to the virtual machine.

Verify that you have the latest version of VMware tools installed.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Under Other in the Settings window, click Compatibility.

4. Under Advanced options, select a hardware version from the Use Hardware Version drop-down menu.
Hardware version 12 enables higher performance of the virtual machine, including improved accelerated 3D graphics
rendering.

 147



 VMware Fusion Pro 13

Configuring Guest Isolation Options for a Virtual Machine
With the isolation option, you can restrict file operations between the virtual machine and the host system, and between
the virtual machine and other virtual machines.

To configure guest isolation options for a selected virtual machine, select Virtual Machine > Settings and select 
Isolation.

The following restrictions apply:

• VMware Tools must be installed in the guest operating system to use guest isolation features.
• You cannot configure these options for a remote virtual machine.
• If the virtual machine is running macOS as the guest operating system, you can copy and paste text between the guest

operating system and the host, but copying files is not supported.

NOTE
The drag and drop and copy and paste operations are turned on by default. You might want to turn off these
operations to prevent files from being accidentally transferred between the virtual machine and the host system.

Table 10: Isolation Options

Option Description

Enable drag and drop When this check box is deselected, the following options are restricted.
• Drag and drop files from the host system to a Linux or Windows guest operating

system.
• Drag and drop files from the guest operating system to the host system.
• Drag files from a file manager to an application that supports drag and drop,

or from applications such as zip file managers that support drag-and-drop
extraction of individual files.

To enable these operations, select the check box.
Enable copy and paste When this check box is deselected, the following operations are restricted.

• Copy and paste text and files from the host system to a Linux or Windows guest
operating system.

• Copy and paste from the guest operating system to the host system.
• Copy and paste text and files from one virtual machine to another.
To enable these operations, select the check box.

Managing Advanced Settings
You can monitor the power supply status, enable VNC access, enable Microsoft virtualization-based security, or configure
other advanced functions for your virtual machine.

Configure Time Synchronization Between Guest and Host Operating Systems
You can configure whether the clock on the guest operating system is synchronized with the clock on the host.
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Turn off other periodic time synchronization mechanisms. Most guests have clock synchronization turned on by default.

If you turn on this advanced setting for time synchronization, the VMware Tools service, which runs inside the guest
operating system, checks once every minute to determine whether the clocks on the guest and host operating systems
still match. If not, the clock on the guest operating system is synchronized to match the clock on the host.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Under Other in the Settings window, click Advanced.

4. Select the Synchronize time check box.

Show the Mac Power Supply Status in the Virtual Machine
You can set the virtual machine to display the status of your Mac power supply.

When this feature is enabled, information about the Mac power status is passed to the virtual machine. The virtual
machine can display the remaining charge on a battery and suspend or hibernate when the battery charge runs low. This
feature is not supported on Mac OS X, OS X, or macOS virtual machines.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Under Other in the Settings window, click Advanced.

4. Select the Pass power status to VM check box.

Troubleshooting Your Virtual Machine
You can decide what level of troubleshooting information to collect for your virtual machines.

The level of troubleshooting information collected can affect the performance of your virtual machine.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Under Other in the Settings window, click Advanced.

4. Select an option from the Troubleshooting menu.
Option Description
Default Fusion determines the best setting for your virtual machine.
None Fusion gathers no troubleshooting information from your virtual

machine. This setting enables your virtual machine to run as fast
as possible.

Hang/Crash Fusion gathers correctness information about hangs or crashes
in the virtual machine.

Performance Fusion gathers performance information, such as when an
operation is taking too long in the virtual machine.

From the VMware Fusion menu bar, select Help > Collect Support Information to collect troubleshooting information
that Fusion has gathered about a selected virtual machine. Fusion creates a .zip file on your desktop to contain
troubleshooting data.

You can select one of the following options under Collect Support Information:

• Quick: This is an option to collect minimal logs.
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The following items are not collected in this option:
– Full physical disk information
– Files :/etc/crontab, /etc/daily, /etc/monthly, /etc/weekly
– Full system and kernel logs
– /var/log/system.*gz, var/log/system.log.*.bz2
– /var/log/kernel.log.*.gz, /var/log/kernel.log.*.bz2
– system_profiler in xml format
– Output file from command : /tmp/system.log, log show --start $(date -v-1d +"%Y-%m-%d") --style syslog

(previously, it was 4 days)
• Full: This option collects full logs.

The following items are collected in this option:
– Existing default items
– All items that are not collected in Quick Collection

Change Hard Disk Buffering
Fusion automatically sets hard disk buffering according to what guest operating system you use, but you can change the
setting.

Hard disk buffering can increase performance of your virtual machine. Hard disk buffering can also consume more
memory on your Mac host than operating unbuffered. Fusion enables or disables hard disk buffering based on your virtual
machine's operating system.

For all Windows Vista and later guest operating systems, Fusion defaults to unbuffered I/O for Mac hosts. The same is
true for all Windows 2000, 2003, XP, and XP 64-bit guests newly created with this version of Fusion. All other guests
default to buffered I/O on Mac hosts.

If you are not familiar with the options, keep the default setting.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Under Other in the Settings window, click Advanced.

4. Select an option from the Hard disk buffering menu.
Option Description
Automatic Fusion determines your operating system and enables or

disables hard disk buffering depending on which type of
buffering provides the best performance.

Enabled The virtual machine's operating system uses buffered I/O.
Deactivated The virtual machine's operating system uses unbuffered I/O.

Set Password Requirement for Opening a Boot Camp Virtual Machine
If you have a virtual machine that powers on the Boot Camp partition, you can set whether a password is required each
time you open it.
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You must have a Boot Camp partition on your Mac, and you must have created a virtual machine to power it on.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Under Other in the Settings window, click Advanced.

4. Select the password requirement by setting Administrative privileges for Boot Camp disks.
Option Description
Never ask When you open a Boot Camp virtual machine in Fusion, you do

not need to enter a password.
Always ask Each time you open a Boot Camp virtual machine, you must

enter the password of the administrator account on the Mac.

Enable a VNC Client to Access the Virtual Machine Remotely
You can configure a virtual machine to allow any virtual network computer (VNC) client to access the virtual machine by
connecting to your Mac.

VNC software enables you to view and interact with one computer from any other computer or mobile device anywhere on
the Internet. VNC software is cross-platform, enabling remote control between different types of computers.

Table 11:  Options for VNC describes the ways in which you can set up VNC.

Table 11: Options for VNC

Option Description

Remote Desktop, Screen Sharing, or Third-party VNC server on
the Mac host

• Enables control of the entire host Mac, including Fusion and
any other applications.

• The connection to the server is made by using the host's IP
address or hostname.

VNC server provided by Fusion • Available for each virtual machine.
• Must use unique ports that are not already in use on the host

Mac.
• Enables control of the virtual machine whenever it is powered

on, even before the guest operating system is running.
• The connection to the server is made by using the host's IP

address or hostname.

VNC server inside the virtual machine's guest operating system • The VNC server is installed in the same way as any other
application inside the virtual machine.

• Enables control of only the guest operating system and is
available only after the guest operating system starts up.

• When using bridged networking, the connection to the server
is made by using the guest's IP address or hostname.
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This procedure describes how to use the VNC server provided by Fusion to enable a VNC Client to access the virtual
machine remotely.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Under Other in the Settings window, click Advanced.

4. Select the Remote display over VNC check box.

5. Optional: Type a password.
Because data sent over VNC is unencrypted, do not use your regular password.

6. Identify the port on the Mac.
The default port is 5900. If you enabled screen sharing on the Mac, port 5900 might already be in use and you must
use another port, such as 5901. For multiple virtual machines, increment the port number for each additional virtual
machine.

Your virtual machine is now visible to VNC clients.

Configure Virtual Machine Power Options
You can configure Fusion to list the soft or hard option of specific power-option pairs in the Virtual Machine drop-down
menu and the applications menus.

When you access the Virtual Machine drop-down menu or an applications menu, Fusion lists the soft or hard option of
each power-option pair, depending on which option is configured. You can configure the soft or hard option for each of the
following power-option pairs.

• Resume/Resume (hard)
The Resume and Resume (hard) options are the same unless you customize the resume script.

• Shut Down/Power Off (hard)
• Suspend/Suspend (hard)

The Suspend and Suspend (hard) options are the same unless you customize the suspend script.
• Restart/Reset (hard)

For descriptions of the power commands, including information about power-option scripts, see Options for Fusion Power
Commands.

NOTE
Also, using a keyboard shortcut, you can switch to the option in a power-option pair not currently configured. For
example, if the soft option of a power-option pair is configured, you can use a keyboard shortcut to list the hard
option instead. See Switch Power Commands from the Default Options.
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When you create a virtual machine in Fusion, the power commands default to the soft options. When you create the virtual
machine in another VMware product, the virtual machine might default to the hard power options.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Under Other in the Settings window, click Advanced.

4. Select the soft or hard option of each power-option pair.

Power-Option Pair Power Options

Resume/Resume (hard) Resume The soft option of the power-
option pair.

Resume (hard) The hard option of the power-
option pair. Also called the
Force Resume option.

Shut Down/Power Off (hard) Shut Down The soft option of the power-
option pair.

Power Off (hard) The hard option of the power-
option pair. Also called the
Force Shut Down option.

Suspend/Suspend (hard) Suspend The soft option of the power-
option pair.

Suspend (hard) The hard option of the power-
option pair. Also called the
Force Suspend option.

Restart/Reset (hard) Restart The soft option of the power-
option pair.

Reset (hard) The hard option of the power-
option pair. Also called the
Force Restart option.

The power options in the Virtual Machine drop-down menu and the applications menus change with the powers options
configured in the advances settings. For example, if you changed Shut Down to Power Off (hard) in the advanced
settings, the Virtual Machine drop-down menu lists the Power Off option, not the Shut Down option.
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Enable Verbose USB Debugging
You can configure Fusion to increase the log information about USB devices connected to a virtual machine.

When verbose USB debugging is enabled, Fusion logs more extensive information about connected USB devices. You
can then collect the troubleshooting information.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Under Other in the Settings window, click Advanced.

4. Select the Enable verbose USB debugging check box.

Fusion starts logging more extensive information about connected USB devices.

Collect the troubleshooting information. See Troubleshooting Your Virtual Machine.

To discontinue the impact that increased logging has on virtual machine performance, such as on CPU and I/O
performance, after you finish collecting troubleshooting information, unselect the Enable verbose USB debugging check
box.

Enable Dark Mode Synchronization
You can enable Dark Mode Synchronization for a virtual machine.

• This option is only available on Windows 10 virtual machine and Mac virtual machine with macOS 10.11 or newer
versions.

• VMware Tools 11.0.0 or a higher version of tools must be installed.
• This option is only available for local virtual machine and is not available for remote virtual machine (virtual machine

stored on ESXi Server or Workstation host).

If you enable Dark Mode Synchronization, the Light mode/Dark mode settings on the host system is synchronized
automatically to the guest operating system (Windows 10 virtual machine and macOS virtual machine).

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Under Other in the Settings window, click Advanced.

4. Select the Enable Dark Mode Synchronization check box.

Now, if you configure your Mac to use Light mode, the guest operating system UI will also change to Light mode and if you
configure your Mac to use Dark mode, the guest operating system UI switches to the Dark mode automatically.
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Enable Microsoft Virtualization-Based Security
You can enable Microsoft virtualization-based security (VBS) on supported Windows guest operating systems.

• Create a virtual machine that uses hardware version 14 or later and one of the following supported guest operating
systems.
– Windows 10 Enterprise, 64-bit
– Windows Server 2016

• To use Windows 2016 as the guest operating system, apply all Microsoft updates to the guest. VBS might not function
in a Windows 2016 guest without the most current updates.

VBS reinforces the security of Microsoft Hyper-V. When you enable VBS, Fusion configures the virtual machine with the
following settings.

Option Required Setting Fusion Settings Page

Firmware type UEFI Advanced Settings

Enable UEFI Secure Boot Enabled Advanced Settings

Enable hypervisor applications in this virtual
machine

Enabled Processors & Memory

Enable IOMMU in this virtual machine Enabled Processors & Memory

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Under Other in the Settings window, click Advanced.

4. Select Enable VBS.

For VBS to run in the guest operating system, you must also perform configurations in the guest. See Microsoft
documentation related to virtualization-based security.

Configure a Firmware Type
You can select the firmware type of a virtual machine.

Make sure that you power off the virtual machine beforehand.

The following firmware types are available depending on the guest operating system.

Option Description

UEFI Unified Extensible Firmware Interface (UEFI) is an interface
between the operating system and the platform firmware. UEFI
has architectural advantages over Basic Input/Output System
(BIOS) firmware.

Legacy BIOS Standard BIOS firmware.
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If you select UEFI, depending on the guest operating system, you might have the option of enabling UEFI Secure Boot.
UEFI Secure Boot secures the boot process by preventing the loading of drivers and operating system loaders that are
not signed with an acceptable digital signature.

1. Select Window > Virtual Machine Library.

2. Select a virtual machine in the Virtual Machine Library window and click Settings.

3. Under Other in the Settings window, click Advanced.

4. Select an option from the Firmware type menu.
If the firmware type is not selectable, look for an explanation and, possibly, instructions at the bottom of the dialog box.

NOTE

• Once a guest operating system is installed, changing the firmware type might cause the virtual machine
boot process to fail.

• If virtualization-based security (VBS) is enabled, the firmware type is set to UEFI and cannot be edited.

When you start the virtual machine, it boots with the selected firmware configuration.

Using vctl Command to Manage Containers and Run Kubernetes
Cluster on Intel-based Mac
You can use the vctl command-line utility in VMware Fusion to manage containers. In addition, vctl provides support for
KIND so that KIND can use vctl container as "nodes" to run local Kubernetes clusters.

The vctl is a command-line utility bundled inside the VMware Fusion application.

Related binaries/components come bundled in the Fusion application and are available in Applications/VMware
Fusion.app/Contents/Library/vkd/ folder.

The three main binaries/components of the vctl command-line utility are summarized in the following section.

bin/containerd

This is a runtime daemon that runs in the background. The containerd daemon must be started first before you can run
any container related operation. To start it, use the vctl system start command and to stop it use the vctl system
stop command.

bin/containerd-shim-crx-v2

When a new container is started, a new containerd-shim-crx-v2 process is launched and works as an adapter between
the container in CRX VM and the containerd daemon.

bin/vctl

It is a command-line utility that runs in the foreground and relays the user input to the containerd daemon.

NOTE
The vctl CLI runs every container inside a lightweight virtual machine, called CRX VM. By default, a CRX VM
is created and starts up when a container starts. It shuts down and is removed when the container stops. The
name of the CRX VM is same as the container.

Using the vctl Utility
The vctl utility is included with VMware Fusion and is ready to run in a terminal window.
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Before using vctl to run any operation on a container image or container, the container runtime must be started first. The
container runtime doesn't start automatically when VMware Fusion application launches, and does not stop automatically
when VMware Fusion application quits. You must manually run the vctl system start command to start it and run vctl
system stop command to stop it.

1. On your Mac, open a terminal window.

2. Run the vctl system info command to check the status of the container runtime.

If the command output displays Container runtime is stopped, run vctl system start command to start the
container runtime.

If the command output shows Container runtime is running, you can start using vctl to manage containers and
container images.

3. Run the vctl command to list the command-line options.

Enabling KIND to Use vctl Container as Nodes to Run Kubernetes Clusters
In Fusion 12.0, vctl utility has an enhancement to support KIND. With this enhancement, KIND can use vctl container
instead of Docker container as nodes to run local Kubernetes clusters.

By default, vctl assigns 2 GB memory for every CRX VM that hosts the vctl container node. Ensure that your Mac
machine has 2 GB free memory when running single-node cluster, 4 GB free memory when running two-node cluster. The
more nodes configured in your cluster, the more free memory is needed.

1. On your Mac, open a terminal window.

2. Run the vctl system start command to start the vctl container runtime.
This command performs the following tasks:

1. Creates a bin folder in the <user home folder>/.vctl folder.
2. Downloads kubectl, kind and crx.vmdk files, and saves them to the bin folder.
3. Creates a docker link file that points to /Applications/VMware Fusion.app/Contents/Library/vkd/

bin/vctl.

3. Run vctl kind command.
This command performs the following four tasks:

1. Creates a bin folder in the <user home folder>/.vctl folder.
2. Downloads kubectl, kind and crx.vmdk files, and saves them to the bin folder.
3. Creates a docker link file that points to /Applications/VMware Fusion.app/Contents/Library/vkd/

bin/vctl.
4. Creates a vctl-based KIND context by adding <user home folder>/.vctl/bin to the PATH environment

variable and makes it the first searchable path.
So in the Terminal window, the kubectl/kind/docker CLI tools in the <user home folder>/.vctl/bin folder
will take precedence over other existing versions of these tools that might be installed else where.
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4. The vctl-based KIND context will be lost if you close the Terminal window.

Next time you want to interact with the Kubernetes clusters, run the vctl kind command.

NOTE

• vctl does not support kind build command.
• By default, vctl assigns 2 GB memory and 2 CPU cores for the CRX VM that hosts the node container,

you can use the --k8s-cpus and --k8s-mem options of vctl system config command to customize the
configurations.

• Each Fusion version supports only a specific version of kind CLI and kubectl CLI tools. For example:
– Fusion 12.0.0 supports kind v0.8.1 and kubectl v1.18.6.
– Fusion 12.1.0 supports kind v0.9.0 and kubectl v1.19.1
The vctl utility in Fusion 12.1.0 introduces a version check for the kind and the kubectl CLI tools. When
you run vctl system start or vctl kind command, if the kind and the kubectl CLI tools already
exist in <user home folder>/.vctl/bin folder and their versions are supported by current Fusion
version, the vctl command will not download the tools again. If their versions are not supported by current
Fusion version, the vctl command will download the supported versions of the tools and remove the
unsupported ones.

Running vctl Commands
The vctl commands have syntax and other requirements that you must follow.

Syntax of vctl Commands
The vctl commands are divided into function categories.

The following tables list vctl commands and their function. Options enclosed in square brackets are optional. The vertical
bar indicates a keyword choice.

NOTE
Use --help to review all the available command options.

vctl Commands to Manage the Container Runtime Resource

Command Description

vctl system config [OPTIONS] Configures and initializes the host OS environment for the
container engine.
The command performs the following tasks:

• Creates a <Home_Folder_of_Your_Account>/.vct
l folder if it doesn't exist.

• Updates the config.yaml file in the .vctl folder with the
customized configurations specified by the command options.

• Prepares the storage according to the configuration in confi
g.yaml file and mounts the storage.

• Checks the availability of the VMware Fusion application.

NOTE
The vctl system config command doesn't start
containerd daemon.

vctl system info [OPTIONS] Displays the container runtime information.
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Command Description

vctl system start [OPTIONS] Starts the container engine.
The command performs the following tasks:
• Creates a <Home_Folder_of_Your_Account>/.vct

l folder if it doesn't exist.
• Updates the config.yaml file in the .vctl folder with the

customized configurations specified by the command options.
• Prepares the storage according to the configuration in confi

g.yaml file and mounts the storage.
• Checks the availability of the VMware Fusion application
• Starts the containerd daemon.

vctl system stop [OPTIONS] Stops the container runtime.

vctl Commands to Manage the Image Resource

Command Description

vctl build [OPTIONS] PATH Builds a container image using a Dockerfile.
NOTE
If the RUN instructions in the Dockerfile run network-
related commands, add ENV instruction into the
Dockerfile to set network proxy, for example: ENV
https_proxy <Proxy_Server>:Proxy_Port for the
network operations to succeed.

vctl images [OPTIONS] [IMAGE...] Lists container images and displays basic information about the
container images.

vctl push [OPTIONS] IMAGE [REMOTE_URL] Pushes the container image to the registry.

vctl rmi [OPTIONS] ([IMAGE...]|--all) Deletes one or more container images.

vctl tag [OPTIONS] SOURCE_IMAGE TARGET_IMAGE
[TARGET_IMAGE...]

Tags container images. It creates an image alias with the TARGET
_IMAGE.

vctl pull [OPTIONS] IMAGE Pulls a container image from the registry.
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vctl Commands to Manage the Container Resource

Command Description

vctl create [OPTIONS] IMAGE [COMMAND] [ARGUMENTS...] Creates a new container from a container image.
NOTE
Ensure the following when you use the --volume
option:

• Specify paths to the folder. The --volume doesn't
support path to files.

• Use absolute path. Relative paths are not
supported.

• Only anonymous volumes can be mounted,
mounting named volumes is not supported.

NOTE
Ensure the following when you use the --publish
option:

• The vctl utility doesn't have a subnet or a link
feature to connect multiple containers to a subnet.
To enable communication between multiple
containers, start the container with the --publish
option. This binds the container port to the host
port so that the service provided by the container is
accessible from the outside.

vctl describe [OPTIONS] CONTAINER Displays details about the container.

vctl exec [OPTIONS] CONTAINER COMMAND [ARGUMENTS...] Runs a command inside a running container.

vctl ps [OPTIONS][CONTAINER...] Lists the containers and displays basic information about the
container.

vctl rm [OPTIONS] ([CONTAINER...]|--all) Deletes one or more containers.

vctl run [OPTIONS] IMAGE [COMMAND] [ARGUMENTS...] Runs a new container from a container image.
NOTE
Ensure the following when you use the --volume
option:

• Specify paths to the folder. The --volume doesn't
support path to files.

• Use absolute path. Relative paths are not
supported.

• Only anonymous volumes can be mounted,
mounting named volumes is not supported.

NOTE
Ensure the following when you use the --publish
option:

• The vctl utility doesn't have a subnet or a link
feature to connect multiple containers to a subnet.
To enable communication between multiple
containers, start the container with the --publish
option. This binds the container port to the host
port so that the service provided by the container is
accessible from the outside.

vctl start [OPTIONS] CONTAINER Starts a created or stopped container.

vctl stop [OPTIONS] CONTAINER Stops the container.
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Command Description

vctl inspect [OPTIONS] NAME Displays detailed container information.

vctl Commands to Manage the CRX VM Resource

Command Description

vctl execvm [OPTIONS] (vmx|-c=CONTAINER) COMMAND
[ARGUMENTS...]

Runs commands from inside a running virtual machine that hosts
the container.

vctl Commands to Manage Volumes

Command Description

vctl volume prune [flags] Removes all unused local volumes.

vctl Commands to Manage Container Images Registry Authentication

Command Description

vctl login [OPTION] [SERVER] Logs in to a remote registry.

vctl logout [SERVER] Logs out from a remote registry.

NOTE

• On macOS, the credentials are saved in the Keychain. On Windows, the credentials are saved in the
Credential Manager.

• Once the login is successful, future Pull, Push and Build requests will leverage the saved credential.
• Logout request deletes the corresponding credential from the Keychain or the Credential Manager.

vctl Commands to Get System Environment Ready for vctl-Based KIND

Command Description

vctl kind Prepares the system environment for vctl-based KIND. KIND uses
vctl containers as nodes for running Kubernetes clusters.

Examples of vctl Commands
The command-line examples that follow work on VMware Fusion.

Commands Related to Image

• When you build a new image, to pull the base image from a private Docker registry successfully, either use the vctl
login command to log in to the private Docker registry first or use the --credential option to pass a JSON file that
stores credentials to vctl build command for registry authentication. For example:

1. Encode your Docker registry username and password in base64 with the following command:
echo -n USER:PASSWORD | base64
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2. Create a config.json file with your Docker registry URL and the base64 encoded string generated in step 1.
{

                           "auths": {

                                          "https://index.docker.io/v2/": {

                                                         "auth": "xxxxxxxxxxxxxxx"

                                         }

                            }

}

3. Build the new image whose base image is in a private Docker registry, by passing the JSON file to vctl build
command:
vctl build --file Dockerfile --tag docker.io/mynamespace/myrepo:1.0 --credential config.json .

Commands Related to Container

• List running containers.
vctl ps

• List all containers, including the running containers and stopped containers.
vctl ps --all

• Run a container in detached mode using the nginx image, which is the same as docker.io/library/nginx:latest.
vctl run --name myContainer -d nginx

• Run a container using the --publish option and the fluentd image, here fluentd is equivalent to docker.io/
library/fluentd:latest.
vctl run --name myContainer --publish 24224:24224/udp --publish 24224:24224 fluentd

• Run multiple containers and enable discovery and communication with each other.
– The vctl utility doesn't have a subnet or a link feature to connect multiple containers to a subnet.

To enable communication between multiple containers, start the container with the --publish option. This binds the
container port to the host port so that the service provided by the container is accessible from the outside.

vctl run --name mydb -m 2048 -e MYSQL_ROOT_PASSWORD=password -p 3306:3306 mysql

vctl run --name mymatomo -m 4096 -p 8080:80 -e MATOMO_DATABASE_HOST=<Host_IP>:3306 matomo

• Run a container using the --volume option and the bonita image, here bonita is equivalent to docker.io/library/
bonita:latest.
vctl run --name myContainer -p 8080:8080 --volume ~/Documents/container:/opt/bonita bonita

Commands Related to CRX VM

• Get shell access to a CRX VM.
– By specifying the container hosted by the CRX VM.

vctl execvm --sh -c myContainer

– By specifying the vmx path of the CRX VM.
NOTE
To get the vmx path, run the vctl describe myContainer command and refer to the Host virtual
machine value in the output.

vctl execvm --sh <Home_Folder_of_Your_Account>/.vctl/.r/vms/myContainer/myContainer.vmx

• Execute a command within a CRX VM.
– By specifying the container hosted by the CRX VM.

vctl execvm -c myContainer /bin/ls

– By specifying the vmx path of the CRX VM.
NOTE
To get the vmx path, run the vctl describe myContainer command and refer to the Host virtual
machine value in the output.
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vctl execvm <Home_Folder_of_Your_Account>/.vctl/.r/vms/myContainer/myContainer.vmx /bin/ls

Cleaning Up Residual Environment Data
By default, the vctl utility stores all its data in the .vctl folder under the home folder of your user account.

Perform the following to clean up the environment data:

1. Run the vctl system stop -f command to stop all running containers and stop container runtime.

2. Run the vctl system info command to check if container runtime has stopped.

3. Remove the <Home_Folder_of_Your_Account>/.vctl  folder.

Changes/Enhancements to the vctl Utility
Fusion 12.1.0

• Upgraded kind CLI tool from v0.8.1 to v0.9.0.
• Upgraded kubectl CLI from v1.18.6 to v1.19.1.
• Changed the storage of anonymous volume data from host to crx.vmdk.
• Added support for kind export logs command.
• Added minikube driver docker-machine-driver-vmware.

Fusion 12.0

• The administrator password is no longer needed to start the vctl container runtime and while using the --publish
option.

• Added enhancement to support KIND, so that KIND can use vctl container as nodes to run local Kubernetes clusters.
• Added vctl login and vctl logout commands.
• Added vctl inspect command to display detailed container information.
• Added support to specify access permission (ro, rw) of the mounted volume
• Added vctl volume prune command.

Using the vmrun Command to Control Virtual Machines
You can use the vmrun command-line utility in VMware FusionWorkstation Pro Workstation Player to control
virtual machines and automate guest operations on VMware virtual machines. The vmrun utility is associated with the VIX
API libraries.

The capabilities of the vmrun utility are summarized in the following sections.

Power Commands

Power commands control virtual machine operations. You can use power commands to start (power on), stop (power off),
reset (reboot), suspend, pause, and unpause a virtual machine.

Snapshot Commands

A snapshot captures the state of a virtual machine at the time of the snapshot, including all data on virtual disks. You
can then use the snapshot to revert the virtual machine to its previous state. Snapshots are useful for data backup and
as a placeholder for development and testing. You can use snapshot commands to list existing snapshots of a virtual
machine, create a snapshot, delete a snapshot, and revert a virtual machine to its state at the time of a snapshot. Revert
to snapshot does not resume running a virtual machine, even if it was running at the time of a snapshot.
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Network Adapter Commands

Network adapter commands allow you to control the virtual network adapters associated with a virtual machine. You can
use network adapter commands to list, add, update, and remove a network adapter.

Host Network Commands

Host network commands allow you to list the host virtual networks and to list, update, or remove a port forwarding
configuration.

Guest Operating System Commands

Guest operating system commands enable you to interact with a guest operating system in the following ways.

• Run an executable program in the guest operating system or run an interpreted script that you provide.
• Check if a file or directory exists in the guest, delete a file or directory, rename a file, list files, or create a new directory.
• Copy a file from the host to the guest or from the guest to the host.
• Create a temporary file in the guest operating system.
• Add a shared folder from the host, make a shared folder writable in the guest, or remove a shared folder.
• Capture a screen image from the guest.
• List the processes running in the guest operating system or end a process.
• Read or write a variable in the guest operating system’s environment or virtual machine state.
• Obtain the IP address of the guest operating system.

The timeout, which is the wait period for VMware Tools, is five minutes for all guest‐related commands.

General Commands

General commands include commands that list all running virtual machines, upgrade the virtual machine hardware
version, install VMware Tools in the guest operating system, check the current status of VMware Tools, and delete virtual
machines. Also, you can clone a virtual machine to create a copy of the virtual machine.

Template Virtual Machine Command

The name of the template virtual machine command is downloadPhotonVM. The command allows you to download the
VMware Project Photon operating system virtual machine.

Use the vmrun Utility
No configuration is needed to use the vmrun utility on a Mac OS X, OS X, or macOS host.

The vmrun utility is included with Fusion and ready to run in a terminal window.

1. On your Mac, open a terminal window.

2. Run the vmrun command to list the command-line options.

Syntax of the vmrun Command
The vmrun command syntax can contain authentication flags, commands, and parameters.

The following syntax applies to the vmrun command.

vmrun [AUTHENTICATION-FLAGS] COMMAND [PARAMETERS]

Using Authentication Flags in vmrun Commands
You can use authentication flags in vmrun commands to provide information required to access a system.
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For example, you can use an authentication flag to specify the local host type because vmrun commands apply to both
VMware Workstation and VMware Fusion host types. You can also use authentication flags to provide the credentials
required to access encrypted virtual machines or a guest operating system.

Authentication flags must appear before the command and command parameters.

The vmrun command supports the following authentication flags.

-T hostType

-vp encryptedVirtualMachinePassword

-gu guestUser

-gp guestPassword

Product Type

The -T flag is optional. When you run vmrun commands with Fusion, fusion is the default. Use the -T flag for Fusion as
follows.

vmrun -T fusion

Encrypted Virtual Machines

Encrypted virtual machines require a password for most operations.

-vp encryptedVirtualMachinePassword

Guest Operations

Guest operations require authentication by the guest operating system.

Use the following flags to specify the user name and password of the user in the guest operating system.

-gu guestUser

-gp guestPassword

Running vmrun Commands
The vmrun commands have syntax and other requirements that you must follow.

Path to VMX File
VMware stores virtual machines as a package that includes the virtual machine settings file, filename.vmx, and the
virtual disks.

When required, you must provide the path to the .vmx file. The examples that follow are of default paths to Windows and
Linux virtual machine for Mac OS X, OS X, or macOS.

Unless you specify a file location for a virtual machine when you create it, Fusion saves the virtual machine package to a
default location, which can vary. See Default File Location of a Virtual Machine.

Examples of the vmrun command include the relative path to the .vmx file instead of the absolute paths that follow.

• your home directory/Virtual\ Machines.localized/Win10.vmwarevm/Win10.vmx
• your home directory/Virtual\ Machines.localized/Ubuntu16.vmwarevm/Ubuntu16.vmx
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IMPORTANT
For vmrun commands that require VMware Tools, install the latest VMware Tools package and, especially after
operating system updates, keep VMware Tools up‐to‐date.

Deactivate Dialog Boxes
To prevent the vmrun utility from failing when you provide user input through a dialog box, you can deactivate dialog
boxes.

The vmrun utility might time out and fail when you use the utility on a virtual machine that requires user input through a
dialog box.

To deactivate dialog boxes, insert the following line in the virtual machine configuration file, the .vmx file.

msg.autoAnswer = TRUE

Syntax of vmrun Commands
The vmrun commands are divided into function categories.

The following tables list vmrun commands and parameters for Fusion according to their function. Parameters are listed
one per line. Parameters enclosed in square brackets are optional. The vertical bar indicates a keyword choice.

The vmrun Power Commands and Parameters

Option Parameters Description

start path to .vmx file
[ gui | nogui ]

Starts a virtual machine. The default gui
option starts the machine interactively,
which is required to display the Fusion
interface. The nogui option suppresses
the Fusion interface, including the startup
dialog box, to allow noninteractive scripting.

NOTE
To start encrypted virtual
machines, use the nogui
flag. The vmrun utility does
not support GUI mode with
encrypted virtual machines.

stop path to .vmx file
[ hard | soft ]

Stops a virtual machine. Use the soft
option to power off the guest after running
shutdown scripts. Use the hard option to
power off the guest without running scripts,
as if you pressed the power button. The
default is to use the powerType value
specified in the .vmx file, if present.

reset path to .vmx file
[ hard | soft ]

Resets a virtual machine. Use the soft
option to run shutdown scripts before
rebooting the guest. Use the hard option to
reboot the guest without running scripts, as
if you pressed the reset button. The default
is to use the powerType value specified in
the .vmx file, if present.
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Option Parameters Description

suspend path to .vmx file
[ hard | soft ]

Suspends a virtual machine without
shutting down the virtual machine, so
local work can resume later. The soft
option suspends the guest after running
system scripts. On Windows guests, these
scripts release the IP address. On Linux
guests, the scripts suspend networking.
The hard option suspends the guest without
running the scripts. The default is to use the
powerType value specified in the .vmx file,
if present.
To resume virtual machine operations after
the suspend command finishes, use the
start command. On Windows, the IP
address is retrieved. On Linux, networking
is restarted.

pause path to .vmx file Pauses a virtual machine.

unpause path to .vmx file Resumes operations of a virtual machine
from where you paused normal operations.

The vmrun Snapshot Commands and Parameters

Option Parameters Description

listSnapshots path to .vmx file
[ showtree ]

Lists all snapshots in a virtual machine. The
showtree option displays snapshots in tree
format, with children indented under their
parent.

snapshot path to .vmx file
snapshot name

Creates a snapshot of a virtual machine.
Because Fusion supports multiple
snapshots, you must provide the snapshot
name.
Because the forward slash defines path
names, do not use the slash character in a
snapshot name. Otherwise, specifying the
snapshot path later becomes difficult.

deleteSnapshot path to .vmx file
snapshot name
[ andDeleteChildren ]

Removes a snapshot from a virtual
machine. Because Fusion supports multiple
snapshots, you must provide the snapshot
name. The virtual machine must be
powered off or suspended. If the snapshot
has children, they become children of the
deleted snapshot's parent, and subsequent
snapshots continue as before from the end
of the chain.
The andDeleteChildren option deletes
the specified snapshot and its children
recursively.
See revertToSnapshot for solutions to
name conflicts.
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Option Parameters Description

revertToSnapshot path to .vmx file
snapshot name
or
path to .vmx file
Snapshot/"Snapshot
2"/"Snapshot N"

Sets the virtual machine to its state at
snapshot time. However if the virtual
machine was powered on at the time of the
snapshot, vmrun reverts it to a suspended
state, but does not resume running the
virtual machine.
If a snapshot has a unique name within a
virtual machine, revert to that snapshot by
specifying the path to the virtual machine's
configuration file and the unique snapshot
name.
If several snapshots have the same name,
specify the snapshot by including a full
pathname for the snapshot. A pathname
is a series of snapshot names, separated
by forward slash characters (/). Each name
specifies a new snapshot in the tree. For
example, the pathname Snap1/Snap2
identifies a snapshot named Snap2 that
was taken from the state of a snapshot
named Snap1.

The vmrun Network Adapter Commands and Parameters

Only Fusion Pro supports the network adapter commands.

Option Parameters Description

listNetworkAdapters path to .vmx file Lists the network adapters in a virtual
machine.

addNetworkAdapter path to .vmx file
Network adapter type
[ Host nework ]

Adds a network adapter to a virtual
machine.

NOTE
The network adapter type can
be nat, hostOnly, bridged, or
custom. When the network
adapter is nat, hostOnly, or
bridged, the Host nework
parameter is not required.
Only when the network
adapter type is custom, must
you specify a value for the
Host nework parameter.
For example, vmrun
addNetworkAdapter
.vmx file custom
vmnet3 .

Note: You must name a custom
virtual network with one of the
names listed in the Custom
section of the Network settings
panel of the virtual machine or
the Fusion Network Preferences
panel.

.
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Option Parameters Description

setNetworkAdapter path to .vmx file
Network adapter index
Network adapter type
[ Host nework ]

Updates a network adapter in a virtual
machine.

NOTE
The network adapter type can
be nat, hostOnly, bridged, or
custom. When the network
adapter is nat, hostOnly, or
bridged, the Host nework
parameter is not required.
Only when the network
adapter type is custom, must
you specify a value for the
Host nework parameter.
For example, vmrun
addNetworkAdapter
.vmx file custom
vmnet3 .

Note: You must name a custom
virtual network with one of the
names listed in the Custom
section of the Network settings
panel of the virtual machine or
the Fusion Network Preferences
panel.

deleteNetworkAdapter path to .vmx file
Network adapter index

Removes a network adapter from a virtual
machine.

The vmrun Host Network Commands and Parameters

Only Fusion Pro supports the host network commands.

Option Parameters Description

listHostNetworks Lists all networks on the host.

listPortForwardings host network name Lists all available port forwardings on a host
network.

setPortForwarding host network name
protocol
host port
guest ip
guest port
[Description]

Sets a port forwarding on a host network.
NOTE
To prevent the command from
returning an error, use the
sudo utility with this option. For
example, sudo vmrun setP
ortForwarding .

deletePortForwarding host network name
protocol
host port

Deletes a port forwarding on a host
network.

NOTE
To prevent the command from
returning an error, use the
sudo utility with this option. For
example, sudo vmrun dele
tePortForwarding .
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The vmrun Guest Operating System Commands and Parameters

The timeout, which is the wait for VMware Tools, is five minutes for all guest‐related commands.

Option Parameters Description

runProgramInGuest path to .vmx file
[ -noWait | -activeWindow | -
interactive ]
program name
[ program arguments ]

Runs a specified program in the guest
operating system. The -noWait option
returns a prompt immediately after the
program starts in the guest, rather than
waiting for it to finish. This option is
useful for interactive programs. The -
activeWindow  option ensures that the
Windows GUI is visible, not minimized.
It has no effect on Linux. The -interacti
ve option forces interactive guest login.
The option is useful for Windows Vista
and Windows 7 or later guests to make
the program visible in the console window.
You must provide the full pathname of
a program accessible to the guest. Also
provide fully accessible path names for any
files specified in the program arguments,
according to the requirements of the
program. VMware Tools and a valid guest
login are required.

fileExistsInGuest path to .vmx file Checks whether the specified file exists in
the guest operating system. VMware Tools
and a valid guest login are required.

directoryExistsInGuest path to .vmx file
directory path on guest

Checks whether the specified directory
exists in the guest operating system.
VMware Tools and a valid guest login are
required.

setSharedFolderState path to .vmx file
share name
path to folder on host
writable | readonly

Modifies the writability state of a specified
folder shared between the host and a guest
virtual machine. The value for the share
name parameter is a mount point in the
guest file system. The value for the path
to folder on host parameter is the
exported directory on the host. To make a
shared folder writable or read-only, include
the writable or readonly parameter.

addSharedFolder path to .vmx file
share name
path to folder on host

Adds a folder to be shared between the
host and guest. The virtual machine must
be running for the addSharedFolder option
to take effect. The value for the share
name parameter is a mount point in the
guest file system. The value for the path
to folder on host parameter is the
exported directory on the host. On Windows
guests, a delay might occur before shared
folders are visible to the runProgramInGues
t, fileExistsInGuest, and directoryExistsInG
uest options.
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Option Parameters Description

removeSharedFolder path to .vmx file
share name

Removes the guest virtual machine’s
access to a shared folder on the host. The
virtual machine must be running for the rem
oveSharedFolder option to take effect. The
value for the share name parameter is a
mount point in the guest file system.

enableSharedFolders path to .vmx file
[runtime]

Allows the guest virtual machine, specified
by the .vmx file, to share folders with its
host. After enabling, run the addSharedF
older option to specify each host folder to
share. The optional [runtime] argument
limits the sharing of folders until the virtual
machine is powered off. Otherwise, the
setting persists at the next power-on.

NOTE
The enableSharedFolders
option takes effect after the
shut-down and restart of the
guest. No error message
appears.

disableSharedFolders path to .vmx file
[runtime]

Prevents the guest virtual machine,
specified by the .vmx file, from sharing
folders with its host. The optional
[runtime] argument limits the stop
applied to the sharing of folders until the
virtual machine is powered off. Otherwise,
the setting persists at next power on.

NOTE
The disableSharedFolders
option takes effect after the
shut-down and restart of the
guest. No error message
appears.

listProcessesInGuest path to .vmx file Lists all processes running in the guest
operating system. VMware Tools and a
valid guest login are required. For example,
you can use the -gu and -gp options to log
in to the guest.

killProcessInGuest path to .vmx file
process ID

Stops a specified process in the guest
operating system. VMware Tools and a
valid guest login are required. For example,
you can use the -gu and -gp options to log
in to the guest. The process ID can be any
number listed after pid= in the output of the
listProcessesInGuest option.

 171



 VMware Fusion Pro 13

Option Parameters Description

runScriptInGuest path to .vmx file
[ -noWait | -activeWindow | -
interactive ]
interpreter path
script text

Runs the specified command script in the
guest operating system. See the runPr
ogramInGuest entry for an explanation
of options. The interpreter path
option runs the script. Provide the complete
text of the script, not a filename. VMware
Tools and a valid guest login are required.
For example, you can use the -gu and -gp
options to log in to the guest.

deleteFileInGuest path to .vmx file
path to file on guest

Deletes the given file from the guest
operating system. VMware Tools and a
valid guest login are required. For example,
you can use the -gu and -gp options to log
in to the guest.

createDirectoryInGuest path to .vmx file
directory path on guest

Creates the specified directory in the guest
operating system. VMware Tools and a
valid guest login are required. For example,
you can use the -gu and -gp options to log
in to the guest.

deleteDirectoryInGuest path to .vmx file
directory path on guest

Deletes the specified directory from the
guest operating system. VMware Tools
and a valid guest login are required. For
example, you can use the -gu and -gp
options to log in to the guest

createTempfileInGuest path to .vmx file Creates a temporary file in the guest
operating system, and returns the path
name of the temporary file created.
The path name varies according to the
operating system. You can run the deleteFil
eInGuest option to remove the file. VMware
Tools and a valid guest login are required.
For example, you can use the -gu and -gp
options to log in to the guest.

listDirectoryInGuest path to .vmx file
directory path on guest

Lists contents of the specified directory
in the guest operating system. VMware
Tools and a valid guest login are required.
For example, you can use the -gu and -gp
options to log in to the guest.

CopyFileFromHostToGuest path to .vmx file
file path on host
file path in guest

Copies a file from the host to the guest
operating system. VMware Tools and a
valid guest login are required. For example,
you can use the -gu and -gp options to log
in to the guest. Specify the source filename,
or host filename, before the destination
filename, or guest filename.

CopyFileFromGuestToHost path to .vmx file
file path in guest
file path on host

Copies a file from the guest operating
system to the host. VMware Tools and a
valid guest login are required. For example,
you can use the -gu and -gp options to log
in to the guest. Specify the source filename,
or guest filename, before the destination
filename, or host filename.
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Option Parameters Description

renameFileInGuest path to .vmx file
original filename
new filename

Renames or moves a file in the guest
operating system. VMware Tools and a
valid guest login are required. For example,
you can use the -gu and -gp options to log
in to the guest. Specify the source filename,
or original filename, before the destination
filename.

connectNamedDevice path to .vmx file
device name

Connects the device named in the
command to the guest operating system.
You can only run this command when the
virtual machine is powered on. You can
use device names, such as sound, serial0,
Ethernet0, sata0:1, etc.

NOTE
After you use the
vmrunconnectNamedDevice
command to connect a
disconnected sound device
to a running virtual machine,
powering off the virtual machine
might disconnect the sound
device from the virtual machine,
even though the virtual machine
settings list the sound device as
connected.

disconnectNamedDevice path to .vmx file
device name

Disconnects the device named in the
command from the guest operating system.
You can only run this command when the
virtual machine is powered on. You can
use device names, such as sound, serial0,
Ethernet0, sata0:1, etc.

NOTE
After you use the vmrundi
sconnectNamedDevic
e command to disconnect a
connected sound device from
a running virtual machine,
powering off the virtual machine
might reconnect the sound
device to the virtual machine,
even though the virtual machine
settings list the sound device as
disconnected.

captureScreen path to .vmx file
output path on host

Captures the screen of the virtual machine
to a local file. The specified output file on
the host is in PNG format. A valid guest
login is required. For example, you can
use the -gu and -gp options to log in to the
guest.
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Option Parameters Description

writeVariable path to .vmx file
[ guestVar | runtimeConfig |
guestEnv ]
variable name
variable value

Writes a variable to the virtual machine
state or guest. You can set a non‐persistent
guest variable, guestVar, a runtime
configuration variable,runtimeConfig, as
stored in the .vmx file, or an environment
variable, guestEnv, in the guest operating
system. A guest variable is a runtime‐only
value that provides a simple way to pass
runtime values in and out of the guest.
Environment variables require VMware
Tools and a valid guest login. For example,
you can use the -gu and -gp options to log
in to the guest. With Linux, setting the guest
environment also requires root login.

readVariable path to .vmx file
[ guestVar | runtimeConfig |
guestEnv ]
variable name

Reads a variable from the virtual machine
state or guest. You can get a guest
variable, a runtime configuration as stored
in the .vmx file, or environment variables
in the guest operating system. Reading the
guestEnv variable requires a valid guest
login. For example, you can use the -gu
and -gp options to log in to the guest. See
the writeVariable entry for a description of
variable types.

getGuestIPAddress path to .vmx file
[ -wait ]

Retrieves the IP address of the guest.
When you use the [ -wait ] option, the
command waits until the IP address is
available. For example, the IP address
is not available until the virtual machine
powers on. If the network is not ready, the
command returns to the command-line
prompt immediately.

The vmrun General Commands and Parameters

Option Parameters Description

list Lists all running virtual machines.

upgradevm path to .vmx file Upgrades a virtual machine to the current
virtual hardware version. Has no effect if
the virtual hardware version is the most
recent supported.
Power off the virtual machine, such as with
the vmrun stop command. Wait a short
period of time for the command to finish.
Then run the  vmrun upgradevm
command.
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Option Parameters Description

installTools path to .vmx file Prepares to install VMware Tools in the
guest operating system. In Windows guests
with autorun enabled, the VMware Tools
installer starts by itself. In Linux guests
without autorun, the command connects the
virtual CD‐ROM drive to the VMware Tools
ISO image suitable for the guest, but the
installer does not start.
You must complete the installation with
additional manual steps, as described in the
product documentation.

checkToolsState path to .vmx file Checks the status of VMware Tools in the
guest. The possible states are unknown,
installed, and running.

deleteVM path to .vmx file Deletes a virtual machine.

clone path to .vmx file
destination .vmx file path
full|linked
[-snapshot=Snapshot Name]
[-cloneName=Name]

Only Fusion Pro supports the clone option.
Creates a copy of the virtual machine.

The vmrun Template Virtual Machine Commands and Parameters

Option Parameters Description

downloadPhotonVM path to save the downloaded
VM

Downloads a VMware Project Photon
operating system virtual machine.

Examples of vmrun Commands
The command-line examples that follow work on VMware Fusion. Ubuntu16 is the virtual machine example for Linux and
Win10 is the virtual machine example for Windows.

Reboot Commands

• Reboot a virtual machine.
vmrun reset Win10.vmwarevm/Win10.vmx soft

Snapshot Commands

• Create a snapshot of a virtual machine
vmrun snapshot Ubuntu16.vmwarevm/Ubuntu16.vmx mySnapshot

• List snapshots on the virtual machine, showing the snapshot created in the previous command.
vmrun listSnapshots Ubuntu16.vmwarevm/Ubuntu16.vmx

• Revert to the snapshot you made, which suspends the virtual machine, and restart to resume operation.
vmrun revertToSnapshot Ubuntu16.vmwarevm/Ubuntu16.vmx mySnapshot
vmrun start Ubuntu16.vmwarevm/Ubuntu16.vmx

• Delete the snapshot by specifying its name.
vmrun deleteSnapshot Ubuntu16.vmwarevm/Ubuntu16.vmx mySnapshot
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Network Adapter Commands

• List all network adapters on a virtual machine.
vmrun listNetworkAdapters Win10.vmwarevm/Win10.vmx

• Add a NAT network adapter to a virtual machine.
vmrun addNetworkAdapter Win10.vmwarevm/Win10.vmx nat

Host Network Commands

• List all networks on the host.
vmrun listHostNetworks

• Add a port forwarding on a host network with examples provided of the host network name, protocol, host port, guest
IP address, guest port, and description.
sudo vmrun setPortForwarding vmnet2 tcp 8082 1.1.1.2 88 portforwarding-description

Running Guest Applications

Most vmrun guest operations require VMware Tools to be installed on the guest operating system.

• Start the command tool, minimized, on a Windows guest.
vmrun -gu guestUser -gp guestPassword runProgramInGuest Win10.vmwarevm/Win10.vmx -
interactive cmd.exe

• Start the command tool on a Windows guest as an active window on the desktop.
vmrun -gu guestUser -gp guestPassword runProgramInGuest Win10.vmwarevm/Win10.vmx -
activeWindow -interactive cmd.exe

• Run a script on a Windows guest, with Perl as the script interpreter. Two separate examples follow.
vmrun -gu guestUser -gp guestPassword runScriptInGuest Win10.vmwarevm/Win10.vmx -
interactive "C:\perl\bin\perl.exe" "system('notepad.exe');"
vmrun -gu guestUser -gp guestPassword runScriptInGuest Win10.vmwarevm/Win10.vmx -
interactive "" "C:\perl\perl.exe C:\script.pl"

• Run a batch script and keep running afterwards. To use cmd.exe on Windows, you must specify the script interpreter
as null.
vmrun -gu guestUser -gp guestPassword runScriptInGuest Win10.vmwarevm/Win10.vmx ""
"cmd.exe /k \"C:\\Program Files\\Microsoft Visual Studio\\VC\\vcvarsall.bat\" x86"

• Run a Bash shell script file or Perl script on a Linux guest.
vmrun -gu guestUser -gp guestPassword runScriptInGuest Ubuntu16.vmwarevm/Ubuntu16.vmx -
interactive "" "/bin/bash myscript"
vmrun -gu guestUser -gp guestPassword runScriptInGuest Ubuntu16.vmwarevm/Ubuntu16.vmx -
interactive "/usr/bin/perl" "system('firefox');"

• Start an X clock on a Linux guest, which requires the -display option to appear on the console.
vmrun -gu guestUser -gp guestPassword runProgramInGuest Ubuntu16.vmwarevm/
Ubuntu16.vmx /usr/bin/xclock -display :0

• Run the same X clock command, but return control back to the console immediately.
vmrun -gu guestUser -gp guestPassword runProgramInGuest Ubuntu16.vmwarevm/Ubuntu16.vmx
-noWait /usr/bin/xclock -display :0

• Run Firefox.
vmrun -gu guestUser -gp guestPassword runProgramInGuest Ubuntu16.vmwarevm/
Ubuntu16.vmx /usr/bin/firefox --display=:0
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• Setting the guest environment with the guestEnv parameter requires root permission on Linux because the change
affects subsequent commands issued by other users.
vmrun -gu guestUser -gp guestPassword writeVariable Ubuntu16.vmwarevm/Ubuntu16.vmx
guestEnv SRC tmp.example.com:1666

• List processes in a Linux guest and end the process numbered 8192.
vmrun -gu guestUser -gp guestPassword listProcessesInGuest Ubuntu16.vmwarevm/
Ubuntu16.vmx
vmrun -gu guestUser -gp guestPassword killProcessInGuest UUbuntu16.vmwarevm/
Ubuntu16.vmx 8192

• Run a Perl script on a Linux guest to remove DOS-style carriage returns from a file.
vmrun -gu guestUser -gp guestPassword runProgramInGuest Ubuntu16.vmwarevm/
Ubuntu16.vmx /usr/bin/perl -e "open(FILE, '>/tmp/unix.txt'); while (<>) { s/\r\n/\n/ ;
print FILE}" /tmp/dos.txt

• Run a Perl script on a Windows guest to insert DOS-style carriage returns in a file.
vmrun -gu guestUser -gp guestPassword runProgramInGuest Win10.vmwarevm/Win10.vmx C:
\cygwin\bin\perl.exe -e "open(FILE, ‘>C:\Users\user\dos.txt’); while (<>) { s/\n/\r
\n/ ; print FILE}" C:\Users\guestUser\unix.txt

Guest to Host File Operations

• To copy a file from the host to a guest, the user must have write permission on the destination.
vmrun -gu guestUser -gp guestPassword copyFileFromHostToGuest Ubuntu16.vmwarevm/
Ubuntu16.vmx ~/img.db /tmp/img.db

• To copy a file from a guest to the host, the user must have read permission on the source file.
vmrun -gu guestUser -gp guestPassword copyFileFromGuestToHost Ubuntu16.vmwarevm/
Ubuntu16.vmx /home/username/addr addr.txt

• To enable shared folders.
vmrun enableSharedFolders Ubuntu16.vmwarevm/Ubuntu16.vmx

• To share a folder on a Mac host with a particular Linux guest.
NOTE
Before sharing folders, you must enable them with the enabledSharedFolders option, or by selecting Enable
Shared Folders in the Sharing Settings panel of the virtual machine. On Linux guests, the /mnt/hgfs
directory is available for sharing, but you can use a different directory for shared folders.

vmrun addSharedFolder Ubuntu16.vmwarevm/Ubuntu16.vmx sharedFolderName ~/Share
• To make a shared folder read‐only or to delete the shared folder.

NOTE
Shared folders are writable by default.

vmrun setSharedFolderState Ubuntu16.vmwarevm/Ubuntu16.vmx sharedFolderName ~/Share
readonly
vmrun removeSharedFolder Ubuntu16.vmwarevm/Ubuntu16.vmx sharedFolderName

NOTE
On Windows Vista and Windows 7 or later guests, only the Administrator account can use
copyFileFromHostToGuest and deleteFileInGuest options to write and delete files in the C:\ and system
folders, or use the createDirectoryInGuest and deleteDirectoryInGuest options to modify system directories.
Regular users, even those with administrator privilege, cannot perform these operations.

Guest Variables and Environment

• From the host, set a guest variable on the virtual machines.
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vmrun writeVariable Win10.vmwarevm/Win10.vmx guestVar vmstartdate 21April2017
• On the guest operating systems, read the guest variable that you just set.

> rpctool.exe "info-get guestinfo.vmstartdate"
$ vmware-rpctool "info-get guestinfo.vmstartdate"

• From the host, set a guest environment variable on a Linux virtual machine and verify by writing the environment
variables into a temporary file.
vmrun writeVariable Ubuntu16.vmwarevm/Ubuntu16.vmx guestEnv LD_LIBRARY_PATH /usr/local/lib

Guest user: root

Guest password:

vmrun runScriptInGuest Ubuntu16.vmwarevm/Ubuntu16.vmx /bin/bash "/usr/bin/env > /tmp/env.out"

Guest user: root

Guest password:

NOTE
No output is sent to the host when you use the runScriptInGuest option with the vmrun command. Find the
output of the command in the /tmp/env.out file on the guest.

• On a Linux guest, determine the IP address and set it in a guest variable.
$ ipaddr=`ifconfig eth0 | grep inet.addr`

$ vmware-rpctool "info-set guestinfo.theip $ipaddr"

• From the host, retrieve the IP address that was just set to the guest.
vmrun readVariable Ubuntu10/Ubuntu10.vmx guestVar theip

General Commands

• List running virtual machines.
vmrun list

Total running VMs: 2

Absolute-path-to-virtual-machine.vmx

Absolute-path-to-virtual-machine.vmx

• Prepare to install VMware Tools.
vmrun installTools Ubuntu16.vmwarevm/Ubuntu16.vmx

The Template Virtual Machine Commands

• Download a VMware Project Photon operating system virtual machine.
vmrun downloadPhotonVM ~

Using vmcli to Control Virtual Machines
You can use the vmcli command-line utility in VMware FusionWorkstation Pro Workstation Player to interact
with the hypervisor from the LinuxmacOS  terminal window or at the Windows command prompt. By using vmcli
commands, you can perform various virtual machine operations like creating new virtual machine or virtual machine
template.

Running the vmcli command-line utility

You can run the vmcli from the LinuxmacOS  terminal window or at the Windows command prompt. You can also create
scripts to run multiple commands.

To run the vmcli command and get the syntax to use the available functionality, run the following command.

vmcli --help
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After you run this command, you receive the following output.

vmcli --help

Usage: vmcli [-v | --version] [<vmx location>] <module> <command> [<args>] [--verbose] [-h | --help] [<vmx lo-

cation>]

Top level arguments:

    -v, --version

        Display the version information.

Global arguments:

    <vmx location>        (required for commands working with VMs)

        Location of the vmx file to work with. Can be the first or last argument on the command line.

    --verbose

        Enable verbose logging.

    -h, --help

        Display the help information

Available modules:

    Chipset

        Chipset options.

    ConfigParams

        Set VM configuration parameters.

    Disk

        Module to perform disk operations.

    Ethernet

        Setup the ethernet configuration in the guest.

    Guest

        guest ops

    HGFS

        HGFS options.

    MKS

        Mouse, keyboard and screen operations.

    Nvme

        Setup NVME ports in the guest.

    Power

        Set the power state of the vm.

    Sata

        Setup SATA ports in the guest.

    Serial

        Setup serial ports in the guest.

    Snapshot

        Snapshot configuration

    Tools

        Tools related configuration.

    VM

        VM related Operations

    VMTemplate

        Create and Deploy vm template

    VProbes

        Setup VProbes in the guest

To learn more about the syntax of each module or operation, for example the Power module, you can run the following
command.

vmcli Power --help
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After you run this command, you receive the following output.

vmcli Power --help

Usage: vmcli [-v | --version] [<vmx location>] Power  [--verbose] [-h | --help] query Start Stop Pause Reset

 Suspend Unpause [<vmx location>]

Top level arguments:

    -v, --version

        Display the version information.

Global arguments:

    <vmx location>        (required for commands working with VMs)

        Location of the vmx file to work with. Can be the first or last argument on the command line.

    --verbose

        Enable verbose logging.

    -h, --help

        Display the help information

Module:

    Power

        Set the power state of the vm.

Arguments available to module "Power":

    query

        Query the power state of the VM.

    Start

        Start the virtual machine.

    Stop

        Stop the virtual machine.

    Pause

        Pause the virtual machine.

    Reset

        Rest the virtual machine.

    Suspend

        Suspend the virtual machine.

    Unpause

        Unpause the virtual machine.

You can also retrieve usage information for a specific operation of any module.

vmcli Power query --help

After you run this command, you receive the following output.

vmcli power query --help

Usage: vmcli [-v | --version] [<vmx location>] Power query  [--verbose] [-h | --help] [-f | --format <2, 1,

 0>] [<vmx location>]

Top level arguments:

    -v, --version

        Display the version information.

Global arguments:

    <vmx location>        (required for commands working with VMs)

        Location of the vmx file to work with. Can be the first or last argument on the command line.

    --verbose

        Enable verbose logging.

    -h, --help

        Display the help information
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Module:

    query

        Query the power state of the VM.

Arguments available to module "query":

    -f, --format <2, 1, 0>

        Sets the format of the output.

Using vmcli to create a template from an existing virtual machine

You can create a virtual machine template from an existing virtual machine. You can later use this template to create a
new virtual machine with the same configuration.

You can use the following syntax.

vmwcli <source vmx path> vmtemplate create  -p <template vmtx path> -n <template name>

Variable Description

source vmx path Path to the source virtual machine vmx from which the template
will be created.

template vmtx path Full path to the new vmtemplate folder along with file name
with the .vmtx extension.
Example: "~/Virtual Machines.localized/
clonevmtest2.vmwarevm/clonevmtest2.vmtx"

template name Name of the tamplate.

Using vmcli to deploy a virtual machine template

You can deploy the VMTemplate that was created by the vmcli command. By using the following syntax, you can create
a new virtual machine from the specified VMTemplate at the same location.

VMTemplate Deploy -p <Full file path of vmtx file of existing VM template>

Using vmcli to create a new virtual machine

You can use the following syntax to create a new virtual machine.

VM Create -n <vm name> -d <path where vm will be created>  -g <guest operating system>

Example:
VM Create -n myVM -d ~/Desktop/ -g windows9-64

Example of creating a virtual machine and attaching an ISO to it

After performing the following steps, you can add a newly created virtual machine to the Virtual Machine Library and then
power the virtual machine on to start the guest installation process by using the ISO file. You can use the syntax from the
following example.

Example:
echo "----creating VM-----"

 

vmcli VM Create -n windowstest -d ~/Desktop/test -g windows9-64

 

vmcli ConfigParams SetEntry displayName "windowstest"  ~/Desktop/test/windowstest.vmx

 

 181



 VMware Fusion Pro 13

 

echo "----create Nvme vmdk related things-----"

 

vmcli nvme SetPresent nvme0 1 ~/Desktop/test/windowstest.vmx

 

vmcli Disk SetBackingInfo nvme0:0 disk windowstest.vmdk 1 ~/Desktop/test/windowstest.vmx

 

vmcli Disk SetPresent nvme0:0 1 ~/Desktop/test/windowstest.vmx

 

echo "----create sata disk for iso mounting-----"

 

vmcli Sata SetPresent sata0 1 ~/Desktop/test/windowstest.vmx

 

vmcli Disk SetBackingInfo sata0:0 cdrom_image ~/Documents/iso/22621.1.220506-1250.ni_release_CLIEN-

T_ENTERPRISES_OEM_x64FRE_en-us.iso 1 ~/Desktop/test/windowstest.vmx

 

vmcli Disk SetPresent sata0:0 1 ~/Desktop/test/windowstest.vmx

 

echo "----create ethernet related things-----"

 

vmcli Ethernet query ~/Desktop/test/windowstest.vmx

 

vmcli Ethernet SetVirtualDevice ethernet0 vmxnet3 ~/Desktop/test/windowstest.vmx

 

vmcli Ethernet SetConnectionType ethernet0 nat ~/Desktop/test/windowstest.vmx

 

vmcli Ethernet SetAddressType ethernet0 generated "" ~/Desktop/test/windowstest.vmx

 

vmcli Ethernet SetLinkStatePropagation ethernet0 true  ~/Desktop/test/windowstest.vmx

 

vmcli Ethernet SetPresent ethernet0 1 ~/Desktop/test/windowstest.vmx

 

vmcli ConfigParams SetEntry  bios.bootOrder "cdrom,hdd" ~/Desktop/test/windowstest.vmx

 

echo "---------Done-------"

Using VMware Fusion REST API
Fusion REST API is available for both Fusion and Fusion Pro and enables you to interact programmatically with the core
VMware hypervisor and virtual machines.

Overview of Fusion REST API

You can send standard GET, PUT, POST, and DELETE requests through HTTP and HTTPS to control configuration and
deployment options. For example, you can use the Fusion REST API to perform power operations. You can perform
network-related operations, such as to create and update virtual NIC configurations and to retrieve IP addresses from the
virtual machine. You can also configure shared folders. Response payloads are delivered in JSON format.

Fusion REST API Considerations

Keep the following considerations in mind when using the Fusion REST API.

• The Fusion REST API service depends on the vmrest process.
• The vmrest service runs as the user who starts it. For example, the sudo vmrest command runs as the root user.
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Use the VMware Fusion REST API Service
You can access the Fusion REST API from a local machine.

1. Install Fusion on your Mac.

2. Before you start the REST API service the first time, set up your credentials.
a) In a terminal window, run the vmrest-C command.
b) Enter a user name and password as prompted.

You do not need to set up credentials when you start the REST API on subsequent occasions.

3. Configure the REST API service for HTTP and HTTPS access.
You can configure the REST API service to provide HTTP or HTTPS access locally.

• Provide HTTP service.

a. In a terminal window, run the vmrest command.
The command returns the IP address and port number from which you can access the HTTP service. The
default IP address is 127.0.0.1:8697.

b. Open a web browser and go to http://address-returned-by-vmrest-command.
c. Click Authorize in the top-right corner of the Fusion API Explorer page.
d. To authenticate, enter the user name and password you configured in 2.

• Provide HTTPS service.

In this situation, when you use the vmrest command to start the REST API service, you must use the -c and -k
options together to specify the certificate and private key.

a. In a terminal window, run a command to generate a certificate and a private key.
The example command that follows, generates a self-signed OpenSSL-based certificate and a private key.
openssl req -x509 -newkey rsa:4096 -keyout fusionapi-key.pem -out fusionapi-
cert.pem -days 365 -nodes

b. To start the Fusion REST API service, run the command that follows. Replace the placeholders with the full path
to the certificate file and the full path to the private key file.
vmrest -c certificate-file -k private-key-file
The command returns the address from which you can access the HTTPS service.

c. Open a web browser and go to https://address-returned-by-vmrest-command.
d. Click Authorize in the top-right corner of the Fusion API Explorer page.
e. To authenticate, enter the user name and password you configured in 2.

Using VMware Fusion REST API Service to Manage Power Options of Encrypted
Virtual Machines
You can power on, power off, suspend, pause, unpause, or retrieve the state of an encrypted virtual machine using the
VMware Fusion REST API service.

You must perform the following steps before using the Fusion REST API services:

• Connect to the IP address from which you can access the HTTP/HTTPS services of Fusion REST API. The default IP
address is 127.0.0.1:8697.

• Authenticate using the credentials you configured for the API service.

 183



 VMware Fusion Pro 13

For more information on how to set the credentials for the Fusion REST API service, see #unique_295

1. After you log in to the Fusion API service page, click VM Power Management from the list of API services.

2. To retrieve the power state of the encrypted virtual machine, click the GET operation, and then perform the following
steps:
a) Under the Parameters section, enter the ID and the encryption password of the virtual machine.
b) Click Try it Out!

The Fusion REST API service returns the power state of the encrypted virtual machine.

3. To manage the power options of the encrypted virtual machine, click the PUT operation, and then perform the following
steps:
a) Under the Parameters section, enter the ID and the encryption password of the virtual machine.
b) Enter one of the following options in the operation field:

• on
• off
• shutdown
• suspend
• pause
• unpause

c) Click Try it Out!
The Fusion REST API service performs the operation you choose for the encrypted virtual machine.

Upgrading Fusion
You can upgrade to a new version of Fusion in several ways.

Use these procedures to upgrade Fusion.

Upgrade Fusion with Autoupdate
Fusion has a built-in software updater that checks for updates to Fusion and VMware Tools and downloads and installs
the updates.

Verify that the Automatically check for updates check box is selected in VMware Fusion > Preferences.

Although Fusion can shut down your running virtual machines as part of this procedure, VMware recommends that you
manually shut down or suspend your virtual machines before you begin.

When the Automatically check for updates check box is selected in VMware Fusion > Preferences, Fusion checks
for updates each time it starts. If Fusion detects a new version, it displays the Software Update window. The Software
Update window has the following options.
Skip This Version

Select this option if you do not want to upgrade to the version described. Fusion ignores this version in any later Autoupdate
checks. If you change your mind later, you can select VMware Fusion > Check for Updates to have Fusion display the
Software Update window again.

Remind Me Later
Fusion closes the Software Update window. The next time Fusion starts, the Software Update window appears.

Download and Install
Fusion downloads the update files to your Mac and installs the updates.

1. In the Software Update window, click Download and Install.
Fusion downloads the update files to your Mac.
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2. At the Ready to install update prompt, shut down any running virtual machines and click Install and Restart.
Fusion downloads the update files to your Mac, displays a progress bar during the installation, and restarts when the
installation is complete.

Upgrade Fusion From a Download
If you have an earlier version of Fusion, you can upgrade to the current version by manually downloading the Fusion disk
image from the VMware Web site.

Verify that all of your virtual machines are shut down and that  is not running.

If you are upgrading Fusion, VMware recommends that you first remove the version of Fusion installed on your Mac. The
process of installing, upgrading, and uninstalling Fusion does not modify existing virtual machines.

1. Drag the previous version of Fusion to the trash.
Fusion is in the Applications folder on your Mac.

2. Download Fusion from the Broadcom Support Portal.
a) Click the Download link and follow the subsequent links for an Electronic Download Distribution.
b) Click the download link and save the application to your Mac.
The Fusion disk image is saved to your default download directory. The filename is VMware-
Fusion-x.x.x-xxxxxx_universal.dmg, where x.x.x is the application version and xxxxxx is the build number
for the download release.

3. Double-click the VMware-Fusion-x.x.x-xxxxxx_universal.dmg file to mount it.

4. Double-click the VMware Fusion icon to copy Fusion to your Mac and start it.

 Upgrading VMware Tools
You can upgrade VMware Tools manually, or you can configure virtual machines to check for and install newer versions of
VMware Tools.

The guest operating system checks the version of VMware Tools when you power on a virtual machine. The status bar of
your virtual machine displays a message when a new version is available.

For vSphere virtual machines,
A newer version of Tools is available for this VM

is displayed when the installed version of VMware Tools is out of date.

In Windows virtual machines, you can set VMware Tools to notify you when an upgrade is available. If this notification
option is enabled, the VMware Tools icon in the Windows taskbar includes a yellow caution icon when a VMware Tools
upgrade is available.

To install a VMware Tools upgrade, you can use the same procedure that you used for installing VMware Tools the first
time. Upgrading VMware Tools means installing a new version.

For Windows and Linux guest operating systems, you can configure the virtual machine to automatically upgrade VMware
Tools. Although the version check is performed when you power on the virtual machine, on Windows guest operating
systems, the automatic upgrade occurs when you power off or restart the virtual machine. The status bar displays the
message Installing VMware Tools ... when an upgrade is in progress. The procedure is mentioned below.

NOTE

Upgrading VMware Tools on Windows guest operation systems automatically installs the WDDM graphics
drivers. The WDDM graphics driver allows the sleep mode available in guest OS power settings to adjust
the sleep options. For example, you can use the sleep mode setting Change when the computer sleeps to
configure your guest OS to automatically go to sleep mode after a certain time or prevent your guest OS from
automatically switching to sleep mode after being idle for some time.
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For vSphere virtual machines, you can use one of the following processes to upgrade multiple virtual machines at the
same time.

You can use one of the following processes to upgrade multiple virtual machines at the same time.

• Log in to vCenter Server, select a host or cluster, and on the Virtual Machines tab specify the virtual machines on
which to perform a VMware Tools upgrade.

• Use  to perform an orchestrated upgrade of virtual machines at the folder or data center level.

Some features in a particular release of a VMware product might depend on installing or upgrading to the version of
VMware Tools included in that release. Upgrading to the latest version of VMware Tools is not always necessary, however,
VMware highly recommends that you upgrade to the most updated version of the VMware Tools. Newer versions of
VMware Tools are compatible with several ESXi host versions. To avoid unnecessary upgrades, evaluate whether the
added features and capabilities are necessary for your environment. See Hardware Features Available with Virtual
Machine Compatibility Settings. However, VMware highly recommends installing and using the latest version of VMware
Tools.xy

Some features in a particular release of a VMware product might depend on installing or upgrading to the version of
VMware Tools included in that release. Upgrading to the latest version of VMware Tools is not always necessary. Newer
versions of VMware Tools are compatible with several host versions. To avoid unnecessary upgrades, evaluate whether
the added features and capabilities are necessary for your environment.

Table 12: Virtual Machine Compatibility Options

Compatibility Description

ESXi 7.0 Update 1 and later This virtual machine (hardware version 18) is compatible with ESXi 7.0 Update 1 and later.
ESXi 7.0 and later This virtual machine (hardware version 17) is compatible with ESXi 7.0 and ESXi 7.0 Update 1.
ESXi 6.7 Update 2 and later This virtual machine (hardware version 15) is compatible with ESXi 6.7 Update 2, ESXi 6.7 Update

3, ESXi 7.0, and ESXi 7.0 Update 1.
ESXi 6.7 and later This virtual machine (hardware version 14) is compatible with ESXi 6.7, ESXi 6.7 Update 2, ESXi

6.7 Update 3, ESXi 7.0, and ESXi 7.0 Update 1.
ESXi 6.5 and later This virtual machine (hardware version 13) is compatible with ESXi 6.5, ESXi 6.7, ESXi 6.7 Update

2, ESXi 6.7 Update 3, ESXi 7.0, and ESXi 7.0 Update 1.
ESXi 6.0 and later This virtual machine (hardware version 11) is compatible with ESXi 6.0, ESXi 6.5, ESXi 6.7, ESXi

6.7 Update 2, ESXi 6.7 Update 3, ESXi 7.0, and ESXi 7.0 Update 1.
ESXi 5.5 and later This virtual machine (hardware version 10) is compatible with ESXi 5.5, ESXi 6.0, ESXi 6.5, ESXi

6.7, ESXi 6.7 Update 2, ESXi 6.7 Update 3, ESXi 7.0, and ESXi 7.0 Update 1.
ESXi 5.1 and later This virtual machine (hardware version 9) is compatible with ESXi 5.1, ESXi 5.5, ESXi 6.0, ESXi

6.5, ESXi 6.7, ESXi 6.7 Update 2, ESXi 6.7 Update 3, ESXi 7.0, and ESXi 7.0 Update 1.
ESXi 5.0 and later This virtual machine (hardware version 8) is compatible with ESXi 5.0, ESXi 5.1, ESXi 5.5, ESXi

6.0, ESXi 6.5, ESXi 6.7, ESXi 6.7 Update 2, ESXi 6.7 Update 3, ESXi 7.0, and ESXi 7.0 Update 1.
ESX/ESXi 4.x and later This virtual machine (hardware version 7) is compatible with ESX/ESXi 4.x, ESXi 5.0, ESXi 5.1,

ESXi 5.5, ESXi 6.0, ESXi 6.5, ESXi 6.7, ESXi 6.7 Update 2, ESXi 6.7 Update 3, ESXi 7.0, and
ESXi 7.0 Update 1.

ESX/ESXi 3.5 and later This virtual machine (hardware version 4) is compatible with ESX/ESXi 3.5, ESX/ESXi 4.x, ESXi
5.1, ESXi 5.5, ESXi 6.0, ESXi 6.5, ESXi 6.7, ESXi 6.7 Update 2, ESXi 6.7 Update 3, ESXi 7.0, and
ESXi 7.0 Update 1. It is also compatible with VMware Server 1.0 and later. ESXi 5.0 does not allow
creation of virtual machines with ESX/ESXi 3.5 and later compatibility, but you can run such virtual
machines if they were created on a host with different compatibility.

For more information, see the VMware Compatibility Guide at http://www.vmware.com/resources/compatibility.
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Uninstalling Fusion
Uninstalling Fusion does not modify existing virtual machines.

Uninstall Fusion
You can uninstall Fusion from the Applications folder.

Power off or suspend all running virtual machines and quit Fusion.

Drag the VMware Fusion application from the Applications folder on your Mac to the trash.

Force Virtual Machine Processes to Quit
If your computer prevents you from upgrading or uninstalling Fusion, you might have to use the Mac Activity Monitor to
correct the problem.

In rare circumstances, the operating system in a virtual machine can quit unexpectedly in a way that leaves some virtual
machine processes running. This situation can prevent you from upgrading or uninstalling Fusion. In this case, the
installation or uninstallation Assistant might display a message that indicates that you cannot install or uninstall Fusion. To
work around this problem, you can use the Mac Activity Monitor to force virtual machine processes to quit.

1. In the Finder, select Applications > Utilities and double-click Activity Monitor to open the Activity Monitor.

2. Select All Processes.

3. In the Process Name column, select VMware Fusion.

4. Select View > Quit Process.

5. In the Quit Process window, select Force Quit.
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Documentation Legal Notice
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